Announcement

Collapse
No announcement yet.

Raise or Lower Setpoints on Zwave T-Stat - Working!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Raise or Lower Setpoints on Zwave T-Stat - Working!

    The title says it all....Is there a way to raise or lower the setpoints from HS on a zwave t-stat? I am using a Wayne Dalton unit.

    Thank you.

  • #2
    Try this in a vb.net script (ie .vb extention):
    Code:
    Dim pi As Object 
    Dim temp as Double
    
    pi = hs.Plugin("ZWave Thermostats") 
    pi.CmdSetCool 1, 75
    The call can be either:
    CmdSetHeat
    CmdSetCool
    -Rupp
    sigpic

    Comment


    • #3
      Thank you, but I got this error when I first ran it. I created it in HS.


      9/22/2010 8:46:27 AM Event Running script in background: Zwave Cool Temp Up
      9/22/2010 8:46:27 AM Error Running script, script run or compile error in file: Zwave Cool Temp Up1025:Expected end of statement in line 3 More info: Exception from HRESULT: 0x800A0401

      I then edited the file to add the .vb extension, and I get this:

      9/22/2010 8:53:10 AM Event Running script in background: Zwave Cool Temp Up.vb
      9/22/2010 8:53:11 AM Error Script compile error: Method arguments must be enclosed in parentheses.on line 20
      9/22/2010 8:53:11 AM SCR Option Strict Offimports Schedulerimports SystemPublic Module scriptcode3#Region "Automatically generated code, do not modify"'Automatically generated code, do not modify'Event Sources Begin Public WithEvents hs As Scheduler.hsapplication Public WithEvents hsp As scheduler.hsp Public WithEvents hssystem As scheduler.phone0'Event Sources End'End of automatically generated code#End RegionSub Main()Dim pi As Object Dim temp as Doublepi = hs.Plugin("ZWave Thermostats") pi.CmdSetCool 1, 75End Sub()End Module

      Comment


      • #4
        Try changing this:
        pi.CmdSetCool 1, 75

        to:
        pi.CmdSetCool(1, 75)
        -Rupp
        sigpic

        Comment


        • #5
          Still not working. Got this error:

          9/22/2010 2:46:02 PM Error Running script, script run or compile error in file: Zwave Cool Temp Up 11025:Expected end of statement in line 3 More info: Exception from HRESULT: 0x800A0401

          Comment


          • #6
            Originally posted by sonypoolplr View Post
            Still not working. Got this error:

            9/22/2010 2:46:02 PM Error Running script, script run or compile error in file: Zwave Cool Temp Up 11025:Expected end of statement in line 3 More info: Exception from HRESULT: 0x800A0401
            Did you make this a .net script?
            -Rupp
            sigpic

            Comment


            • #7
              Rupp - he needs to wrap your code with:

              Sub Main(ByVal parms as Object)
              End Sub
              HS3Pro Running on a Raspberry Pi3
              68 Z-Wave Nodes, 174 Events, 326 Devices
              UPB modules via OMNI plugin/panel
              Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
              HSTouch Clients: 3 Android, 1 Joggler

              Comment


              • #8
                I had it created in whatever format HS uses, as I created the script from inside HS. I did have

                Sub Main
                End Sub

                But not the Sub Main(ByVal parms as Object). I will try that.

                Edit: Tried it this way and got this error:
                9/22/2010 10:31:17 PM Error Running script, script run or compile error in file: Zwave Cool Temp Up 11006:Expected ')' in line 1 More info: Exception from HRESULT: 0x800A03EE
                Last edited by sonypoolplr; September 22nd, 2010, 09:32 PM.

                Comment


                • #9
                  Originally posted by rmasonjr View Post
                  Rupp - he needs to wrap your code with:

                  Sub Main(ByVal parms as Object)
                  End Sub
                  Yea, I shouldn't have assumed he would add that.

                  I can't test this here as I do not have a Z-Wave stat but this should work:

                  Code:
                  Sub Main(ByVal parms as Object)
                  Dim pi As Object 
                  Dim temp as Double
                  
                  pi = hs.Plugin("ZWave Thermostats") 
                  pi.CmdSetCool (1, 75)
                  End Sub
                  -Rupp
                  sigpic

                  Comment


                  • #10
                    Just tried the new script and it didn't work. Got this error:

                    9/24/2010 4:14:10 AM Error Running script, script run or compile error in file: Zwave Cool Temp Up 11006:Expected ')' in line 1 More info: Exception from HRESULT: 0x800A03EE

                    Comment


                    • #11
                      Originally posted by sonypoolplr View Post
                      Just tried the new script and it didn't work. Got this error:

                      9/24/2010 4:14:10 AM Error Running script, script run or compile error in file: Zwave Cool Temp Up 11006:Expected ')' in line 1 More info: Exception from HRESULT: 0x800A03EE
                      How are you running the script? I've never seen an error reported in line 1 in a .net script. HomeSeer adds 13 lines of includes to the file so this would indicate a HomeSeer issue.
                      -Rupp
                      sigpic

                      Comment


                      • #12
                        I have the script set up in an event that is manually triggered.


                        Thanks.

                        Comment


                        • #13
                          Originally posted by Rupp View Post
                          How are you running the script? I've never seen an error reported in line 1 in a .net script. HomeSeer adds 13 lines of includes to the file so this would indicate a HomeSeer issue.
                          Is this something that I should put in a help desk issue about?

                          Comment


                          • #14
                            Originally posted by sonypoolplr View Post
                            The title says it all....Is there a way to raise or lower the setpoints from HS on a zwave t-stat? I am using a Wayne Dalton unit.

                            Thank you.
                            Is there a reason you aren't just doing this with an event? You just need to select the z-wave thermostat action. Or are you doing something special?

                            Barry

                            Comment


                            • #15
                              The thermostat actions doesn't have a raise or lower setpoint, just a set temp, set mode, or set fan mode.

                              Unless you are seeing something I am not.

                              Thanks.

                              Comment

                              Working...
                              X