Announcement

Collapse
No announcement yet.

"Z-Wave Thermostat" device type is invisible

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Rupp
    replied
    Originally posted by Dafunktyfunk View Post
    Now that this is out of Beta, perhaps we can move or copy this documentation to the forum that is not in the beta section. SInce I dont want any betas, usually, i stay out of the beta section. Perhaps other users do the same.
    It would take weeks to parse all the data that has been posted in the beta forums for the last year. The release notes are in the 2.5.x release thread. This may or may not (most likely not) include all the notes that were in the betas.

    Leave a comment:


  • Dafunktyfunk
    replied
    Originally posted by IKUS View Post
    Could you point me in the direction of that explanation?
    Now that this is out of Beta, perhaps we can move or copy this documentation to the forum that is not in the beta section. SInce I dont want any betas, usually, i stay out of the beta section. Perhaps other users do the same.

    Leave a comment:


  • IKUS
    replied
    Originally posted by Rupp View Post
    Yes, it's in the updater for older HS installs, and if you disable it HS will automatically re-enable it for the latest versions of HS. Rick explained most of this in the recent beta treads.
    Could you point me in the direction of that explanation?

    Leave a comment:


  • Rupp
    replied
    Originally posted by IKUS View Post
    More documentation from the current 2.5.0.0 helpfile that indicates .THM scripts are the means to get to ControlThermostat.

    http://<your-hs-hostname-or-ip-and-port>/WebHelp/scripting/devices/scripting_devices_controlthermostat.htm
    Yes, this is trued for all stats that still have thermostat scripts available. As far as I know no scripts still exits and all should be using a plugin. But hey, if you want to write a Z-Wave script go for it but I'm not sure it will be all that easy.

    Leave a comment:


  • Rupp
    replied
    Originally posted by IKUS View Post
    Also, why is the Z-Wave Thermostat Plugin still available on the Update page if it's now built in? Is it for older installs? There's no HS server version requirement mentioned on the plugin and it didn't automatically get deactivated when I updated to HS2.5.0.0.
    Yes, it's in the updater for older HS installs, and if you disable it HS will automatically re-enable it for the latest versions of HS. Rick explained most of this in the recent beta treads.

    Leave a comment:


  • IKUS
    replied
    More documentation from the current 2.5.0.0 helpfile that indicates .THM scripts are the means to get to ControlThermostat.

    http://<your-hs-hostname-or-ip-and-port>/WebHelp/scripting/devices/scripting_devices_controlthermostat.htm

    Leave a comment:


  • IKUS
    replied
    Also, why is the Z-Wave Thermostat Plugin still available on the Update page if it's now built in? Is it for older installs? There's no HS server version requirement mentioned on the plugin and it didn't automatically get deactivated when I updated to HS2.5.0.0.

    Leave a comment:


  • IKUS
    replied
    Originally posted by Rupp View Post
    There are no Z-Wave thermostat scripts any longer. The Z-Wave thermostat support is now built into HomeSeer.
    Why are they still documented in the 2.5.0.0 helpfile? Take a look at the helpfile documentation at http://<your-hs-hostname-or-ip-and-port>/WebHelp/confighomeseer/devicetypes/popups/config_devicetypes_thermostat.htm

    I understand that Z-Wave thermostats are supported directly by HS, but according to the documentation, scripting of thermostats via hs.ControlThermostat is ONLY available using the included thermostat scripts which are connected to thermostat device TYPES. In addition, if there are no longer any thermostat scripts, why is it that when you add a thermostat device type, the script drop down still appears and is still populated by the .thm script files? Try it.
    Last edited by IKUS; December 29th, 2010, 04:34 PM.

    Leave a comment:


  • Rupp
    replied
    There are no Z-Wave thermostat scripts any longer. The Z-Wave thermostat support is now built into HomeSeer.

    Leave a comment:


  • IKUS
    replied
    Originally posted by Rupp View Post
    You can't change the properties on a Z-Wave stat as this plugin is built into HS and can't be changed.
    Not true. Note, I'm referring to the "Z-Wave Thermostat" device TYPE not the thermostat device itself. The "Z-Wave Thermostat" device type lets you select one of the included .thm thermostat scripts which is required if you want to use hs.ControlThermostat functionality.

    Under Setup / Device Types, try adding a new device type by selecting "New Device Type" from the Device Type dropdown. Check the "Thermostat Device" checkbox and then click "Check Changes" and you'll see a Thermostat Script dropdown appear. I should be able to simply select my existing "Z-Wave Thermostat" device type so that I can change the script but "Z-Wave Thermostat" doesn't appear here anymore...I can't add it either because it says it's already there.

    Leave a comment:


  • Rupp
    replied
    You can't change the properties on a Z-Wave stat as this plugin is built into HS and can't be changed.

    Leave a comment:


  • IKUS
    started a topic "Z-Wave Thermostat" device type is invisible

    "Z-Wave Thermostat" device type is invisible

    I posted this in the beta forum a while back but got nothin, so here it is again.

    In short: under Setup / Device Types, the dropdown list does not show "Z-Wave Thermostat" but it does seem to exist, as evidenced by the defined Type of my thermostat on the Status page and the fact that when I try to add a new device type called "Z-Wave Thermostat" I get an error that says this is a duplicate device type. How can I get device type "Z-Wave Thermostat" to be visible on the list again? I need to edit it's properties.

    Long version: At some point in the 2.4 series of betas my thermostat events that made use of the hs.ControlThermostat function stopped working but I wasn't too concerned or motivated to fix it since the weather has been so mild where I live. Now that 2.5 is final and it's beginning to get a bit chilly I'm trying to get this fixed. Since I removed and re-added my zwave thermostat at one point during the beta upgrades, I'm assuming that the correct .thm script didn't get associated with my thermostat again. I'm trying to fix this by editing the "Z-Wave Thermostat" device type but for some reason it doesn't show up, even though under the Device Type column on the status screen my thermostat is defined as a "Z-Wave Thermostat" type. I tried to add "Z-Wave Thermostat" as a new device type but I got an error saying that it was a duplicate...as if it already exists. I then added a second device type called "Z-Wave Thermostat2" which I was going to attempt to associate with the correct .thm script but it too does not show on the drop down list to select. (I also can't add it again without getting a duplicate device type error message). I can remove (visible) entries from the Device Types list and edit existing (visible) entries just fine. I just can't get to the invisible ones... "Z-Wave Thermostat" and now also "Z-Wave Thermostat2". Any ideas?
Working...
X