Announcement

Collapse
No announcement yet.

Status Tracking & Animated GIFs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Status Tracking & Animated GIFs

    I have a virtual device that among other gifs also has animated gifs. Everything works find on the windows client. However, on my two Android devices and iPad the gifs are not animated. When I just have an image with the animated gif it works. It just doesn't work when the animated gif is a status. Has somebody else experienced this.

    #2
    Are you using status tracking?
    Thats how I got it working on Android. Works perfectly.

    Otherwise you can wrap it into an HTML page that just displays the graph image;
    ​​​See this thread, post #20 and following.

    https://forums.homeseer.com/forum/le...image?t=153373

    Hope this helps,
    ​​​​​​

    Comment


      #3
      Yes, I am using status tracking and define which image to show via the StatusImages property. Initially I used a Text field which didn't work. I changed it to an Image field which made it work on the Windows Client but it still doesn't work on the Android devices. What type of control do you use?

      Comment


        #4
        Well, I finally figures out what is going on. When I started I just had static images and my preferred format is png. Then I expanded the functionality and added animated gifs. It turns out HSTouch doesn't like it when you mix png and gif files so it shows the animated gif files just as static.

        But now I am facing another wired problem. I have 4 different images that track the same virtual device but use different status images using the property StatusImages. For some reason all 4 of the images show the status image of the virtual device rather than the status image I define in HSTouch through that StatusImages property. It works as expected on the Windows client but not on the Android clients. The only change I made is using MatchValue rather than a mix of MatchValue and MatchStatus. This worked before....

        Comment


          #5
          I dont use HS status images, i pull images from my own image folder. Can you share screenshots of your setup?

          Comment


            #6
            This may or may not be involved with your problem, but I discovered that Android has a problem with images with the same name but in different directories (when the image is on the server). In other words, "../contemporary/on.png" is confused with "../classic/on.png". To avoid that problem, I copied (on the server) one of those on.png files to a different, unique name (such as "newon.png").

            Comment


              #7
              123qweasd Below are some screenshots for the properties, what I set for StatusTrackingNormal and StatusImages. It seems HSTouch ignores the status images and just uses the image associated with the status of the device I am tracking (Location). Again, this works fine on the Windows Client, i.e. the Windows Client is using the status images but my Android devices (and even iPad) ignore the status images I defined and show the image of the device.

              Click image for larger version

Name:	Properties.png
Views:	78
Size:	7.4 KB
ID:	1398065Click image for larger version

Name:	Tracking.png
Views:	46
Size:	10.2 KB
ID:	1398066Click image for larger version

Name:	StatusImages.png
Views:	70
Size:	15.2 KB
ID:	1398067

              Comment


                #8
                your configuration seems correct; I would try deleting the image of the device for testing;
                Also If this element was copied, it sometimes create issues, so I would suggest deleting the status images and recreate them.

                Comment

                Working...
                X