Announcement

Collapse
No announcement yet.

New HSTouch Actions!

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Originally posted by rjh View Post
    I added this to the HSTouch client, the next update will have it.
    I don't see it in the .54 update. Is it there?

    Comment


      #17
      I'd wait, there were some people (myself included) that the .54 client causes some issues.

      I'm hoping .55 has the fix (there are helpdesk tickets in as far as I know).

      Right now, I went back to the .48 client. It wasn't hurting my HSTouch screens...so I might just stay...unless some REALLY new / neat feature gets added.

      --Dan
      Tasker, to a person who does Homeautomation...is like walking up to a Crack Treatment facility with a truck full of 3lb bags of crack. Then for each person that walks in and out smack them in the face with an open bag.

      Comment


        #18
        Thanks. I walked away from HSTouch six months ago out of frustration. I came back hoping some of the bugs had been fixed.

        I've been working on getting "Simulated press of an element" to work on an HS Touch client computer for a day now.

        Is that one of the .54 issues that you know of? I'm trying to figure out if it's me or HS.

        Thanks again.

        Comment


          #19
          Originally posted by auger66 View Post
          Thanks. I walked away from HSTouch six months ago out of frustration. I came back hoping some of the bugs had been fixed.

          I've been working on getting "Simulated press of an element" to work on an HS Touch client computer for a day now.

          Is that one of the .54 issues that you know of? I'm trying to figure out if it's me or HS.

          Thanks again.
          This caught me out before and may help you (or you may have already thought about it, in that case sorry). The simulate press does just that - presses the button, it does not release that press until you send another release command (which is another action - I sent the release after a 1sec delay).

          This is particularly important if what you are pressing uses ActionsWhenReleased rather than ActionsWhenPressed, as with the former and you send the simulated press you never send the release, its only after you send the release that the action associated with that element triggers.

          If not what trouble are you having?

          Comment


            #20
            Please don't apologize for trying to help. I need all I can get! I've tried it both ways--press and release.

            I'm trying to turn the client monitor on from an ISY device trigger by "launch application" the "monitors.exe" program. I created a visible button for testing purposes. It works fine if I physically press the button on the client. I read on other posts that the path wasn't working so I tried it in the windows/system32 folder--no change.

            To eliminate the variable of the "monitors.exe" program, I tried a light button on my design--a simple toggle on/off. The "Simulate press" didn't work on the light, either.

            It's like the "Simulate press (or release) of a button" is not going to the client at all. I'm at a loss.

            I'll post the question on the ISY plug-in forum. A buggin' the pluggin' is the only thing I can think of now.

            Comment


              #21
              Quite possibly a bug then...do any of the other actions work? I was using the simulate press/release action on release .50 (IIRC) and it seemed to work fine, possibly downgrade/use another client? (there was a standalone client knocking about a couple of months ago that did not require any installation, could be worth a go just to see if its an issue with the newer client)

              Comment

              Working...
              X