Announcement

Collapse
No announcement yet.

How do you use a Drop List

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    How do you use a Drop List

    How do you make a Drop List set the value of a HomeSeer device? I enter the List_Values and List_Labels and that works fine, until you set Status Tracking to a specific device - then the drop list then becomes blank. (???) It says, "The element you selected supports the display of multiple status/value items, so it will also be used for control of the device or item."

    I read where you can have the value passed to a script and manipulate it that way too, but I need many dropdown lists to control several devices and don't want to write a whole bunch of scripts just to set the device value. Anyone know how to have the value selected in the Drop List to set the value of a device in HomeSeer?

    #2
    Bump - Anyone know how to use a drop-list to set the value of a device? (See above)

    Comment


      #3
      HST list box ussage

      CJ
      Take a look at this sticky
      http://board.homeseer.com/showthread.php?t=134702

      The only way I could get it to work is you set the values that you want in the device as documented in the sticky and assosiate the device in HST. When HST loads it loads the dropdown and then they track each other. The only drawback is HST apears to only load the list on startup so you can not have dynamic lists.

      Here is one I use for my Sprinkler interface

      Public Sub populate(ByVal pParms As Object)

      'this sub is to populate the device that is linked into the Hstouch schedule list box
      hs.DeviceValuesAdd("J20", "Aormal Summer 1" & Chr(2) & "1" & Chr(1) & "PlaySchedule 2" & Chr(2) & "2" & Chr(1) & "Quick all zone test 3" & Chr(2) & "3" & Chr(1) & "All Zones 15 Min 4" & Chr(2) & "4", True)

      'hs.DeviceValuesAdd("J20", "My On" & Chr(2) & "1" & Chr(1) & "My Off" & Chr(2) & "2", True)





      Originally posted by CJVann View Post
      Bump - Anyone know how to use a drop-list to set the value of a device? (See above)

      Comment


        #4
        Ah, so "List_Values" and "List_Labels" in Drop Lists don't work for you either. All I was trying to do was select a number in a drop list to set a device's value - Like selecting 10 on the drop list and doing a hs.SetDeviceValue "A1", 10. I guess I could write scripts for everything, but it seems like HST should do it for you. Thanks for the reply!

        Comment


          #5
          I assume if you changed the words to numbers it would accomplish what you want without a script.

          Originally posted by CJVann View Post
          Ah, so "List_Values" and "List_Labels" in Drop Lists don't work for you either. All I was trying to do was select a number in a drop list to set a device's value - Like selecting 10 on the drop list and doing a hs.SetDeviceValue "A1", 10. I guess I could write scripts for everything, but it seems like HST should do it for you. Thanks for the reply!

          Comment


            #6
            I am able to follow the instructions in the Sticky. i can create steps 1, 3 and 4. but i am NOT able to complete step 2: assign G1 device to a listbox element or a droplist element. when i click on the button for Status Tracking, a popup form shows the message: "The element you selected supports the display of multiple status/value items, so it will also be used for control of the device or item". . is there another way to set the Status Tracking ?

            Comment


              #7
              Having the same issue here. Drop list (and list box) seem to be broken and have the device selection drop down grayed out in the Status Tracking settings and has that message in large bold font above it.

              All I want to do is specify some numerical values and human-friendly strings. When the user picks a string off the list, use the numerical value to set the state of an HS device.
              Doesn't seem like this should be so difficult.

              Originally posted by Heychristian View Post
              I am able to follow the instructions in the Sticky. i can create steps 1, 3 and 4. but i am NOT able to complete step 2: assign G1 device to a listbox element or a droplist element. when i click on the button for Status Tracking, a popup form shows the message: "The element you selected supports the display of multiple status/value items, so it will also be used for control of the device or item". . is there another way to set the Status Tracking ?

              Comment


                #8
                I emailed support@homeseer.com and they replied "I have logged this bug with an engineer, though I do not have a time frame for a resolution."

                Comment


                  #9
                  What type of client are you using? There seem to be other problems with Andorid clients and drop down boxes, like the font and background colors (and highlight colors) not working correctly.

                  I am able to use a drop down box to control a Virtual Switch. Perhaps that might be a workaround, have the Virtual Switch be controlled by HS Touch, which in turn controls the real device? Anyway, try an experiment with a Virtual Switch and see if that works for you.

                  Comment


                    #10
                    At least in my case I'm just using the Windows client but I don't even get that far. Even within the Designer I get no way to even pick an HS device. The dialog for the StatusTracker properties has the dropdown list to pick the device grayed out and disabled so there is no way to even pick an object to map to the dropdown list object on the page. Same is true for the List Box UI element. Everything else seems to work fine in Designer as far as picking HS devices to map to UI elements. I created a simple virtual device with a dropdown range on the HS3 system but the Designer continues to not allow me to pick any device. I've attached a screenshot of what the StatusTracker dialog appears for me. Click image for larger version

Name:	Capture.PNG
Views:	305
Size:	27.0 KB
ID:	1300916

                    What version of the Designer are you running?

                    Originally posted by aa6vh View Post
                    What type of client are you using? There seem to be other problems with Andorid clients and drop down boxes, like the font and background colors (and highlight colors) not working correctly.

                    I am able to use a drop down box to control a Virtual Switch. Perhaps that might be a workaround, have the Virtual Switch be controlled by HS Touch, which in turn controls the real device? Anyway, try an experiment with a Virtual Switch and see if that works for you.

                    Comment


                      #11
                      Originally posted by XboxMeister View Post

                      What version of the Designer are you running?
                      I wont be able to access my system that has Designer installed until Friday, but I installed the HS3 Designer last November, so it is fairly recent. Will get the exact version on Friday. I will also check then for the exact settings I used when setting up that Touch object.

                      I did not stay with the drop down boxes for long due to my other problems with fonts and backgrounds, as a List Box is more readable for me.

                      I do use the "Use Value" option. The contents of the list box uses the labels from the Virtual switch's value-label list (and the list is updated if/when I add new value-label pairs). Note that you will not see that list in the designer, only on a running client (true for me on both a Windows Client and on Android).

                      Comment


                        #12
                        No problem. Whenever you can get it would be great. I will try to remember to roll mine back a few versions to see if it changes. As you can see in the pic I posted, I don't even have a choice about whether to pick "Use Value" or not. It is the only control active on the page. Also when I manually put in name/value pairs into the Designer if I click the dropdown in the Designer, it quickly flashes the list of strings. But if I run it in the Windows Client, it says "Nothing" in the dropdown box and none of the options I manually entered are shown.

                        Originally posted by aa6vh View Post

                        I wont be able to access my system that has Designer installed until Friday, but I installed the HS3 Designer last November, so it is fairly recent. Will get the exact version on Friday. I will also check then for the exact settings I used when setting up that Touch object.

                        I did not stay with the drop down boxes for long due to my other problems with fonts and backgrounds, as a List Box is more readable for me.

                        I do use the "Use Value" option. The contents of the list box uses the labels from the Virtual switch's value-label list (and the list is updated if/when I add new value-label pairs). Note that you will not see that list in the designer, only on a running client (true for me on both a Windows Client and on Android).

                        Comment


                          #13
                          Originally posted by XboxMeister View Post
                          No problem. Whenever you can get it would be great. I will try to remember to roll mine back a few versions to see if it changes. As you can see in the pic I posted, I don't even have a choice about whether to pick "Use Value" or not. It is the only control active on the page. Also when I manually put in name/value pairs into the Designer if I click the dropdown in the Designer, it quickly flashes the list of strings. But if I run it in the Windows Client, it says "Nothing" in the dropdown box and none of the options I manually entered are shown.
                          Just a point of interest - I do not put any value-label pairs in using the designer. All of my value-label pairs are entered for the virtual switch via Homeseer itself.

                          Maybe that is the problem?

                          Comment


                            #14
                            No I have tried it either way. No value/label pairs gets me exactly the same thing in the StatusTracker dialog.

                            Originally posted by aa6vh View Post

                            Just a point of interest - I do not put any value-label pairs in using the designer. All of my value-label pairs are entered for the virtual switch via Homeseer itself.

                            Maybe that is the problem?

                            Comment


                              #15
                              Originally posted by XboxMeister View Post
                              No I have tried it either way. No value/label pairs gets me exactly the same thing in the StatusTracker dialog.
                              Here is the information on how I set my system up:

                              Homeseer Version: 3.0.0.345 (Windows)
                              HS3 Touch: 3.0.56

                              Virtual Switch (used to specify Hue light color):
                              Status Only Device: False
                              User Access: Any
                              Dimmable: False
                              Supports Status: False
                              value - label pairs:
                              0 Off
                              1 Blue
                              2 Cyan
                              (and so forth)


                              List box Object in Designer:

                              Action when selected: Nothing
                              lst_labels: Blank
                              lst_values: Blank
                              Status Tracking: HueColor (Name of virtual switch)
                              Normal Association Type: Homeseer Devices
                              Homeseer Devices: Utility Virtual HueColor (Room, etc of virtual switch)
                              Check boxes: Use Value (Other checkboxes grayed out)
                              Value Modification: No modification

                              My other list boxes are setup similiar.

                              Hope this helps!

                              Comment

                              Working...
                              X