Announcement

Collapse
No announcement yet.

HSTouch won't connect - Fixed!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    HSTouch won't connect - Fixed!

    I powered down my HS machine today and turned it back on. HS started up just fine. HSTouch won't connect even when running it on the machine running HS.

    HS version HSPro 2.5.0.1
    HSTouch Server 1.0.0.33
    HS Designer 1.0.0.54

    I can't get HS Designer to connect either. I've tried restarting the plugin, no luck. I've disabled Windows firewall which has an exception for 10200 and that didn't help. No anti-virus software running on the HS machine.

    Any ideas?

    #2
    try and check to see if your IP address has changed for some reason, only thing I can think of at the moment...

    Comment


      #3
      verified that but good suggestion. I can still get to the HS web interface from other PC's on the network. Also verified username/password in HSTouch.

      Comment


        #4
        Any errors in the HomeSeer log file when you start HS up?
        -Rupp
        sigpic

        Comment


          #5
          Originally posted by jabrans View Post
          I powered down my HS machine today and turned it back on. HS started up just fine. HSTouch won't connect even when running it on the machine running HS.

          HS version HSPro 2.5.0.1
          HSTouch Server 1.0.0.33
          HS Designer 1.0.0.54

          I can't get HS Designer to connect either. I've tried restarting the plugin, no luck. I've disabled Windows firewall which has an exception for 10200 and that didn't help. No anti-virus software running on the HS machine.

          Any ideas?
          I had some similar problems which appeared to resolve after running the 2.5.0.5 updater.

          Comment


            #6
            When you install the plug-in Windows may not always open the 10200 port for you. I had this problem. You have to manualy open the port. I'll post a how to in the morning.

            Comment


              #7
              Rupp - No errors in the log file, HSTouch server started up just fine.

              I rebooted my HS machine and now the clients can connect again, local and remote. That's the first time I've seen this happen and restarting HS didn't fix the probelm. Had to reboot the PC.

              Comment


                #8
                I've been struggling with this for some time. Settings looked correct and netstat looked like the port was working correct.

                But wasn't untill I manually opened 10200 that it started working. Windows 10:
                1. Navigate to Control Panel, System and Security and Windows Firewall.
                2. Select Advanced settings and highlight Inbound Rules in the left pane.
                3. Right click Inbound Rules and select New Rule.
                4. Add port 10200 and click Next.
                5. Add the protocol (TCP) and the port number 10200 into the next window and click Next.
                6. Select Allow the connection in the next window and hit Next.
                7. Select the network type as you see fit and click Next.
                8. Name the rule something meaningful and click Finish.
                I was uncertain which port to use, since there is some different ports mentioned in the setup part of HS. But all threads mention 10200 which turned out to be correct. Just needed manually opening.

                Comment


                  #9
                  The port HSTouch is using is set in the Settings for each Server in the phone app. 10200 is the default.
                  Karl S
                  HS4Pro on Windows 10
                  242 Devices
                  56 Z-Wave Nodes
                  37 Events
                  HSTouch Clients: 3 Android, 1 iOS
                  Google Home: 3 Mini units 1 display

                  Comment

                  Working...
                  X