Announcement

Collapse
No announcement yet.

Schlage lock questions/assistance.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #46
    Try
    dim sr as System.IO.StreamReader = New System.IO.StreamReader(hs.GetAppPath & FNAME)
    -Rupp
    sigpic

    Comment


      #47
      Originally posted by Rupp View Post
      Try
      dim sr as System.IO.StreamReader = New System.IO.StreamReader(hs.GetAppPath & FNAME)
      Thanks Rupp,

      The dim command is earlier in the script. For the whole script, see Post 2 in this thread.

      Thanks
      Al
      HS 3.0.0.548: 1990 Devices 1172 Events
      Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

      Comment


        #48
        I'm still running my lock in HS2, so I havent even converted this script over to HS3 just yet.
        That error message is very strange. Are you sure you dont have a stray 'space' in the line with the StreamReader? I ask because that error is complaining that the parameter to StreamReader is not narrowed enough.
        HS4Pro Running on a Raspberry Pi4
        68 Z-Wave Nodes, 175 Events, 359 Devices
        UPB modules via OMNI plugin/panel
        Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
        HSTouch Clients: 3 Android, 1 Joggler

        Comment


          #49
          Originally posted by rmasonjr View Post
          I'm still running my lock in HS2, so I havent even converted this script over to HS3 just yet.
          That error message is very strange. Are you sure you dont have a stray 'space' in the line with the StreamReader? I ask because that error is complaining that the parameter to StreamReader is not narrowed enough.
          Thanks, I might have, although it worked that way under HS2. I just took the script and did a "save as" into my HS3 folder and then modified the device references and nothing else. I'll take another look at it tonight.

          Thanks
          Al
          HS 3.0.0.548: 1990 Devices 1172 Events
          Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

          Comment


            #50
            Hi Rob,

            I was looking at this script tonight and trying to figure out what's going on under HS3. I don't think it's related to reading and writing to the file, rather the reading of the lock device. Have you looked at this script under HS3 yet?

            Thanks
            Al
            HS 3.0.0.548: 1990 Devices 1172 Events
            Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

            Comment


              #51
              Originally posted by sparkman View Post
              Hi Rob,

              I was looking at this script tonight and trying to figure out what's going on under HS3. I don't think it's related to reading and writing to the file, rather the reading of the lock device. Have you looked at this script under HS3 yet?

              Thanks
              Al
              Hi Al
              Unfortunately, this is the *last* device that is still running under my HS2 instance. I have migrated all other Z-Wave devices except my lock. I am very nervous about moving it since it is so important to our family. For example, we have special codes for Physical Therapists, housecleaning, etc and we get text messages when those and other codes are used.
              HS4Pro Running on a Raspberry Pi4
              68 Z-Wave Nodes, 175 Events, 359 Devices
              UPB modules via OMNI plugin/panel
              Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
              HSTouch Clients: 3 Android, 1 Joggler

              Comment


                #52
                Thanks Rob, are you using 2 zwave networks, one with HS2 and one with HS3? I was able to test my locks under HS3 while still using HS2 as my production system. See this thread on how to do that: http://board.homeseer.com/showthread.php?t=167500. That only works if using the same network though.

                Cheers
                Al
                HS 3.0.0.548: 1990 Devices 1172 Events
                Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

                Comment


                  #53
                  Ah. I had not seen that. My hs2 system still has 2 ztrollers and my hs3 only has 1. I'm waiting on the new ztroller to be released then I'll use that for hs3.

                  Sent from my SCH-R970X using Tapatalk
                  HS4Pro Running on a Raspberry Pi4
                  68 Z-Wave Nodes, 175 Events, 359 Devices
                  UPB modules via OMNI plugin/panel
                  Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
                  HSTouch Clients: 3 Android, 1 Joggler

                  Comment


                    #54
                    Hi Rob,

                    While watching the Seahawks win tonight , I updated the script to work with HS3:



                    EDIT: Script removed. Now posted at http://board.homeseer.com/showthread.php?p=1156347.

                    Cheers
                    Al
                    Last edited by sparkman; January 13, 2015, 09:16 PM.
                    HS 3.0.0.548: 1990 Devices 1172 Events
                    Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

                    Comment


                      #55
                      I've added more functionality to this script and it's posted here: http://board.homeseer.com/showthread.php?p=1156347.

                      Cheers
                      Al
                      HS 3.0.0.548: 1990 Devices 1172 Events
                      Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

                      Comment

                      Working...
                      X