Announcement

Collapse
No announcement yet.

New HSTouch Server Plug-in Released v 1.0.0.50

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • rmasonjr
    replied
    Originally posted by zakrzep View Post
    Awesome! It worked great. I saw another date/time before I posted my question, but it was not the local time.

    Thanks
    Yeah, that one is called "Local Observation Date and Time".

    Here's another one that I display on my weather screen - may be helpful - it is the "nearest area". For me, it lists the actual community I live in. The URL must have the '&includeLocation=yes' on the end:
    Attached Files

    Leave a comment:


  • zakrzep
    replied
    Awesome! It worked great. I saw another date/time before I posted my question, but it was not the local time.

    Thanks

    Leave a comment:


  • rmasonjr
    replied
    Originally posted by zakrzep View Post
    Is there a way to get the current forecast date/time?

    Thanks
    Yes - you can add a text elment with the following setup:
    Attached Files

    Leave a comment:


  • zakrzep
    replied
    Is there a way to get the current forecast date/time?

    Thanks

    Leave a comment:


  • Larryguy50
    replied
    Weatherbug

    I also like WB. It seems a little more accurate on conditions.

    Leave a comment:


  • VirtualPanther
    replied
    Originally posted by rjh View Post
    Build .54 did not always update weather info so please use .55:

    ftp://ftp.homeseer.com/updates/Beta/...H_1_0_0_55.zip
    While I was brainstorming in the my reply above, I forgot one important point: Thank You!

    I know all of us are quick to complain, when something doesn't work. I'm just as guilty of holding the HomeSeer crew to the highest standard. But it is also worth while noting that without them fixing things and actively monitoring this board, there would not be much point in pursuing this time and effort consuming quest to automate everything. Thanks, Rich!

    Leave a comment:


  • VirtualPanther
    replied
    Originally posted by rjh View Post
    Build .54 did not always update weather info so please use .55:

    ftp://ftp.homeseer.com/updates/Beta/...H_1_0_0_55.zip
    The updated dll seems to work for me. The iPad still displays the weather from the World Weather Online (like it did after previous update), whereas the iPhones display weather the way they have been for the last year. Did not dig into what has changed, but the iPhone does not seem to use the new weather provider, as evidenced by the use of zip code based location (instead of latitude and longitude) and a different forecast. Additionally, when compared side-by-side, the iPad weather by World Weather Online seems way off from both the iPhone weather in HSTouch and the real world s well. It was foggy and chilly a bit this morning here, which is what the iPad was displaying in the morning. It still displays that, despite it being sunny and 65...

    Back to the point, for those that do care, the iPhone in my case seems to display weather correctly after the latest dll update.

    I just use the weather.com app on the phone and that is it. Why reinvent the wheel?

    Leave a comment:


  • rjh
    replied
    Build .54 did not always update weather info so please use .55:

    ftp://ftp.homeseer.com/updates/Beta/...H_1_0_0_55.zip

    Leave a comment:


  • CJVann
    replied
    No - I've had my key for a year or two.

    Leave a comment:


  • rjh
    replied
    Did you just request your key? It can take hours before the key actually works. Enter the url in a browser and make sure the xml displays.


    Originally posted by CJVann View Post
    Okay, that gave me an idea. HST hard coded your API key into all my projects, in the RSSUrlNormal line (There's no "api_key=[$WEATHERAPIKEY]" replacement). So I entered YOUR API key into the HST Config, and now WeatherBug data is present. I'm not sure why it's not doing the same with my key (unless I use a different URL like: i.wxbug.net/REST/SP/getLiveWeatherRSS.aspx?api_key=[$WEATHERAPIKEY]&stationid=KMQJ&UnitType=0&OutputType=1)

    Leave a comment:


  • CJVann
    replied
    Okay, that gave me an idea. HST hard coded your API key into all my projects, in the RSSUrlNormal line (There's no "api_key=[$WEATHERAPIKEY]" replacement). So I entered YOUR API key into the HST Config, and now WeatherBug data is present. I'm not sure why it's not doing the same with my key (unless I use a different URL like: i.wxbug.net/REST/SP/getLiveWeatherRSS.aspx?api_key=[$WEATHERAPIKEY]&stationid=KMQJ&UnitType=0&OutputType=1)

    Leave a comment:


  • rjh
    replied
    We are having the board hide our API key as it should not be made public, that is why the paste is not the same.

    I tried a bunch of old projects with the new plugin and they all displayed fine. Make sure you restart HS after trying a new project, see if that helps. The new plugin does cache the RSS data where before it would reset the cache whenever any client connected/disconnected. It may be related to that.

    Originally posted by CJVann View Post
    That was a direct copy/paste from an old project. It changes the text of the code from "ACode=A567..." to "ACode=WeatherAPIKey" when I paste it into the message board. Weird. Note that if I "edit" the existing project fields in the RSS Data Browser, all the data is present in the tables. It just won't show in the HST projects for some reason. I'll remove the http:// from the fields and we'll try something simpler - the text name for tomorrow (THU) from the WeatherBug forecast.

    Existing HST project field (No longer works, just shows "Text")
    RSS: api.wxbug.net/getForecastRSS.aspx?ACode=A567Removed&zipcode=46229&unittype=0
    title
    alttitle
    1

    Using my RSS address & WB API key - HST shows "THU" as expected:
    RSS: i.wxbug.net/REST/XML/GetXml.aspx?api_key=Removed&RequestType=22&Latitude=39.76&Longitude=-85.96 &ForecastType=7
    title
    alttitle
    1

    Leave a comment:


  • CJVann
    replied
    That was a direct copy/paste from an old project. It changes the text of the code from "ACode=A567..." to "ACode=WeatherAPIKey" when I paste it into the message board. Weird. Note that if I "edit" the existing project fields in the RSS Data Browser, all the data is present in the tables. It just won't show in the HST projects for some reason. I'll remove the http:// from the fields and we'll try something simpler - the text name for tomorrow (THU) from the WeatherBug forecast.

    Existing HST project field (No longer works, just shows "Text")
    RSS: api.wxbug.net/getForecastRSS.aspx?ACode=A567Removed&zipcode=46229&unittype=0
    title
    alttitle
    1

    Using my RSS address & WB API key - HST shows "THU" as expected:
    RSS: i.wxbug.net/REST/XML/GetXml.aspx?api_key=[$WEATHERAPIKEY]&RequestType=22&Latitude=39.76&Longitude=-85.96 &ForecastType=7
    title
    alttitle
    1
    Last edited by CJVann; March 14, 2012, 03:29 PM.

    Leave a comment:


  • rjh
    replied
    So which one of those works now? I assume that in the first one "WeatherAPIKey" is your actual key (and not our key)? If not, it needs to be like this:

    [$WEATHERAPIKEY]

    and it will be replaced with the key as entered in the server plugin.

    Originally posted by CJVann View Post
    EDIT: I experimented with my own RSS address, and had success getting WeatherBug data. None of the existingRemoved

    Leave a comment:


  • CJVann
    replied
    EDIT: I experimented with my own RSS address, and had success getting WeatherBug data. BUT - none of the existingRemoved
    Last edited by CJVann; March 14, 2012, 02:34 PM.

    Leave a comment:

Working...
X