Announcement

Collapse
No announcement yet.

Weather RSS feed not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Weather RSS feed not working

    The worldweatheronline RSS feed has stopped working. Has anyone else experienced this?

    Ken

    #2
    I use WeatherXML to pull World Weather Online and mine just updated about an hour ago.
    HS4Pro Running on a Raspberry Pi4
    68 Z-Wave Nodes, 175 Events, 359 Devices
    UPB modules via OMNI plugin/panel
    Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
    HSTouch Clients: 3 Android, 1 Joggler

    Comment


      #3
      I use WeatherXML and it stopped working for me
      It give me several errors like this one
      Error with observation time: De objectvariabele of With block-variabele is niet ingesteld.
      - Bram

      Send from my Commodore VIC-20

      Ashai_Rey____________________________________________________________ ________________
      HSPro 3.5.0
      PIugins: ZMC audio | ZMC VR | ZMC IR | ZMC NDS | RFXcom | AZ scripts | Jon00 Scripts | RFXCOM | BLRadar | BLBackup

      Comment


        #4
        Originally posted by AshaiRey View Post
        I use WeatherXML and it stopped working for me
        It give me several errors like this one
        Error with observation time: De objectvariabele of With block-variabele is niet ingesteld.
        Here is the error I am getting when you go to an HSTouch screen with the weather icons on it. The error is logged for each icon on the screen.

        9/5/2013 5:02:03 AM - Error - Running script, init error: Cannot use parentheses when calling a Sub


        Comment


          #5
          My problem is solved.
          I had to re register for a new API key and instert that in the INI file
          {edit}
          Sorry cheered to early.
          I still got these error
          5-9-2013 13:28:00 weatherXML Error with visibility: De objectvariabele of With block-variabele is niet ingesteld.
          5-9-2013 13:28:00 weatherXML Error with barometer: De objectvariabele of With block-variabele is niet ingesteld.
          5-9-2013 13:28:00 weatherXML Error with condition icon: De objectvariabele of With block-variabele is niet ingesteld.
          5-9-2013 13:28:00 weatherXML Error with feels like: De objectvariabele of With block-variabele is niet ingesteld.
          5-9-2013 13:28:00 weatherXML Error with wind speed: De objectvariabele of With block-variabele is niet ingesteld.
          5-9-2013 13:28:00 weatherXML Error with wind direction: De objectvariabele of With block-variabele is niet ingesteld.
          5-9-2013 13:28:00 weatherXML Error with wind degrees: De objectvariabele of With block-variabele is niet ingesteld.
          5-9-2013 13:28:00 weatherXML Error with humidity: De objectvariabele of With block-variabele is niet ingesteld.
          5-9-2013 13:28:00 weatherXML Error with current temperature: De objectvariabele of With block-variabele is niet ingesteld.
          5-9-2013 13:28:00 weatherXML Error with observation time: De objectvariabele of With block-variabele is niet ingesteld.


          @Ken
          The error is quiet clear
          Error - Running script, init error: Cannot use parentheses when calling a Sub

          Have you tried to remove the () from the call to the Sub?
          You can't pass parameters to a Sub like you can do with Functions and Methodes
          Last edited by AshaiRey; September 5, 2013, 06:41 AM.
          - Bram

          Send from my Commodore VIC-20

          Ashai_Rey____________________________________________________________ ________________
          HSPro 3.5.0
          PIugins: ZMC audio | ZMC VR | ZMC IR | ZMC NDS | RFXcom | AZ scripts | Jon00 Scripts | RFXCOM | BLRadar | BLBackup

          Comment


            #6
            For instructions to use the new API key with weatherXML go to this thread.
            http://board.homeseer.com/showthread.php?t=161849

            There is a new URL that needs to be inserted into the ini file.
            The new API key can be entered in the locations page. You don't have to edit the ini file for the API Key.

            Originally posted by AshaiRey View Post
            My problem is solved.
            I had to re register for a new API key and instert that in the INI file
            {edit}
            Sorry cheered to early.
            I still got these error
            5-9-2013 13:28:00 weatherXML Error with visibility: De objectvariabele of With block-variabele is niet ingesteld.
            5-9-2013 13:28:00 weatherXML Error with barometer: De objectvariabele of With block-variabele is niet ingesteld.
            5-9-2013 13:28:00 weatherXML Error with condition icon: De objectvariabele of With block-variabele is niet ingesteld.
            5-9-2013 13:28:00 weatherXML Error with feels like: De objectvariabele of With block-variabele is niet ingesteld.
            5-9-2013 13:28:00 weatherXML Error with wind speed: De objectvariabele of With block-variabele is niet ingesteld.
            5-9-2013 13:28:00 weatherXML Error with wind direction: De objectvariabele of With block-variabele is niet ingesteld.
            5-9-2013 13:28:00 weatherXML Error with wind degrees: De objectvariabele of With block-variabele is niet ingesteld.
            5-9-2013 13:28:00 weatherXML Error with humidity: De objectvariabele of With block-variabele is niet ingesteld.
            5-9-2013 13:28:00 weatherXML Error with current temperature: De objectvariabele of With block-variabele is niet ingesteld.
            5-9-2013 13:28:00 weatherXML Error with observation time: De objectvariabele of With block-variabele is niet ingesteld.


            @Ken
            The error is quiet clear
            Error - Running script, init error: Cannot use parentheses when calling a Sub

            Have you tried to remove the () from the call to the Sub?
            You can't pass parameters to a Sub like you can do with Functions and Methodes
            --
            Jeff Farmer
            HS 3, HSPhone
            My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
            Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

            Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

            Comment


              #7
              Confused...

              Originally posted by CFGuy View Post
              For instructions to use the new API key with weatherXML go to this thread.
              http://board.homeseer.com/showthread.php?t=161849

              There is a new URL that needs to be inserted into the ini file.
              The new API key can be entered in the locations page. You don't have to edit the ini file for the API Key.

              Jeff, the various weather sources and (their) API keys have me more than a little confused. I use your WeatherXML, but my primary data source is currently Weather Underground, which also has an API key. I am not getting any errors so I assume it will continue to work. I also have registered at Weather Online and have a (new) API key that went through a reissue process in late March 2013. It begs the question of which is the better to use in WeatherXML. Can you give me some guidance please?

              Thanks
              Gary

              Comment


                #8
                Originally posted by Kbevo View Post

                Jeff, the various weather sources and (their) API keys have me more than a little confused. I use your WeatherXML, but my primary data source is currently Weather Underground, which also has an API key. I am not getting any errors so I assume it will continue to work. I also have registered at Weather Online and have a (new) API key that went through a reissue process in late March 2013. It begs the question of which is the better to use in WeatherXML. Can you give me some guidance please?

                Thanks
                Gary
                Personally, I like Weather Underground the best. I have 4 weather locations setup in weatherXML. The first two are the ones I want the info for and I use WUnderground for both. The third one is a test city for NOAA and the 4th is a test city for World Weather Online. Once I get the new API for WeatherBug I'll add a test city for them.

                The original post in this thread for was HSTouch. I don't know if it has been updated to use the new API key.
                --
                Jeff Farmer
                HS 3, HSPhone
                My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
                Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

                Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

                Comment


                  #9
                  Thanks Jeff for the reply.

                  I already figured out that the url has been changed and i update the script to match the new url.
                  Yes, i updated the script because i use and older version and i've translated that one to Dutch. It works well for me and i don't want to go into the hassle of getting all in Dutch again. It's a nice script.
                  - Bram

                  Send from my Commodore VIC-20

                  Ashai_Rey____________________________________________________________ ________________
                  HSPro 3.5.0
                  PIugins: ZMC audio | ZMC VR | ZMC IR | ZMC NDS | RFXcom | AZ scripts | Jon00 Scripts | RFXCOM | BLRadar | BLBackup

                  Comment


                    #10
                    Instructions for updating HSTouch screens?

                    Trying to fix broken HSTouch weather. I know I need to change the URLs, with the new API key, but are there instructions for doing so within the Designer? What is the new URL format?

                    Any guidance/help appreciated.

                    Barry
                    - OK - got it working.
                    1. Update the API key in the HSTouch config screen
                    2. Open the project file with Notepad or other editor.
                    3. Locate the old URL - free.worldweatheronline.com/feed/weather.ashx
                    4. Replace with new URL string - api.worldweatheronline.com/free/v1/weather.ashx
                    5. Save the project file
                    Last edited by lhfarm; September 8, 2013, 04:49 PM. Reason: Found the answer to my own question

                    Comment


                      #11
                      Hi Barry. Can you clarify what you mean by "project file" please? Do you mean the .mdb file on the server? It's a jumbo if I open that one. Thanks.

                      ---- Edit: nevermind, got it. You mean the project file in HSTouch Designer.

                      Comment


                        #12
                        Originally posted by Jinster View Post
                        Hi Barry. Can you clarify what you mean by "project file" please? Do you mean the .mdb file on the server? It's a jumbo if I open that one. Thanks.

                        ---- Edit: nevermind, got it. You mean the project file in HSTouch Designer.
                        Yes, the XML file you created with the designer. I figured out the mass replace after reading other post.

                        Good luck,
                        Barry

                        Comment


                          #13
                          Old Thread but new issue...
                          Jan-03 11:36:01 PM HSTouch Server Warning, could not update RSS data for URL: http://weather.homeseer.com/weather/...762025&apikey= More info: Name cannot begin with the '1' character, hexadecimal value 0x31. Line 1, position 8.
                          Jan-03 11:06:30 PM HSTouch Server Warning, could not update RSS data for URL: http://weather.homeseer.com/weather/...762025&apikey= More info: Unexpected end of file has occurred. The following elements are not closed: nodata. Line 1, position 9.
                          Jan-03 10:37:00 PM HSTouch Server Warning, could not update RSS data for URL: http://weather.homeseer.com/weather/...762025&apikey= More info: Name cannot begin with the '1' character, hexadecimal value 0x31. Line 1, position 8.
                          Jan-03 10:07:29 PM HSTouch Server Warning, could not update RSS data for URL: http://weather.homeseer.com/weather/...762025&apikey= More info: Name cannot begin with the '1' character, hexadecimal value 0x31. Line 1, position 8.
                          Jan-03 9:37:59 PM HSTouch Server Warning, could not update RSS data for URL: http://weather.homeseer.com/weather/...762025&apikey= More info: Name cannot begin with the '1' character, hexadecimal value 0x31. Line 1, position 8.
                          Jan-03 9:08:29 PM HSTouch Server Warning, could not update RSS data for URL: http://weather.homeseer.com/weather/...762025&apikey= More info: Name cannot begin with the '1' character, hexadecimal value 0x31. Line 1, position 8.
                          Jan-03 8:38:59 PM HSTouch Server Warning, could not update RSS data for URL: http://weather.homeseer.com/weather/...762025&apikey= More info: Name cannot begin with the '1' character, hexadecimal value 0x31. Line 1, position 8.
                          Jan-03 7:39:53 PM HSTouch Server Warning, could not update RSS data for URL: http://weather.homeseer.com/weather/...762025&apikey= More info: Unexpected end of file has occurred. The following elements are not closed: nodata. Line 1, position 9.
                          Jan-03 7:10:33 PM HSTouch Server Warning, could not update RSS data for URL: http://weather.homeseer.com/weather/...762025&apikey= More info: Name cannot begin with the '1' character, hexadecimal value 0x31. Line 1, position 8.
                          Jan-03 6:40:52 PM HSTouch Server Warning, could not update RSS data for URL: http://weather.homeseer.com/weather/...762025&apikey= More info: Name cannot begin with the '1' character, hexadecimal value 0x31. Line 1, position 8.
                          Jan-03 6:11:20 PM HSTouch Server Warning, could not update RSS data for URL: http://weather.homeseer.com/weather/...762025&apikey= More info: Name cannot begin with the '1' character, hexadecimal value 0x31. Line 1, position 8.
                          Jan-03 5:41:50 PM HSTouch Server Warning, could not update RSS data for URL: http://weather.homeseer.com/weather/...762025&apikey= More info: Name cannot begin with the '1' character, hexadecimal value 0x31. Line 1, position 8.
                          Jan-03 5:12:19 PM HSTouch Server Warning, could not update RSS data for URL: http://weather.homeseer.com/weather/...762025&apikey= More info: Name cannot begin with the '1' character, hexadecimal value 0x31. Line 1, position 8.
                          Jan-03 4:42:49 PM HSTouch Server Warning, could not update RSS data for URL: http://weather.homeseer.com/weather/...762025&apikey= More info: Name cannot begin with the '1' character, hexadecimal value 0x31. Line 1, position 8.
                          Jan-03 4:13:19 PM HSTouch Server Warning, could not update RSS data for URL: http://weather.homeseer.com/weather/...762025&apikey= More info: Unexpected end of file has occurred. The following elements are not closed: nodata. Line 1, position 9.

                          Comment


                            #14
                            I'm seeing the same thing since very early this morning.

                            Comment


                              #15
                              Same issue for me as well and the error started on Jan 3rd around 4pm (CST) in the log file as yours also shows.

                              If I go to a browser and enter the URL to see what XML it returns, I get "<error 100>" as the only information returned.

                              Comment

                              Working...
                              X