Announcement

Collapse
No announcement yet.

Problems with music menu Squeezebox

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Problems with music menu Squeezebox

    I'm using Squeezebox plug-in for music.

    When designing the menus in HS Touch

    For music selection I'm using

    ListBox -> Status Tracking -> Music Selector

    It does work to some extent however I see some garbage there such as "macromark" and "snap-small" that are not part of my Logitec Media Server (LMS). Also I see some "iTunes" labels regardless that I never use iTunes.

    Furthermore LMS favorites do not show as a list. It stops short to "LMS favorites" line and will not allow further drill down as it does on LMS web interface.

    Help will be appreciated.

    Thanks

    RI2

    #2
    Is this with hs2 or hs3?

    Comment


      #3
      HS2

      It's HS2.

      RI2

      Comment


        #4
        One more problem with HS Touch design with Squeezebox plug-in HS2

        Feedback info (artist name, album name, album cover image, song name etc.) doesn't show for one player while it does show for another.
        In order to avoid any possibility for error I created two identical screens for the two players using the standard build-in "music browser" in HSTouch.
        The only info that I needed to enter was to pick the name of each player from a drop down box. This is nice if it worked. One player shows perfectly. The controls work for the other player (play, pause, stop, fast forward) , however the feedback is not there. It shows "stopped" and no other info even when it is playing music that I can hear.
        Both players show normally and update properly in HomeSeer devices.
        Both players show normally in Logitec Music Server (LMS).The problem is with HSTouch design only.

        Needless to say that I did re-boot the player, and HS.

        Please help.

        RI2
        Attached Files

        Comment


          #5
          Did you try to switch to the other players on the screen that worked? Did you check the settings of the player that is linked / used for the different controls (used for artist name, album name, etc)?

          I used a similar setup with 4 media screens with one for each player and updates + control worked fine (since I switched my touch displays to HS3).

          Comment


            #6
            Originally posted by pcp View Post
            Did you try to switch to the other players on the screen that worked? Did you check the settings of the player that is linked / used for the different controls (used for artist name, album name, etc)?

            I used a similar setup with 4 media screens with one for each player and updates + control worked fine (since I switched my touch displays to HS3).
            Hi Phillippe,

            Thanks for your attention to this annoying problem.

            1. I'm using "Basic Music Browser" in HSTouch to eliminate any possibility of human error. When I activate it it just asks for the player's name from a drop down box and that's all. I will get into fancy custom design once I get the problem solved. With that said it is impossible to "switch" to the other player without going trough the boxes one by one since the easy part (select player by name only) is available in the beginning only. Regardless I started "changing" the problematic boxes one by one and voila the information popped up immediately for the "good player" and disappeared when I went back to the "bad player".

            2. IMPORTANT HINT... I noticed that the "bad player" (named Picacho1), is listed twice in the drop down box. I tried both entries with no luck. I went to Squeezebox Plug-In Status page in HS and I found two Picacho1 listed there as well. One "connected" and the other "disconnected". In addition the "good player" (called Picacho 3) is listed as well however only once. The two Picacho 1 players have the same name however different IDs

            00:04:20:16:bc:e0 192.168.1.200 receiver Picacho3 Playing
            00:04:20:16:a1:b9 receiver Picacho1 Disconnected
            00:04:20:16:a1:7a 192.168.1.211 receiver Picacho1 Playing


            LMS shows only one Picacho1 and one Picacho3. Where did this extra player come from and how to delete it?

            3. What do you mean when you say "did you check the settings of the player". My players are "Squeezebox Duet" and I do not remember using any settings for them.

            4. Please note that all that is missing is feedback from the player about status, track name, artist name, album cover photo etc. Everything else does work - start, stop, play etc. The missing info is clearly visible in the photos attached above.

            5. Please note also that the missing info is missing in HS Touch only. It shows properly everywhere else incl. in Home Seer "devices" created by your plug-in, LMS server, other apps that I approach LMS server with such as "Penguin" for iPhone.

            Thanks,

            RI2

            Comment


              #7
              i will look more into your notes this evening. But having twice a player could eb the source. Try the following: delete the devices for the player you have twice, shutdown hs2, edit the plugin ini file (in hs2 config folder) and remove the sections for player. The section for the player starts with a bracket that contains the player's MAC address. Then restart hs2, plugin, select the player in the plugin status page (cehck box) to create devices and ensure its only created once.

              Comment


                #8
                Resolved

                The good news first. The deletion of the phantom player resolved the problem.

                Not so good news is that Squeezebox plug-in shows some inconsistency described below.

                After I followed your instructions to delete the phantom player from the .ini file I rebooted HS as instructed.

                Went to the status page of squeezebox just to realize that the plug-in was quick to find and list the phantom player again. Fortunately, this time it was listed with no name associated with it unlike last time when it stole the name of the legitimate player Picacho1 and caused the problems. I also found the check-box for the legitimate player Picacho 1 unchecked, while the box of the other player Picacho3 was still checked. The HS devices however were there for both Picacho1 and Picacho3. These devices are operating properly and I'm not sure what to do with the box. If I check it than the plug-in may create new duplicate devices and create more problems. I will keep it unchecked until I hear from you.

                I'm glad that this annoying problem was resolved, however the other problem remains untouched
                http://board.homeseer.com/showthread.php?t=171385

                Comment

                Working...
                X