No announcement yet.

CM15A on Linux

  • Filter
  • Time
  • Show
Clear All
new posts

  • CM15A on Linux

    I have installed the CM15A plug-in on HS3 Linux. When I enable the plug-in, I received the following error : **FATAL**: ActiveX Control not installed.
    Do I have to install a Linux CM15 A driver or doing something special ?

  • #2
    Same problem here, tried Debian and Ubuntu. Everything else works.
    Activex is a Microsoft invention and as far as I can see there is no way of running Activex under Mono. CM15A needs Activex, so this means it's impossible to use CM15A with Linux.
    Submitted a bug report today and I received the following reply:
    We support the CM15A on the Zee using the Mochad open source CM15A driver,
    currently this has not been built for the Linux version of HS3 that supports
    EXE plugins. We will get an EXE version out soon.
    Last edited by WfromL; July 29th, 2014, 11:59 AM.


    • #3
      comparison with windows

      I have also installed CM15A under Windows to see what is different.
      After he installation, I have the same error after starting the CM15A interface :
      **FATAL**: ActiveX Control not installed. As explained in the release info, I download and install theActiveHome PRO SDK (ahsdk_install.exe) and after this, it works !
      That means that we need on Linux this SDK running. I have tried to run the same exe with mono under Linux but it does not work (Not a CIL image).
      I hope that the homeseer team will work on this fix because I want to migrate on Linux as soon as possible.


      • #4
        CM15A (X15) works with HS3 .143

        After upgrading to .143 on UBUNTU I noticed my CM15A works !


        • #5
          Originally posted by WfromL View Post
          After upgrading to .143 on UBUNTU I noticed my CM15A works !
          Okay this is going to be a bit confusing (sorry). I have a x86_64 bit Debian system my self compiled 64bit mochad doesn't work (it stops sending data after a short time). But I also have support for the lib32 libraries (don't ask how) and I have another self compiled x86 (32bit) mochad working (so far). The mochad that came with HomeSeer needed a newer glibc than I had so I had to fall back to something I compiled on an other x86 Linux system.

          And before you ask, this is for a demo so the CM15 will end up on the Pi running HomeSeer as I don't want to lose my home Homeseer setup (but don't mind losing the X10).
          Edit: Seems I spoke too soon, the lib32 version of mochad locked up 15 minutes after I posted this. (grrr!).
          I'll need to spend some time on this code.
          Last edited by ncherry; December 10th, 2014, 07:54 AM.


          • #6
            I found a problem with mochad; when it starts up, it doesn't set the time. If your CM15A doesn't have batteries or they're dead the CM15A will send an A5 (reset the time) and mochad doesn't know what to do. I've just tested my set time code and it works. Ill figure out where to add the code (I have it at startup right now, but that isn't enough) and I'll post the fix. Not sure if I have write access to the original code but I can always post to one of my public git accounts.

            I'll also post a bug to Homeseer. I'm not sure if they use they're own internal repo or the one on SourceForge. I do know that the version shipped with HS3 .149 requires a library (lib32 GLIBC_2.16) that isn't updated that far on Debian.

            Problem fixed and my code is posted to :
            LinuxHA Mochad github repo
            Last edited by ncherry; December 29th, 2014, 06:05 PM. Reason: Updated with fix