Announcement

Collapse
No announcement yet.

Fakro Chain Drive for Windows

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Leachy76
    replied
    Hi,
    Did you end up getting the Fakro chain actuator working with HS3?

    Leave a comment:


  • fermate
    replied
    A little correction:

    When setting the device to Poll
    Bouth the "Switch Binary" and the "Switch Multilevel" reports correctly when the window is fully opened and fully closed

    When in motion they reads "Ivalid Value" and "Unknown State/Position"

    And the log:

    feb-01 21:21:40 Z-Wave Device: Node 94 Z-Wave Switch Multilevel Set to Unknown State/Position
    feb-01 21:21:40 Z-Wave Device: Node 94 Z-Wave Switch Binary Set to INVALID VALUE
    Can this be changed by setting Status Graphics ?
    How do i find the value reported?
    Last edited by fermate; February 1st, 2015, 03:43 PM.

    Leave a comment:


  • fermate
    replied
    Adding with HS2 gave betetr results.

    I moved my Z-wave controller to my old HS2 PC and did a Add-node here.

    After that I moved it back to my HS3 PC and did a "Scan Existing Devices (Light Scan)"

    The log showed:

    feb-01 20:05:11 Z-Wave 2 out of 2 Child devices of node 94 were created successfully.
    feb-01 20:05:10 Z-Wave Getting association information for Node 94 Z-Wave Fakro Switch Multilevel Node 94
    feb-01 20:05:09 Z-Wave Z-Wave Stick: Adding association for Z-Wave device Node 94 Z-Wave Fakro Switch Multilevel Node 94 (Node 94, Group 1) to HomeSeer
    feb-01 20:05:09 Z-Wave All associations for node 94 have been retrieved successfully, it supports associations on these groups: 1.
    feb-01 20:05:09 Z-Wave Node 94 Association Group 1 can have 5 associations, and currently has 0
    feb-01 20:05:08 Z-Wave Getting association information for node 94
    feb-01 20:05:08 Z-Wave Node: 94 Supports Class(es): SWITCH_MULTILEVEL_V2, SWITCH_ALL, SWITCH_BINARY, MANUFACTURER_SPECIFIC, VERSION_V2, ASSOCIATION, PROTECTION, POWERLEVEL, SECURITY
    feb-01 20:05:08 Z-Wave Z-Wave Stick: Contacting node 94 to get supported features
    feb-01 20:05:08 Z-Wave Z-Wave Stick: Node 94 supports class: COMMAND_CLASS_SECURITY
    feb-01 20:05:08 Z-Wave Z-Wave Stick: Node 94 supports class: COMMAND_CLASS_POWERLEVEL
    feb-01 20:05:08 Z-Wave Z-Wave Stick: Node 94 supports class: COMMAND_CLASS_PROTECTION
    feb-01 20:05:08 Z-Wave Z-Wave Stick: Node 94 supports class: COMMAND_CLASS_ASSOCIATION
    feb-01 20:05:08 Z-Wave Z-Wave Stick: Node 94 supports class: COMMAND_CLASS_VERSION_V2
    feb-01 20:05:08 Z-Wave Z-Wave Stick: Node 94 supports class: COMMAND_CLASS_MANUFACTURER_SPECIFIC
    feb-01 20:05:08 Z-Wave Z-Wave Stick: Node 94 supports class: COMMAND_CLASS_SWITCH_BINARY
    feb-01 20:05:08 Z-Wave Z-Wave Stick: Node 94 supports class: COMMAND_CLASS_SWITCH_ALL
    feb-01 20:05:08 Z-Wave Z-Wave Stick: Node 94 supports class: COMMAND_CLASS_SWITCH_MULTILEVEL_V2
    feb-01 20:05:08 Z-Wave Z-Wave Stick: Node 94 is reporting 8 command classes in the node information.
    feb-01 20:05:08 Z-Wave Checking if we can reach node 94
    feb-01 20:05:08 Z-Wave Z-Wave Stick: Contacting node 94 to get supported features
    feb-01 20:05:07 Z-Wave Checking if we can reach node 94
    feb-01 20:05:07 Z-Wave Device synchronization needs to get Z-Wave class information for one node.
    feb-01 20:05:07 Z-Wave
    feb-01 20:05:07 Z-Wave Device synchronization needs to create devices for one new node.
    feb-01 20:05:07 Z-Wave
    feb-01 20:05:07 Z-Wave Syncing Z-Wave nodes with device list...
    The devices turned up (Se picture)

    And the Controls acts like:

    Close: Start Closing the window
    Open: Start Opening the window
    On: If Closing in progress: Stop
    On: If Stopped: Start Opening
    Off: If Opening in progress: Stop
    Off: If Stopped: Start Closing

    The "Dimmer bar" just shows if a Open or Close command have been issued and shows 0% or 100% only.

    If I try to rescan the device, the log shows:
    feb-01 20:11:29 Z-Wave Warning The device at node 94 should result in 2 child devices being created, but the node interrogation currently has 0. This may still result in a successful child creation.
    feb-01 20:11:29 Z-Wave Error Security class information is NOT present - cannot continue loading node 94
    feb-01 20:11:21 Z-Wave Getting SECURITY class information for node 94
    feb-01 20:11:21 Z-Wave
    feb-01 20:11:21 Z-Wave Device synchronization needs to create devices for one new node.
    feb-01 20:11:21 Z-Wave
    feb-01 20:11:21 Z-Wave Syncing Z-Wave nodes with device list...
    This leads me to think that my device is OK and that the current HS3 z-wave plugin does something different (right or wrong -I don't know) than HS2

    Is there any debug that I can help with doing?
    I realy would like to be able to Add my next Fakro devices without using HS2 and I don't trust the mixed thing I just did...
    Attached Files

    Leave a comment:


  • fermate
    replied
    Rescaning the node (and Adding in the first place) was done with the controller 2 cm from the device.

    Optimized 4 times. - Still no reaction from the controllers.

    Is there any other testing I can do for you, to avoid shiping this expensive unit?

    Leave a comment:


  • Rupp
    replied
    Have you tried to rescan the device while it's close to your controller to see if that helps? Also do not forget to do the optimize four times after adding the device as well. It could be that it's not fully compatible with HS3 but that's just a guess. I'm sure Rich and crew would need one to test with to be sure.

    Leave a comment:


  • fermate
    started a topic Fakro Chain Drive for Windows

    Fakro Chain Drive for Windows

    Hi

    I got a Fakro Chain Drive for Pivot Windows some months ago.
    I tested it with HS2 and was able to run it but I found it unstable and decided to wait until I had switched to HS3.

    Now HS3 is up and running and I can add it like this:

    A new node has been found and is being added...
    Adding a new SLAVE NODE...
    Replication protocol transfer done - waiting for application specific replication (if any) to finish.
    Node 92 Added.
    DONE - Add Node Operation is Complete.
    Done. Node 92 Added.
    Node 92 supports the SECURITY command class - negotiating a security scheme...
    Security device (Node 92) is verified as operating securely in this network.
    Synchronizing node information with HomeSeer and creating new device(s) as necessary...
    Synchronize nodes finished. Number of device nodes to be created/added = 1

    Device synchronization needs to create devices for one new node.

    Getting SECURITY class information for node 92
    Z-Wave manufacturer information for node 92, ID: 133=85H (Fakro), Type: 3=3H, ID: 1=1H
    Node: 92 Supports Class(es): SWITCH_MULTILEVEL_V2, SWITCH_ALL, SWITCH_BINARY, MANUFACTURER_SPECIFIC, VERSION_V2, ASSOCIATION, PROTECTION, POWERLEVEL, SECURITY
    Node: 92 Supports Secure Class(es): SWITCH_MULTILEVEL_V2, SWITCH_ALL, SWITCH_BINARY, MANUFACTURER_SPECIFIC, VERSION_V2, ASSOCIATION, PROTECTION, POWERLEVEL
    All associations for node 92 have been retrieved successfully, it supports associations on these groups: 1.
    Warning: Node 92 did not respond to the Switch Multilevel Supported Get request.
    Root Node Device Node 92 Z-Wave Fakro Switch Multilevel Node 92 was created for node 92 on network 0161EAE7
    Z-Wave Stick: Adding association for Z-Wave device Node 92 Z-Wave Fakro Switch Multilevel Node 92 (Node 92, Group 1) to HomeSeer
    2 out of 2 Child devices of node 92 were created successfully.
    Reloading (importing) node information from the controller...
    Finished with Replication process.
    The Devices is showing up with correct picture and the controls looks promising (See attached picture) but none of them is working in any way.

    - "Test Connectivity" works fine.
    - Optimize works fine.
    - Audit this node works fine.

    Do I have a faulty device or is it not compatible with HS3?

    Anyoune else got this device to work with HS3?
    Attached Files
Working...
X