Announcement

Collapse
No announcement yet.

Error "Request failed"?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Error "Request failed"?

    Hi!

    Do you know why this Error occurs in my log and how get rid of them?

    Best Wishes,
    Anders



    Code:
    10-08-2020 20:21:40
    Legacy-Plugin
    AK Ikea Warning
    [546]: Retry: /15005/131074/196613
    
    10-08-2020 20:21:40
    Legacy-Plugin
    AK Ikea ERROR
    [546]: Request failed() : /15005/131074/196613
    
    10-08-2020 16:37:19
    Legacy-Plugin
    AK Ikea Warning
    [546]: [newIkea] New Receiver (127.0.0.1:80): Setting new IP address: 10.168.10.137:80

    #2
    It looks like you created the device manually? Did you have problems with mDNS/Zeroconf discovery?

    This can be caused by anything - the plugin is not able to communicate with IKEA Gateway. It can be wrong IP address...

    Can you describe what you did?

    Comment


      #3
      Yes, I put in the IP address and the secret key manually because it didn't find my gateway.


      Click image for larger version

Name:	IKEA.png
Views:	47
Size:	78.8 KB
ID:	1425014

      Comment


        #4
        If discovery doesn't find your device - kust be some issue with notwork setup. So I think it's better to try mDNS working first.
        From your screenshot I see you are on Windows and it's using TmDS discovery. Most reliable is Apple Bonjour service Download Bonjour Print Services for Windows v2.0.2
        I suggest to install the service. Then restart the plugin - it should detect the service and change the discovery from Tmds to Mono.Zeroconf

        I have a couple of mDNS test programs (attached) - please try them.

        Anothe question - from the screenshot I see that it actually did work - because you have the devices found. So, what happened?

        It helpful when you report a problem - to actually describe more details...
        Attached Files

        Comment


          #5
          BTW Anders, 546 is not the error number - it's the IKEA Root HS device reference number, So I will rename the thread.

          Comment


            #6
            Sorry, for wrong subject.

            It is working, but gives this message in the log sometimes:

            ----
            10-09-2020 13:57:54

            Legacy-Plugin
            AK Ikea ERROR
            [546]: Request failed() : /15004/131074

            10-09-2020 13:57:49

            Legacy-Plugin
            AK Ikea ERROR
            [546]: Request failed() : /15005/131074/196611

            10-09-2020 13:57:44

            Legacy-Plugin
            AK Ikea Warning
            [546]: Retry: /15004/131074

            10-09-2020 13:57:44

            Legacy-Plugin
            AK Ikea ERROR
            [546]: Request failed() : /15004/131074

            10-09-2020 13:57:40

            Legacy-Plugin
            Z-Wave
            Device: Node 2 Hilkka Volts Set to 234,92 (234,92 Volts)

            10-09-2020 13:57:40

            Legacy-Plugin
            Z-Wave
            Device: Node 19 HK Växtlyse Volts Set to 233,29 (233,29 Volts)

            10-09-2020 13:57:40

            Legacy-Plugin
            Z-Wave
            Device: Node 36 Fönster Volts Set to 230,64 (230,64 Volts)

            10-09-2020 13:57:39

            Legacy-Plugin
            AK Ikea Warning
            [546]: Retry: /15005/131074/196611

            10-09-2020 13:57:39

            Legacy-Plugin
            AK Ikea ERROR
            [546]: Request failed() : /15005/131074/196611
            ----

            I will try you recommendation and report back.

            Comment


              #7
              I have the problem sometimes too - the IKEA Gateway looses connection. I don't know why. Rebooting the gateway and HS fixes the problem.


              Unrelated - I noticed logs "Device: Node 36 Fönster Volts Set to 230,64 (230,64 Volts)"
              You can disable the log for each device:
              Click image for larger version

Name:	Screenshot 2020-10-10 003440.jpg
Views:	48
Size:	35.4 KB
ID:	1425035

              Comment


                #8
                Thank you for the tips!


                I hope it will work better now:

                10-09-2020 15:38:40 Legacy-Plugin AK Ikea Warning Running on 'windows' - using Locator.MonoZeroconf.DeviceLocator

                Comment


                  #9
                  Originally posted by tussebatong View Post
                  Thank you for the tips!


                  I hope it will work better now:

                  10-09-2020 15:38:40 Legacy-Plugin AK Ikea Warning Running on 'windows' - using Locator.MonoZeroconf.DeviceLocator
                  Yeah, looks better. Also - it's better to set static IP address for IKEA gateway in your router.

                  Comment

                  Working...
                  X