No announcement yet.

Somewhat strange behaviour controlling a group with the On button

  • Filter
  • Time
  • Show
Clear All
new posts

    Somewhat strange behaviour controlling a group with the On button

    I just switched from TradfriSeer to AK Ikea, the setup was very straight forward and everything showed up as expected.

    However, when I try to control a light using the "group" it belongs to it behaves a bit strange. If i press the On button in the HomeSeer web gui, nothing happens. If I press the Last button, it works and the light turns on. I can also turn on the light by using the dim-slider.

    Now comes the really strange thing. If I have turned on the light using the dim-slider, and then turn it off again. I can turn it on, using the On button that didn't work at first. Then the light first seems to go to the previous dim level (that was before turning it off) and then to full On. If I turn it off again, it can not be turned on again with the On button.

    If I operate the controls on the bulb or LED-driver HS-device directly, the On-button always works.

    For most of my Trådfri gear this is ok for me, but I have one group with three bulbs in as main ceiling lamp in the master bedroom that we mostly control using Google Home. I will get plenty of complaints from the users (=wife) if that doesn't work smoothly ;-)

    Plugin version is, I am running HS3 Pro Edition on Ubuntu 20.04. Mono JIT compiler version (Debian Wed Feb 26 23:23:50 UTC 2020)

    I would prefer not to upgrade to HS4 just yet, since the last time I tried I ran into a bug that made HS4 crash all the time when opening settings for any device. I think it was related to some devices getting an empty location and it might be fixed in the current version (HS-989,Convert empty strings to None when saving locations using UpdatePropertyByRef) but I am not sure and I do not have the time for rollback at the moment.

    Any chance you can take a look at it and see if you can reproduce it? If so, what can I do to help?

    Best Regards,

    Hi zyrgh , I'll try to reproduce the problem. The groups in Ikea may behave strange as I just send the command to the group (in IKEA controller), then the group decides what to do. And IKEA app is known to be buggy. We'll see.


      Hi alexbk66!

      Thank you for taking the time to see what you can do.

      I just managed to find a "user friendly" workaround for Google Assistant by swapping the "Control Use:" for "On" and "On Alternate" in the "Status Graphics" tab for the group. It does not change the behaviour in the HomeSeer web gui though, but it seems to work for Google Assistant and HomeSeer Mobile if somebody else runs into the same issue.


        I'm porting AKIkea now to HS4, lots of fun


          I can confirm that controlling On/Off via the group doesn't work anymore... Will investigate...


            Ver. - Fixed rounding brightness and group ON control