Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

CPS Tuya

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • bsobel
    replied
    Thank you, I will have to test the country mappings, it should be working in all 3 zones (US, EU, Asia) but clearly something is off. No huge harm, but you will be tied to the US servers if you continue to run this way. Since most control is local TCP it shouldn't really matter, so FYI...

    Leave a comment:


  • wanaka
    replied
    by the way you are right country code is the issue. I have using +1 and actually get a different message that a confirmation has mail to you.

    Leave a comment:


  • wanaka
    replied
    Yes I am located in Singapore

    Leave a comment:


  • bsobel
    replied
    Thanks. This may be a real error, I will try to reproduce and fix. Are you located in Singapore? (From the 65 country code). I may have made an error in server mappings for Asia. Unfortunately I’m in India this week so may not be able to update you until this coming weekend when Im back in San Diego.

    Leave a comment:


  • wanaka
    replied
    Here is the error when you are trying add account.

    Leave a comment:


  • bsobel
    replied
    Can you post the error you get? (Or a screenshot). My apologies for the hassle for most folks this has been seemless but clearly their are some corner cases.

    Leave a comment:


  • wanaka
    replied
    The script solved the mono installation issue. Thanks. However, now I got a new error from the plugins it said incorrect token even though my password is correct.

    Leave a comment:


  • bsobel
    replied
    Originally posted by spud View Post
    this is a known problem with the SEL
    there is a script to fix that, see this post: https://forums.homeseer.com/forum/me...92#post1284892
    Spud, dude, THANKS! Much appreciated.

    Leave a comment:


  • spud
    replied
    this is a known problem with the SEL
    there is a script to fix that, see this post: https://forums.homeseer.com/forum/me...92#post1284892

    Leave a comment:


  • bsobel
    replied
    mono-devel : Depends: libglib2.0-0 (>= 2.40.2) but 2.40.0-2 is to be installed

    This seems wrong as that version appears to be indeed >= I have seen this once before, on my SEL the sources list was edited down quite a bit which kept many security updates from occurring . I restored the sources list to the Ubuntu default, but (in case you decide to do this) then a LOT of updates occurred. One was the network manager (so best to do this from the machine itself as when it updates it disconnects SSH). I am currently traveling (India) but can try to see if there is another way to address this when I get back to the states on Saturday, but the core issue I believe is some missing mono components and the above error would seem to unfortunately support that. Did the mono-complete go ok?

    Leave a comment:


  • wanaka
    replied



    root@hometrollerSEL:/home/homeseer# apt-get install mono-complete

    Reading package lists... Done

    Building dependency tree

    Reading state information... Done

    Some packages could not be installed. This may mean that you have

    requested an impossible situation or if you are using the unstable

    distribution that some required packages have not yet been created

    or been moved out of Incoming.

    The following information may help to resolve the situation:




    The following packages have unmet dependencies:

    mono-complete : Depends: mono-devel (= 5.18.0.240-0xamarin1+ubuntu1404b1) but it is not going to be installed

    Depends: monodoc-manual (= 5.18.0.240-0xamarin1+ubuntu1404b1) but it is not going to be installed

    E: Unable to correct problems, you have held broken packages.

    root@hometrollerSEL:/home/homeseer# apt-get install mono-devl

    Reading package lists... Done

    Building dependency tree

    Reading state information... Done

    E: Unable to locate package mono-devl

    root@hometrollerSEL:/home/homeseer# apt-get install mono-devel

    Reading package lists... Done

    Building dependency tree

    Reading state information... Done

    Some packages could not be installed. This may mean that you have

    requested an impossible situation or if you are using the unstable

    distribution that some required packages have not yet been created

    or been moved out of Incoming.

    The following information may help to resolve the situation:




    The following packages have unmet dependencies:

    mono-devel : Depends: libglib2.0-0 (>= 2.40.2) but 2.40.0-2 is to be installed

    Recommends: referenceassemblies-pcl but it is not going to be installed

    Recommends: msbuild but it is not going to be installed

    E: Unable to correct problems, you have held broken packages.

    Leave a comment:


  • bsobel
    replied
    Thanks. Looks like you upgraded (good) from th stock SEL. Can you ensure you installed both mono-complete and mono-devel (complete should cover it, but develop Justin case). You can try complete first.

    Leave a comment:


  • wanaka
    replied
    Here is the Mono Version.
    Mono JIT compiler version 5.0.1.1 (2017-02/5077205 Thu May 25 09:18:45 UTC 2017)

    Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com

    TLS: __thread

    SIGSEGV: altstack

    Notifications: epoll

    Architecture: x86

    Disabled: none

    Misc: softdebug

    LLVM: supported, not enabled.

    GC: sgen (concurrent by default)

    Leave a comment:


  • bsobel
    replied
    Thanks, can you post the mono version (run mono --version)

    Leave a comment:


  • wanaka
    replied
    Debug log
    Attached Files

    Leave a comment:

Working...
X