Announcement

Collapse
No announcement yet.

Color change not working in RGBW bulbs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Color change not working in RGBW bulbs

    Hi,

    Thanks for this great PI!

    I'm using these bulbs (which are just rebranded Tuya):
    https://globe-electric.com/en/produc...e-2-pack34207/

    They are detected by the PI and added successfully. I can turn on/off, brighten/dim, change color temperature, but I am unable to change color of the bulb. When I select "colour" under "work_mode", the bulb changes from white to red, but the "colour_data" field does not have any effect on the colour of the bulb. Wondering if you have any suggestions.

    Click image for larger version

Name:	tuya.jpg
Views:	370
Size:	68.3 KB
ID:	1314762

    Thanks again!

    #2
    bsobel as a follow up to this comment, I've added the bulbs to my Google Home app (using the Tuya integration).

    When I make changes in the GH app (eg on/off, bright/dim), the bulbs react and in HomeSeer Web Control I see the changes. When I make a colour change in the GH app, the bulbs also change colour but aside from "work_mode" changing from "white" to "colour", no other fields change (including colour_data and scene_data).

    Thanks

    Comment


      #3
      Originally posted by benrjunk View Post
      bsobel as a follow up to this comment, I've added the bulbs to my Google Home app (using the Tuya integration).

      When I make changes in the GH app (eg on/off, bright/dim), the bulbs react and in HomeSeer Web Control I see the changes. When I make a colour change in the GH app, the bulbs also change colour but aside from "work_mode" changing from "white" to "colour", no other fields change (including colour_data and scene_data).

      Thanks
      The bulbs are available via the plugin OR via one of the Tuya applications. Not sure exactly what you mean with the Tuya integration with GH, but if that is not via HS it won't work, that is a Tuya limitation unfortunately (but the devices are visible via HS Mobile and any other HS integrated mobile app)

      On the color issue, it may be related to you trying to control the device with GH and the plugin. If not, the color data above looks right, no response when you set the build to on and the work_mode to color?

      Comment


        #4
        Hi bsobel

        I had the problem of not being able to change color before I added them to Google Home. But in any event, I am able to add to both interfaces (this is not a limitation of my particular Tuya devices). When I integrate in GH, I search for "Globe" and I add my account. The Google Home app interface then gives me the option to add using Casa Piedra Software Smart Devices or Globe Suite (see screenshot from my phone). When I select Casa Piedra (I assume this is you), the bulbs appear in GH and are controllable from both GH (app and assistant devices) and HomeSeer (myHS/Web Control). Additionally changes I make using GH are reflected in the HomeSeer control.

        If I select "Globe Suite", there are no bulbs in that account.

        Regarding the color problem, this problem existed even before I added to my google account. And as you say, when I turn the bulb on and switch work_mode to color, the bulb turns on and goes from white to red. Following this, any color changes using the color_data field have no effect on the bulb. Additionally, when I turn the bulb on using the GH app, the switch_led field changes from Off to On. However, while changes to color in the GH app actually change the bulb color, it has no effect on the color_data field in HomeSeer. The work_mode field does change from white to color, however.

        Click image for larger version  Name:	Screenshot_20190710-115306.jpg Views:	0 Size:	21.0 KB ID:	1314990

        Comment


          #5
          Hi bsobel

          Any suggestions here?

          Thanks!

          Comment


            #6
            Originally posted by benrjunk View Post
            Hi bsobel

            Any suggestions here?

            Thanks!
            I suspect a firmware change makes these look different than the normal bulbs, Ive seen that once before. I ordered one to debug with, should be here next week.

            Comment


              #7
              Thank you so much!

              Comment


                #8
                Hi bsobel

                Any progress with this bulb?

                Thanks

                Comment


                  #9
                  Originally posted by benrjunk View Post
                  Hi bsobel

                  Any progress with this bulb?

                  Thanks
                  Can you install the latest, the current beta supports the v2 firmware on TCP only (MQTT receive is working, I am still working on getting MQTT control for firmware v2 working). Kindly report back after you try. Thanks!

                  Comment


                    #10
                    Sorry, could you remind me where to download this plugin from!

                    Regards, Ben

                    Comment


                      #11
                      http://download.casapiedrasoftware.i...r_override.txt

                      Comment

                      Working...
                      X