Announcement

Collapse
No announcement yet.

(Scheduled for Deletion) I tried to delete the plugin.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • (Scheduled for Deletion) I tried to delete the plugin.

    I setup Tuya a while back. It was working awesome, then it didn't.

    I had issues and tried to uninstall it. Now, it doesn't work at all. If I try to modify the plugins config, I get "Error: An unknown error has occured, please check for an exception file in the HomeSeer directory."

    From startup. There are a ton of these.

    Warning Issue checking parent device (395) Cps Tuya Cps Tuya Smart Plug, Energy Monitoring
    Nov-11 7:08:37 PM Warning Device (396) Cps Tuya Cps Tuya Smart Plug, Energy Monitoring switch_1 is marked as child, but does not reference any parent
    N

    I was able to setup one test device with the smart life app, so something is working. I remember having to remove the devices from the app in order to load them into HS.

    Thanks for the help!

  • #2
    I set up the plug-in and have same results multiple times as well. Seems I get that error for each child device on the one Smart Bulb that I do have connected. Everything seems to work fine. I only seem to get that Error when I restart HS or restart the plug-in.

    No idea why. I would not think this is what it is supposed to do. Wonder if should use the fix child/parent button to attempt to fix it?

    Comment


    • #3
      Can you confirm the version you are running?

      Comment


      • #4
        HomeSeer version 3.0.0.548 Edition: HS3 Standard Starting Now
        Cps Tuya
        N/A 1.1.0.0 N/A Included OK

        Comment


        • #5
          Can I uninstall the plugin and try again? I don't seem to be able to do that as well. I'm trying to get my HS3 cleaned up before we get HS4.

          Comment


          • #6
            Yes, but the version you are running is expired and extremely old. Please download the latest (use the same directions) and you should see 1.5 vs 1.1

            Comment


            • #7
              I'm running version 1.5 and when HS3 starts up I see a lot of these entries as well. It seems there's an entry for every device registered in the plugin.
              Device (334) First Master Bath JL 3 cur_voltage does not reference a parent, it should reference one parent
              Nov-12 6:49:47 PM Warning Issue checking child device (334) First Master Bath JL 3 cur_voltage
              Nov-12 6:49:47 PM Warning Device (333) First Master Bath JL 3 cur_power does not reference a parent, it should reference one parent
              Nov-12 6:49:47 PM Warning Issue checking child device (333) First Master Bath JL 3 cur_power
              Nov-12 6:49:47 PM Warning Device (332) First Master Bath JL 3 cur_current does not reference a parent, it should reference one parent
              Nov-12 6:49:47 PM Warning Issue checking child device (332) First Master Bath JL 3 cur_current
              Nov-12 6:49:47 PM Warning Device (331) First Master Bath JL 3 add_ele does not reference a parent, it should reference one parent
              Nov-12 6:49:47 PM Warning Issue checking child device (331) First Master Bath JL 3 add_ele
              Nov-12 6:49:47 PM Warning Device (330) First Master Bath JL 3 countdown does not reference a parent, it should reference one parent
              Nov-12 6:49:47 PM Warning Issue checking child device (330) First Master Bath JL 3 countdown
              Nov-12 6:49:47 PM Warning Device (329) First Master Bath JL 3 switch_on does not reference a parent, it should reference one parent
              Nov-12 6:49:47 PM Warning Issue checking child device (329) First Master Bath JL 3 switch_on
              Nov-12 6:49:47 PM Warning Device (334) First Master Bath JL 3 cur_voltage is marked as child, but does not reference any parent
              .
              .
              .
              -Rupp
              sigpic

              Comment


              • #8
                Very odd, did you manually delete the root devices? It almost seems like the roots were missing and HS removed the invalid reference and so is now reporting this.

                Comment


                • #9
                  My errors are reporting parent/child errors. I did not delete the root device. My root device is still listed.
                  Version 1.5.0.0

                  Comment


                  • #10
                    I downloaded this file: http://download.casapiedrasoftware.i...ates3/CpsTuya/ I moved the update_override.txt to the HS3 directory. Upon restart, the
                    plugin page looks normal with no option to updated CPSTuya. The upate_override.txt is gone after the restart.

                    What am I doing wrong?

                    Comment


                    • #11
                      Originally posted by bsobel View Post
                      Very odd, did you manually delete the root devices? It almost seems like the roots were missing and HS removed the invalid reference and so is now reporting this.
                      No, my devices are all intact and the root devices looks like it always has. This just started a few weeks ago but I'm not sure why.
                      -Rupp
                      sigpic

                      Comment


                      • #12
                        Originally posted by Blinder View Post
                        I downloaded this file: http://download.casapiedrasoftware.i...ates3/CpsTuya/ I moved the update_override.txt to the HS3 directory. Upon restart, the
                        plugin page looks normal with no option to updated CPSTuya. The upate_override.txt is gone after the restart.

                        What am I doing wrong?
                        I move the updater_override.txt file into HS3 while it was running. Then selected Plugins > Manage. You can then install the file and it will be removed once the file is installed.
                        -Rupp
                        sigpic

                        Comment


                        • #13
                          That worked. Thanks Rup

                          Comment

                          Working...
                          X