Announcement

Collapse
No announcement yet.

HS3 Insteon Plug-In Version 3.0.7.1 Release (Windows & Linux)

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HS3 Insteon Plug-In Version 3.0.7.1 Release (Windows & Linux)

    Please backup your config\insteon.ini and data\homeseer.hsd files.

    New Device support:
    - Motion Sensor II
    - Siren Module (2868) support; this device superceeds the Alert Module
    - EZsnsRF basic support (you must link manually the device to the Interface)

    Changes:
    - Added sorting feature to Device Manage page. Click column heading once for asc sort, click again for desc sort. Currently, your sort option will not persist between plugin restarts.
    - Revised dimmer sliders to include max value 100. This will allow setting 100% On via the slider regardless of default on-level. See Note 1 below.
    - Disables polling for devices that do not respond after 2 failed attempts. See Note #2 below to disable this feature.
    - Revised Insteon Receive message format to include HS Location2
    - Added some additional Configuration Change Trigger calls
    - Manages the insteon.ini file internally; does not use the HS3 methods. See Note #3 below
    - Revised ini management routines. The insteon.ini will be re-saved about 3 seconds after any required changes (comm stats, polling results, or config changes)
    - Device value set to -1 (Unknown) if polling fails
    - Changed the default value for the Hub setting GetXMLBufferInterval=2000
    - Syncing linked responder devices now use the responder link values to set the on level and ramp rate
    - Hub.GetBuffer routine won't generate report log files on exceptions; now logs a Normal msg
    - Added 'Disable Relay Polling" option to IOLincs. Use this option if polling is triggering the relay
    - The Interface Port help text on the Config page will now display the list of available ports
    - Added an Insteon tab on the hs devices edit pages that includes links to the plugin
    - Allows empty or blank group locations to better support Alexa
    - Small improvement to Hub II buffer processing
    - Revised logging for Hub network errors; no functional changes
    - Added additional message processing for new Hub messages
    - Revised Hidden Door Sensor support; added 2 Groups option - see user's manual

    Fixes:
    - An error (can't write to log file) associated with External Device registration.
    - A bug when display sub device on add/Create Group page
    - An error when using All Off button with Controlinc
    - Registration of old motion sensors (fw 30 or older)
    - IOLinc polling fix
    - Resolved X10 control issue
    - Revised KPL HS Devices sync with KPL LEDs
    - Revised KPL HS Devices sync when using radio or combine button groups
    - A bug when programming a group without a controller
    - A bug with original motion sensors causing exceptions
    - X10 polling for dimmers supporting preset dim
    - Config folder name change for Linux
    - KPL HS device syncing
    - On-level and ramp rates in group definition for KPL Load device #9
    - X10 processing will ignore X10 messages for devices owned by other plugins
    - Fanlinc/Keypadlinc control from HS dev management page
    - KPL and switchlinc syncing
    - Device syncing will not propagate the Beep command
    - Unknown group broadcasts will not generate an exception/error report; just logged
    - Increased field space on Insteon ID fields
    - Linux dimmer image reference
    - Hub issue with older UK Hub 1 (devicetype 0330) processing

    Please post any issues with this beta to this thread.

    Notes:
    1. You will need to either manually change the slider definition by changing the max value from 99 to 100 or add RecreateDevices=1 to the [config] section of the insteon.ini and restart the plugin. Do not use the ini option if you have customized your devices.
    2. add FailedPollThreshold=0 to the [config] section of the insteon.ini to continue to poll devices that do not respond. The default value is 2.
    3. I have incorporated my own ini file management routines in an effort to avoid losing the insteon.ini file when HS3 crashes or terminates unexpectedly. The ini file will get reordered/sorted by section and key when its saved but nothing should get lost. use the Configuration trigger and Backup Configuration action to make backups.

    Last edited by mnsandler; December 17th, 2018, 10:30 AM. Reason: update related to 3.0.7.1
    Mark

    HS3 Pro 3.0.0.534
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

  • #2
    Mark, how is best to update the plugin? From the manage plugins page, it doesn't show that there is an update.

    Thanks,
    Terry

    Comment


    • #3
      Originally posted by terrydeadwyler View Post
      Mark, how is best to update the plugin? From the manage plugins page, it doesn't show that there is an update.

      Thanks,
      Terry
      Yes, from the Manage Plugin page is the best way to upgrade. Still waiting for HST to post it. I submitted it yesterday.
      Mark

      HS3 Pro 3.0.0.534
      Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
      Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
      Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

      Comment


      • #4
        How long should something like this take? Why is Homeseer not updating when new versions are released?

        Mark, thanks for quickly updating your plugin. Just still waiting for Homeseer.....

        Comment


        • #5
          The new version was just posted to the Updater. Please backup your configuration before proceeding with the update.
          Mark

          HS3 Pro 3.0.0.534
          Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
          Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
          Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

          Comment


          • #6
            If you have an older Hub I with devicetype 0330 (i think its a UK version) you will need to installed Beta 3.0.7.1 to fix the hub errors. I will post this to the Updater once i know there are no other issues.
            Mark

            HS3 Pro 3.0.0.534
            Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
            Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
            Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

            Comment


            • #7
              I am trying to update from 3.0.6 from the HS3 plugin manage page and it continually fails the update. I have a license and been using for years now. Any ideas?

              Comment


              • #8
                Originally posted by tbone View Post
                I am trying to update from 3.0.6 from the HS3 plugin manage page and it continually fails the update. I have a license and been using for years now. Any ideas?
                Tim, try shutting down the running plugin before updating
                Mark

                HS3 Pro 3.0.0.534
                Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                Comment


                • #9
                  Thank you Mark. Thank worked perfectly. I am one of those users that just keeps the system running and running... day after day and I often forget about what I need to do to keep things in tip top shape... LOL. Thank you again Mark.

                  Comment


                  • #10
                    Glad it worked. Time to update your signature
                    Mark

                    HS3 Pro 3.0.0.534
                    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                    Comment


                    • #11
                      All,
                      I accidentally posted 3.0.7.2 as a Release. 3.0.7.1 should be the current Release. See the beta thread for details on 3.0.7.2+
                      Mark

                      HS3 Pro 3.0.0.534
                      Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                      Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                      Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                      Comment


                      • #12
                        I just went to HomeSeer 3. I'm using a 2413U. It works with HSInsteon but not with your plugin. I configure it for 2 and I restart HomeSeer.
                        Insteon Plug-in Error Log Generated 2/9/2019 7:39:38 AM
                        -----------*Error Message*----------------
                        Error: Forced error / log generation -- 2/9/2019 7:39:38 AM
                        --------*Initialization Log*--------------
                        2/9/2019 7:28:06 AM - Host System: 192.168.0.42 (DESKTOP-A0KT18I) 3.0.0.500
                        2/9/2019 7:28:06 AM - Plugin HSPI_Insteon.exe version: 3.0.7.1
                        2/9/2019 7:28:06 AM - Insteon Support library (Insteon.dll) version: 1.0.7.1
                        2/9/2019 7:28:06 AM - RegisterCallback Completed
                        2/9/2019 7:28:06 AM - Enter InitIO
                        2/9/2019 7:28:06 AM - Enter InitPlugin
                        2/9/2019 7:28:06 AM - Global initialization of plug-in required, starting up.
                        2/9/2019 7:28:06 AM - Initializing Insteon hardware interface...
                        2/9/2019 7:28:06 AM - In ProcessRawReceiveThread
                        2/9/2019 7:28:06 AM - Initializing Interface...
                        2/9/2019 7:28:06 AM - In PLMBuffer_ProcessBufferThread
                        2/9/2019 7:28:06 AM - Insteon hardware interface initialization failed.
                        2/9/2019 7:28:06 AM - Enter InitX10
                        2/9/2019 7:28:06 AM - Please first Enable the Insteon plugin on the Homeseer Plugin Manage page.
                        2/9/2019 7:28:06 AM - Enter InitPlugin
                        2/9/2019 7:28:06 AM - Global initialization of plug-in required, starting up.
                        2/9/2019 7:28:06 AM - In ProcessRawReceiveThread
                        2/9/2019 7:28:06 AM - Initializing Insteon hardware interface...
                        2/9/2019 7:28:06 AM - Initializing Interface...
                        2/9/2019 7:28:06 AM - In PLMBuffer_ProcessBufferThread
                        2/9/2019 7:28:06 AM - Insteon hardware interface initialization failed.
                        2/9/2019 7:28:06 AM - Exit InitX10
                        2/9/2019 7:28:06 AM - Please visit the plugin configuration page, and enter a valid port, then restart HS.
                        2/9/2019 7:28:06 AM - Exit InitIO

                        -----------*Pre-Error Log*----------------
                        2/9/2019 7:28:06 AM - Please visit the plugin configuration page, and enter a valid port, then restart HS.
                        2/9/2019 7:33:05 AM - Saving comm stats...
                        2/9/2019 7:33:05 AM - ..finished saving comm stats.
                        2/9/2019 7:38:05 AM - Saving comm stats...
                        2/9/2019 7:38:05 AM - ..finished saving comm stats.
                        --------*End Pre-Error Log*--------------
                        --------*Start C:\Program Files (x86)\HomeSeer HS3\Config\Insteon.ini*--------------
                        [Config]
                        DetailedLog=1
                        DisablePolling=0
                        DoCleanups=1
                        InterfacePort=2
                        MaxHops=2
                        NumRetries=5
                        SortDeviceLinks=0
                        UseLocation2=0
                        WaitTimeout=3
                        X10Enabled=1
                        --------*End C:\Program Files (x86)\HomeSeer HS3\Config\Insteon.ini*--------------


                        Comment


                        • #13
                          Originally posted by wfitzner View Post
                          I just went to HomeSeer 3. I'm using a 2413U. It works with HSInsteon but not with your plugin. I configure it for 2 and I restart HomeSeer.
                          Insteon Plug-in Error Log Generated 2/9/2019 7:39:38 AM
                          -----------*Error Message*----------------
                          Error: Forced error / log generation -- 2/9/2019 7:39:38 AM
                          --------*Initialization Log*--------------
                          2/9/2019 7:28:06 AM - Host System: 192.168.0.42 (DESKTOP-A0KT18I) 3.0.0.500
                          2/9/2019 7:28:06 AM - Plugin HSPI_Insteon.exe version: 3.0.7.1
                          2/9/2019 7:28:06 AM - Insteon Support library (Insteon.dll) version: 1.0.7.1
                          2/9/2019 7:28:06 AM - RegisterCallback Completed
                          2/9/2019 7:28:06 AM - Enter InitIO
                          2/9/2019 7:28:06 AM - Enter InitPlugin
                          2/9/2019 7:28:06 AM - Global initialization of plug-in required, starting up.
                          2/9/2019 7:28:06 AM - Initializing Insteon hardware interface...
                          2/9/2019 7:28:06 AM - In ProcessRawReceiveThread
                          2/9/2019 7:28:06 AM - Initializing Interface...
                          2/9/2019 7:28:06 AM - In PLMBuffer_ProcessBufferThread
                          2/9/2019 7:28:06 AM - Insteon hardware interface initialization failed.
                          2/9/2019 7:28:06 AM - Enter InitX10
                          2/9/2019 7:28:06 AM - Please first Enable the Insteon plugin on the Homeseer Plugin Manage page.
                          2/9/2019 7:28:06 AM - Enter InitPlugin
                          2/9/2019 7:28:06 AM - Global initialization of plug-in required, starting up.
                          2/9/2019 7:28:06 AM - In ProcessRawReceiveThread
                          2/9/2019 7:28:06 AM - Initializing Insteon hardware interface...
                          2/9/2019 7:28:06 AM - Initializing Interface...
                          2/9/2019 7:28:06 AM - In PLMBuffer_ProcessBufferThread
                          2/9/2019 7:28:06 AM - Insteon hardware interface initialization failed.
                          2/9/2019 7:28:06 AM - Exit InitX10
                          2/9/2019 7:28:06 AM - Please visit the plugin configuration page, and enter a valid port, then restart HS.
                          2/9/2019 7:28:06 AM - Exit InitIO

                          -----------*Pre-Error Log*----------------
                          2/9/2019 7:28:06 AM - Please visit the plugin configuration page, and enter a valid port, then restart HS.
                          2/9/2019 7:33:05 AM - Saving comm stats...
                          2/9/2019 7:33:05 AM - ..finished saving comm stats.
                          2/9/2019 7:38:05 AM - Saving comm stats...
                          2/9/2019 7:38:05 AM - ..finished saving comm stats.
                          --------*End Pre-Error Log*--------------
                          --------*Start C:\Program Files (x86)\HomeSeer HS3\Config\Insteon.ini*--------------
                          [Config]
                          DetailedLog=1
                          DisablePolling=0
                          DoCleanups=1
                          InterfacePort=2
                          MaxHops=2
                          NumRetries=5
                          SortDeviceLinks=0
                          UseLocation2=0
                          WaitTimeout=3
                          X10Enabled=1
                          --------*End C:\Program Files (x86)\HomeSeer HS3\Config\Insteon.ini*--------------

                          what com port did you set on the plugin config page
                          Mark

                          HS3 Pro 3.0.0.534
                          Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                          Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                          Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                          Comment


                          • #14
                            2 I looked in Device Manager to confirm this is correct.

                            Comment


                            • #15
                              please enter COM2
                              Mark

                              HS3 Pro 3.0.0.534
                              Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                              Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                              Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                              Comment

                              Working...
                              X