Announcement

Collapse
No announcement yet.

HS3 Insteon Plug-In Version 3.0.7.25 BETA (Windows & Linux)

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HS3 Insteon Plug-In Version 3.0.7.25 BETA (Windows & Linux)

    Already starting the next beta cycle...As always, make backups of your entire HS3 setup

    Changes
    - A hub error on the UK Hub I with device type 0330 (3.0.7.1)
    - Added Detach Load feature to On/Off KPLs (device type 022C) with fw 43+ (3.0.7.2)
    - Added "Sync attributes with hs devices" to KPLs. Disable to allow custom name, location, and location2 values on KPL hs devices (3.0.7.3)
    - Added Advanced Settings tab within plugin. These settings are documented, but were previously only adjustable by editing the insteon.ini. Do not change unless we discuss your particular issue/need. (3.0.7.4)
    - Added an Advanced Setting to enable the HS Set Device Value trigger that fires when the value is set to the existing value (eg Off to Off) (3.0.7.4)
    - Added 'Poll All Devices' action (3.0.7.4)
    - Revised 'Poll All Devices' action to include an interval delay (3.0.7.5)
    - Added a Cancel button to other programming transactions (3.0.7.6)
    - No longer removes hs devices if the insteon.ini file is lost/deleted/removed (3.0.7.6)
    - Saves the insteon.ini to a new "Insteon Plugin" device. This will help with restores (3.0.7.6)
    - Added Off Processing for MS II when in Occupancy Mode II (3.0.7.8)
    - Added IOLinc 070D (3.0.7.11)
    - Added 2 scene mode to the remotelinc2 switch (3.0.7.15)
    - Added LED on/off for Range Extenders (3.0.7.16)
    - Added European hidden door and motion sensor device types (3.0.7.17)

    Fixes
    - Moved supporting DLLs to the bin\insteon folder using hspi_insteon.exe.config file (3.0.7.5)
    The installer should create a bin\insteon subfolder and put insteon.dll and ftd2xx_net.dll in there also, you should get an hspi_insteon.exe.config in the hs root
    - Action configurations settings lost, now restored(3.0.7.7)
    - Reset and Reprogram Interface button (3.0.7.9)
    - Outletlinc lower outlet Unknown status (3.0.7.9)
    - Beep and Poll action (3.0.7.10)
    - MS II registration process (3.0.7.11)
    - supports more that 256 insteon devices (3.0.7.13)
    - linux serial port issue during power failure (3.0.7.13)
    - KPL sync error when KPL is offline (3.0.7.15)
    - lamplinc sync issue (3.0.7.18)
    - Update X10 Devices routine for devices created from another X10 plugin (3.0.7.19)
    - Hidden door sensor LED options (3.0.7.21)
    - Log received error (3.0.7.23)
    - KPL detached Load device management (3.0.7.25)
    Last edited by mnsandler; November 7th, 2018, 12:09 PM.
    Mark

    HS3 Pro 3.0.0.534
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

  • #2
    Have noticed that the location2 text box is missing when adding devices. I do have location2 checked in the config page. The text “floor” is there but not the text entry box.

    Insteon Device ID: 0E.F7.3B

    Device Name:

    Device Location:


    Floor:
    Device Type: SwitchLinc V2 600W Dimmer
    Firmware Version: 35
    Comm Reliability: 85% (3 failed out of 20 cmds)
    Resume dim mode: False
    Default local on level: 68%
    HomeSeer 2, HomeSeer 3, Allonis myServer, Amazon Alexa Dots, ELK M1G, ISY 994i, HomeKit, BlueIris, and 6 "4k" Cameras using NVR, and integration between all of these systems. Home Automation since 1980.

    Comment


    • #3
      I upgraded to 3.0.7.2 from 3.0.6.1 and have literally lost all my modules and information in HS3 Standard. I've tried rolling back to a previous Configuration File and cannot get anything to communicate.

      I can confirm HS3 is com with my PowerLinc USB (2413U). Even if I try enabling tap-add I hear the interface beep to acknowledge it has switched modes but no devices are detected in HS3.

      Any suggestions? I'm dead in the water at the moment. Is there an easy way to roll back?

      Comment


      • #4
        I believe that message quality refers only to how many hops successful messages take, not to how many messages succeed versus how many fail.

        Comment


        • #5
          Good point. I have removed the post since it was taking a lot of space here. I tried editing and removing the attachment, and found it was easier to delete the post. Thx
          HomeSeer 2, HomeSeer 3, Allonis myServer, Amazon Alexa Dots, ELK M1G, ISY 994i, HomeKit, BlueIris, and 6 "4k" Cameras using NVR, and integration between all of these systems. Home Automation since 1980.

          Comment


          • #6
            Your point about low percentage reliability is still a good one. Those devices with low % are having difficulty communicating and will be missing commands, or at least needing multiple repeats which takes up communication bandwidth and slows things down. There are several other threads on this board related to improving Insteon and X10 signal reliability that can be very helpful to fix your devices that are in trouble.

            Comment


            • #7
              posted 3.0.7.4. See notes at the top
              Mark

              HS3 Pro 3.0.0.534
              Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
              Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
              Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

              Comment


              • #8
                Post 3.0.7.5. See notes above
                Mark

                HS3 Pro 3.0.0.534
                Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                Comment


                • #9
                  Anyone able to load 3.0.7.5? I get the following on Linux every time I install it:
                  Code:
                  Warning, Cannot load EXE file (possibly missing dependencies) HSPI_Insteon.exe: Exception of type 'System.Reflection.ReflectionTypeLoadException' was thrown.Warning, Error details with EXE HSPI_Insteon.exe: Could not load file or assembly 'Insteon, Version=1.0.7.5, Culture=neutral, PublicKeyToken=null' or one of its dependencies.Warning, Error details with EXE HSPI_Insteon.exe: Could not load file or assembly 'Insteon, Version=1.0.7.5, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
                  Guessing related to this: "Moved supporting DLLs to the bin\insteon folder using hspi_insteon.exe.config file (3.0.7.5)"

                  Comment


                  • #10
                    Originally posted by mloebl View Post
                    Anyone able to load 3.0.7.5? I get the following on Linux every time I install it:
                    Code:
                    Warning, Cannot load EXE file (possibly missing dependencies) HSPI_Insteon.exe: Exception of type 'System.Reflection.ReflectionTypeLoadException' was thrown.Warning, Error details with EXE HSPI_Insteon.exe: Could not load file or assembly 'Insteon, Version=1.0.7.5, Culture=neutral, PublicKeyToken=null' or one of its dependencies.Warning, Error details with EXE HSPI_Insteon.exe: Could not load file or assembly 'Insteon, Version=1.0.7.5, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
                    did the installer create a bin\insteon subfolder and put insteon.dll and ftd2xx_net.dll in there? also, did you get an hspi_insteon.exe.config in your hs root?
                    Mark

                    HS3 Pro 3.0.0.534
                    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                    Comment


                    • #11
                      Originally posted by mnsandler View Post

                      did the installer create a bin\insteon subfolder and put insteon.dll and ftd2xx_net.dll in there? also, did you get an hspi_insteon.exe.config in your hs root?
                      It seems to, yes:

                      Code:
                      Dec-21 3:41:17 PM         Error    Warning, Cannot load EXE file (possibly missing dependencies) HSPI_Insteon.exe: Exception of type 'System.Reflection.ReflectionTypeLoadException' was thrown.Warning, Error details with EXE HSPI_Insteon.exe: Could not load file or assembly 'Insteon, Version=1.0.7.5, Culture=neutral, PublicKeyToken=null' or one of its dependencies.Warning, Error details with EXE HSPI_Insteon.exe: Could not load file or assembly 'Insteon, Version=1.0.7.5, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
                      Dec-21 3:41:15 PM         Updater    Install/Update of package Insteon was successful.
                      Dec-21 3:41:15 PM         Updater Warning    File exists, not overwriting: \opt\HomeSeer\scripts\Insteon_ExtDevSupport_Sample.vb
                      Dec-21 3:41:15 PM         Updater Warning    File exists, not overwriting: \opt\HomeSeer\html\images\insteon\shieldred.png
                      Dec-21 3:41:15 PM         Updater Warning    File exists, not overwriting: \opt\HomeSeer\html\images\insteon\shieldgreen.png
                      Dec-21 3:41:15 PM         Updater Warning    File exists, not overwriting: \opt\HomeSeer\html\images\insteon\water.png
                      Dec-21 3:41:15 PM         Updater Warning    File exists, not overwriting: \opt\HomeSeer\html\images\insteon\redline.png
                      Dec-21 3:41:15 PM         Updater Warning    File exists, not overwriting: \opt\HomeSeer\html\images\insteon\heartbeat.png
                      Dec-21 3:41:15 PM         Updater Warning    File exists, not overwriting: \opt\HomeSeer\html\images\insteon\checkgreen.png
                      Dec-21 3:41:15 PM         Updater Warning    File exists, not overwriting: \opt\HomeSeer\html\images\insteon\battery_empty.png
                      Dec-21 3:41:15 PM         Updater Warning    File exists, not overwriting: \opt\HomeSeer\html\images\insteon\battery_half.png
                      Dec-21 3:41:15 PM         Updater Warning    File exists, not overwriting: \opt\HomeSeer\html\images\insteon\battery_good.png
                      Dec-21 3:41:15 PM         Updater Warning    File exists, not overwriting: \opt\HomeSeer\html\images\insteon\battery_full.png
                      Dec-21 3:41:15 PM         Updater Warning    File exists, not overwriting: \opt\HomeSeer\html\images\insteon\battery.png
                      Dec-21 3:41:15 PM         Updater Warning    File exists, not overwriting: \opt\HomeSeer\html\images\insteon\5-x-5_trans_spacer.gif
                      Dec-21 3:41:15 PM         Updater Warning    File exists, not overwriting: \opt\HomeSeer\bin\insteon\FTD2XX_NET.dll
                      Dec-21 3:41:15 PM         Updater    Copying file: /opt/HomeSeer/bin/insteon/Insteon.dll
                      Dec-21 3:41:15 PM         Updater    Deleting file: \opt\HomeSeer\Insteon.dll
                      Dec-21 3:41:15 PM         Updater    Copying file: /opt/HomeSeer/HSPI_Insteon.exe.config
                      Dec-21 3:41:15 PM         Updater    Copying file: /opt/HomeSeer/HSPI_Insteon.exe
                      Dec-21 3:41:15 PM         Updater    Installing package Insteon
                      Dec-21 3:41:15 PM         Updater    Update hspi_insteon.exe downloaded successfully
                      Dec-21 3:41:14 PM         Updater    Downloading update: Insteon

                      Code:
                      /opt/HomeSeer/bin/insteon$ ls -l
                      total 636
                      -rw-r--r-- 1 root root  70656 Aug  4  2012 FTD2XX_NET.dll
                      -rw-r--r-- 1 root root 576512 Dec 19 12:42 Insteon.dll
                      Code:
                      /opt/HomeSeer$ ls -l HSPI_Insteon.exe.*
                      -rw-r--r-- 1 root root 1385 Dec 18 13:00 HSPI_Insteon.exe.config
                      I am able to go back to 3.0.7.1 without any problems. Thanks!

                      Comment


                      • #12
                        the .config file is supposed to tell the exe where to find the dlls.

                        maybe we need to mod the .config file to reverse the slash


                        find the line in .config

                        <probing privatePath="bin\insteon"/>

                        change to

                        <probing privatePath="bin/insteon"/>
                        Mark

                        HS3 Pro 3.0.0.534
                        Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                        Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                        Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                        Comment


                        • #13
                          Originally posted by mnsandler View Post
                          the .config file is supposed to tell the exe where to find the dlls.

                          maybe we need to mod the .config file to reverse the slash

                          Bingo, that was it. Thank you! I did have to cycle HS3 to see the plugin with the modified config file.

                          Comment


                          • #14
                            Originally posted by mloebl View Post

                            Bingo, that was it. Thank you! I did have to cycle HS3 to see the plugin with the modified config file.
                            thanks for trying/testing. this is going to be a difficult one to solve on my end. The .config file is basically static. Not sure how i'm going to change it based on OS.
                            Mark

                            HS3 Pro 3.0.0.534
                            Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                            Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                            Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                            Comment


                            • #15
                              Posted beta 3.0.7.6. See changes above
                              Mark

                              HS3 Pro 3.0.0.534
                              Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                              Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                              Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                              Comment

                              Working...
                              X