Announcement

Collapse
No announcement yet.

Help: Lost all Insteon Devices

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help: Lost all Insteon Devices

    My HomeseerSel controller recently had an issue and would not boot. I unplugged the USB Insteon interface and connected it to my TV. I had to select something on the screen. After selecting that boot partition it booted fine. I shut it down and reconnected everything and booted back up again.

    My Insteon plug in did not have a interface port. So I added it back. /dev/ttyUSB0. I stopped the plug in and restarted it again. All looked good.

    The issue is all my Insteon devices are gone from Homeseer. In all my events I get things like Device with ref=467 is no longer in the system.

    Help please!

    Thanks,
    Ryan


  • #2
    some versions of HS3 corrupt ini files when it crashes. sounds like what happened.

    what version of the plugin are you running? there should be a backup of the insteon.ini in the config folder. you will need to restore a backup of your homeseer.hsd as well (the current one is now corrupt).
    Mark

    HS3 Pro 3.0.0.534
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

    Comment


    • #3
      Thanks so much. I have a bit of relief. 3.0.6.0 plug in....homeseer 3.0.0.500.

      So can you walk me through exactly what to do to restore the Insteon.ini and which Homeseer.hsd to restore to.

      I don't want to mess it up if it's my one chance to save everything. (years of stuff in there)

      Comment


      • #4
        Should have mentioend it is a linux box.

        Comment


        • #5
          Ryan

          thanks for the screen shots. very helpful. you will need to open the latest insteon error report.log file and extract the insteon.ini contents from the bottom of the file assuming it has all your devices.

          shutdown hs.

          from the insteon error report.log file, copy from [config] all the way down to the bottom and save as insteon.ini

          homeseer.hsd backup file is located in the Data folder. you need to find a backup from before the crash. rename it to HomeSeerData.hsd (this is the default)

          the restart hs

          once you get this working, you need to upgrade to the latest plugin version.
          Mark

          HS3 Pro 3.0.0.534
          Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
          Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
          Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

          Comment


          • #6
            THANK YOU!!!! You're awesome. Back up and working agin. So much better than calling a help desk!

            Comment


            • #7
              We got lucky. Please setup some kind of backup system. And upgrade the plugin. The newer version does a better job of saving the Insteon.ini file
              Mark

              HS3 Pro 3.0.0.534
              Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
              Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
              Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

              Comment

              Working...
              X