Announcement

Collapse
No announcement yet.

New ToggleLinc does not work - solved!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • New ToggleLinc does not work - solved!

    Plugin registered the device but it HS3 does not control it. No error trying to turn it off or on through HS, but nothing happens. The switch controls manually just fine but setting the switch to a dim value at the switch renders this error:
    ***:Error in SetHSDeviceStatusAndValue: Object reference not set to an instance of an object. -- Details System.NullReferenceException: Object reference not set to an instance of an object. at HSPI_Insteon.hspiAPI+HSAPI.GetDeviceAddress (System.Int32 ref) [0x0000b] in :0 at Insteon.Support.Core.InsteonModule.SetHSDeviceStatusAndValue (System.Int32 ref, System.Int32 Level, System.Boolean IsAPollUpdate) [0x00009] in <40adda337b0943ff93445b79c4d43a54>:0
    Model #2466 revision 6.7 2119

    Any help appreciated.

  • #2
    Can you enable detailed logging, try the hs3 control again. And post the HS log snippet
    Mark

    HS3 Pro 3.0.0.435
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

    Comment


    • #3
      Originally posted by mnsandler View Post
      Can you enable detailed logging, try the hs3 control again. And post the HS log snippet
      I realize this is more than a snippet but here goes. Switch is behaving the same way as original post.
      Oct-27 2:10:33 PM Insteon Saved ini file. msecs=106
      Oct-27 2:10:30 PM Insteon ..Finished Scheduled Polling for 1 devices.
      Oct-27 2:10:29 PM Insteon ** To request help with this problem please post this log file to the forum along with a detailed description of what lead to this problem.
      Oct-27 2:10:29 PM Insteon ** An error occurred in this plug-in. The details have been written to the log file - /usr/local/HomeSeer/Config/Insteon Error Report.Log
      Oct-27 2:10:29 PM Insteon ***:Error in SetHSDeviceStatusAndValue: Object reference not set to an instance of an object. -- Details System.NullReferenceException: Object reference not set to an instance of an object. at HSPI_Insteon.hspiAPI+HSAPI.GetDeviceAddress (System.Int32 ref) [0x0000b] in :0 at Insteon.Support.Core.InsteonModule.SetHSDeviceStatusAndValue (System.Int32 ref, System.Int32 Level, System.Boolean IsAPollUpdate) [0x00009] in <40adda337b0943ff93445b79c4d43a54>:0
      Oct-27 2:10:29 PM Insteon StandardDeviceClass ProcessStatus called with Level:65
      Oct-27 2:10:29 PM Insteon Database delta value of 4 for device 53.C6.E4 is current. No changes since last database update.
      Oct-27 2:10:29 PM Insteon Received a Direct ACK from Outside Outside Rear Entry Light (53.C6.E4): 53 C6 E4 4C 16 8A 2A 04 41
      Oct-27 2:10:29 PM Insteon Database recently heard delta value for device 53.C6.E4 is current.
      Oct-27 2:10:29 PM Insteon Received STX 0x50 (Raw Insteon Rec):53 C6 E4 4C 16 8A 2A 04 41
      Oct-27 2:10:29 PM Insteon ..Got RF PLM Response 02 62 53 C6 E4 0A 19 00 06
      Oct-27 2:10:29 PM Insteon Sending command 02 62 53 C6 E4 0A 19 00 to RF PLM, (Expecting 0 bytes extra back) Pre-Payload ACK:False, NAK is ok:False
      Oct-27 2:10:29 PM Insteon Attempting to update the status for Outside Outside Rear Entry Light (53.C6.E4)
      Oct-27 2:10:29 PM Insteon Requesting Insteon status (Polling) for device Outside Outside Rear Entry Light (53.C6.E4)
      Oct-27 2:10:29 PM Insteon Timed poll for Insteon device Outside Outside Rear Entry Light (53.C6.E4), Last contact 10/27/2019 2:10:23 PM. Polling interval of 0 min. reached, polling...
      Oct-27 2:10:29 PM Insteon Starting Scheduled Polling...
      Oct-27 2:10:26 PM Insteon Saved ini file. msecs=107
      Oct-27 2:10:23 PM Insteon Received a Direct ACK from Outside Outside Rear Entry Light (53.C6.E4): 53 C6 E4 4C 16 8A 2A 04 41
      Oct-27 2:10:23 PM Insteon Setting NeedsPoll flag for Outside Outside Rear Entry Light (53.C6.E4) because a stop-ramp broadcast was detected.
      Oct-27 2:10:23 PM Insteon ** To request help with this problem please post this log file to the forum along with a detailed description of what lead to this problem.
      Oct-27 2:10:23 PM Insteon ** An error occurred in this plug-in. The details have been written to the log file - /usr/local/HomeSeer/Config/Insteon Error Report.Log
      Oct-27 2:10:23 PM Insteon ***:Error in SetHSDeviceStatusAndValue: Object reference not set to an instance of an object. -- Details System.NullReferenceException: Object reference not set to an instance of an object. at HSPI_Insteon.hspiAPI+HSAPI.GetDeviceAddress (System.Int32 ref) [0x0000b] in :0 at Insteon.Support.Core.InsteonModule.SetHSDeviceStatusAndValue (System.Int32 ref, System.Int32 Level, System.Boolean IsAPollUpdate) [0x00009] in <40adda337b0943ff93445b79c4d43a54>:0
      Oct-27 2:10:23 PM Insteon ** To request help with this problem please post this log file to the forum along with a detailed description of what lead to this problem.
      Oct-27 2:10:23 PM Insteon ** An error occurred in this plug-in. The details have been written to the log file - /usr/local/HomeSeer/Config/Insteon Error Report.Log
      Oct-27 2:10:23 PM Insteon ***:Error in SetHSDeviceStatusAndValue: Object reference not set to an instance of an object. -- Details System.NullReferenceException: Object reference not set to an instance of an object. at HSPI_Insteon.hspiAPI+HSAPI.GetDeviceAddress (System.Int32 ref) [0x0000b] in :0 at Insteon.Support.Core.InsteonModule.SetHSDeviceStatusAndValue (System.Int32 ref, System.Int32 Level, System.Boolean IsAPollUpdate) [0x00009] in <40adda337b0943ff93445b79c4d43a54>:0
      Oct-27 2:10:22 PM Insteon StandardDeviceClass ProcessStatus called with Level:65
      Oct-27 2:10:22 PM Insteon Database delta value of 4 for device 53.C6.E4 is current. No changes since last database update.
      Oct-27 2:10:22 PM Insteon Database recently heard delta value for device 53.C6.E4 is current.
      Oct-27 2:10:22 PM Insteon Received STX 0x50 (Raw Insteon Rec):53 C6 E4 4C 16 8A 2A 04 41
      Oct-27 2:10:22 PM Insteon ..Got RF PLM Response 02 62 53 C6 E4 0A 19 00 06
      Oct-27 2:10:22 PM Insteon Sending command 02 62 53 C6 E4 0A 19 00 to RF PLM, (Expecting 0 bytes extra back) Pre-Payload ACK:False, NAK is ok:False
      Oct-27 2:10:22 PM Insteon Attempting to update the status for Outside Outside Rear Entry Light (53.C6.E4)
      Oct-27 2:10:22 PM Insteon Requesting Insteon status (Polling) for device Outside Outside Rear Entry Light (53.C6.E4)
      Oct-27 2:10:22 PM Insteon ProcessGroupBroadcast: Device Outside Outside Rear Entry Light (53.C6.E4) is group broadcast source (tgt group/button:1) sending cmd 18
      Oct-27 2:10:22 PM Insteon ProcessInsteonTrigger Parameters: DeviceID=53.C6.E4, Command=18, Command2=00, Group=1
      Oct-27 2:10:22 PM Insteon Received STX 0x50 (Raw Insteon Rec):53 C6 E4 00 00 01 CB 18 00
      Oct-27 2:10:21 PM Insteon ProcessGroupBroadcast: Device Outside Outside Rear Entry Light (53.C6.E4) is group broadcast source (tgt group/button:1) sending cmd 17
      Oct-27 2:10:21 PM Insteon ProcessInsteonTrigger Parameters: DeviceID=53.C6.E4, Command=17, Command2=01, Group=1
      Oct-27 2:10:21 PM Insteon Received STX 0x50 (Raw Insteon Rec):53 C6 E4 00 00 01 CF 17 01
      Oct-27 2:10:00 PM Device Control Device: Outside Outside Rear Entry Light to Off (0) by/from: CAPI Control Handler
      Oct-27 2:08:18 PM Device Control Device: Outside Outside Rear Entry Light to On (100) by/from: CAPI Control Handler
      Oct-27 2:08:09 PM Insteon Saved ini file. msecs=119
      Oct-27 2:06:24 PM Insteon ** To request help with this problem please post this log file to the forum along with a detailed description of what lead to this problem.
      Oct-27 2:06:24 PM Insteon ** An error occurred in this plug-in. The details have been written to the log file - /usr/local/HomeSeer/Config/Insteon Error Report.Log

      Comment


      • #4
        did you by any chance add a Code to the hs device? i don't support that.
        Mark

        HS3 Pro 3.0.0.435
        Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
        Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
        Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

        Comment


        • #5
          Originally posted by mnsandler View Post
          did you by any chance add a Code to the hs device? i don't support that.
          By code do you mean X-10? Anyway, all I did was add the device by it's address in the plugin.

          Comment


          • #6
            UPDATE: I previously added the device by it's address. I deleted it and tap added it, and it's working. Thanks for your replies.

            Comment


            • #7
              Glad you got it working.
              Mark

              HS3 Pro 3.0.0.435
              Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
              Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
              Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

              Comment

              Working...
              X