Announcement

Collapse
No announcement yet.

Mini Remote OFF button doesn't work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mini Remote OFF button doesn't work

    After installing 2342 Mini Remotes, the ON button works, but the OFF button does not. I've tried two different 4 channel and an 8 channel version and tried every combination of linking to HS3, rescanning, and reinstalling that I could think of . Any guidance would be appreciated.

  • #2
    if you link the remote directly to a switch does the on/off work?

    there is only one link required
    Mark

    HS3 Pro 3.0.0.435
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

    Comment


    • #3
      Originally posted by mnsandler View Post
      if you link the remote directly to a switch does the on/off work?

      there is only one link required
      Thanks for your prompt reply.

      Yes. The on/off works and so does the dim/bright.

      What do you mean only one link required?

      Comment


      • #4
        So, besides programming the MINI to homeseer, I need to link the MINI directly to at least one Insteon device to allow the OFF buttons to work? Right?
        The other three buttons are working now.
        Thanks!!

        Comment


        • #5
          I have several of the 2342 devices. Both 4 button and 8 button. I find it to be a bit tricky to create a good user experience. Here are some thoughts:

          1. I don't rely on the ON/OFF status of the button. Instead, I just test for whether the button has been pressed by using the Insteon Transmits and On Command or Transmits an Off command. I test for either in the event as a trigger and then take the appropriate action. Alternatively, just test whether the device has been set or changed. It kind of depends on the use. The easytrigger toggle command works real well with these remotes.
          2. With the 4 button, I just label each as one thing and it doesn't really matter where the button is pressed. Since I test for either, it works nicely.
          3. On a button where the result is not obvious (ie. setting the thermostat), the event will often speak something so the user knows it was accepted. I find the LED to be mostly useless.

          Below are several events to illustrate. Miniremote 1 and 2 are a 8 button and Miniremote 3 is a 4 button.

          Click image for larger version

Name:	miniremote1.png
Views:	56
Size:	32.4 KB
ID:	1337429
          Click image for larger version

Name:	miniremote2.png
Views:	52
Size:	34.4 KB
ID:	1337430
          Click image for larger version

Name:	miniremote3.png
Views:	51
Size:	37.5 KB
ID:	1337431

          Comment


          • #6
            You don’t need to manually link a device; I just want to know if that fixes the off issue.

            the plugin will create the links. Typically only one link per button is required. It defines the On settings. The Off is assumed.
            Mark

            HS3 Pro 3.0.0.435
            Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
            Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
            Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

            Comment


            • #7
              Mark,
              Yes that seemed to get the OFF buttons to work.

              Comment


              • #8
                logbuilder,

                Thanks for sharing your experience, insights and example. I look forward to trying out your suggestions soon.

                I'm still rather early on the learning curve.

                HomeSeer is way different than the x10-centric StarGate system that I'm migrating from.

                Comment


                • #9
                  can you post the links from the insteon.ini file for the [device x] section in question
                  Mark

                  HS3 Pro 3.0.0.435
                  Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                  Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                  Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                  Comment


                  • #10
                    Mark,

                    Here are the listings for both the 4 channel mini whose buttons can now be turned off (after I linked it to another Insteon device and a (non-linked) 8 channel mini whose buttons will not turn off.


                    [Device 13]
                    ChannelName1=a DINETTE LIGHTS
                    ChannelName2=b KITCHEN LIGHTS
                    ChannelName3=c QUIET MODE
                    ChannelName4=d DINETTE DRAPES
                    DatabaseDelta=13
                    DeviceID=44.B4.91
                    DeviceLocation=Dinette
                    DeviceName=4 Scene Remote
                    DeviceType=001B
                    EEValues=RBPMask=0,OpFlags1=230
                    FailedInteractions=10
                    FirmwareVer=39
                    HopData=1015,916,84,15
                    LastContact=11/1/2019 3:01:42 PM
                    Link 1=E2 01 34 7A B9 03 1C 01 2
                    Link 2=E2 02 34 7A B9 03 1C 02 3
                    Link 3=E2 03 34 7A B9 03 1C 03 4
                    Link 4=E2 04 34 7A B9 03 1C 04 5
                    Link 5=E2 01 06 56 A5 00 00 01 1
                    LinksDownloaded=1
                    NumLinks=5
                    PollingInterval=0
                    Protocol=3
                    RecentDatabaseDelta=13
                    SyncLinkedDevices=0
                    TotalInteractions=149


                    [Device 14]
                    ChannelName1
                    ChannelName2
                    ChannelName3
                    ChannelName4
                    ChannelName5
                    ChannelName6
                    ChannelName7
                    ChannelName8
                    DatabaseDelta=0
                    DeviceID=44.BA.7A
                    DeviceLocation=House
                    DeviceName=8 Scene Remote
                    DeviceType=001A
                    EEValues=RBPMask=0,OpFlags1=22
                    FailedInteractions=0
                    FirmwareVer=39
                    HopData=67,64,3,0
                    LastContact=11/1/2019 3:21:48 PM
                    Link 1=E2 02 34 7A B9 00 00 02 1
                    Link 2=E2 01 34 7A B9 00 00 01 2
                    Link 3=E2 04 34 7A B9 00 00 04 3
                    Link 4=E2 03 34 7A B9 00 00 03 4
                    Link 5=E2 06 34 7A B9 00 00 06 5
                    Link 6=E2 05 34 7A B9 00 00 05 6
                    Link 7=E2 08 34 7A B9 00 00 08 7
                    Link 8=E2 07 34 7A B9 00 00 07 8
                    LinksDownloaded=1
                    NumLinks=8
                    PollingInterval=0
                    Protocol=3
                    RecentDatabaseDelta=0
                    SyncLinkedDevices=0
                    TotalInteractions=6


                    Comment


                    • #11
                      logbuilder
                      Cunning!!
                      Coming from StarGate, this gets around the missing "idle" mode.
                      Works great.
                      Thanks again!

                      Comment


                      • #12
                        Originally posted by Haxster View Post
                        Mark,

                        Here are the listings for both the 4 channel mini whose buttons can now be turned off (after I linked it to another Insteon device and a (non-linked) 8 channel mini whose buttons will not turn off.


                        [Device 13]
                        ChannelName1=a DINETTE LIGHTS
                        ChannelName2=b KITCHEN LIGHTS
                        ChannelName3=c QUIET MODE
                        ChannelName4=d DINETTE DRAPES
                        DatabaseDelta=13
                        DeviceID=44.B4.91
                        DeviceLocation=Dinette
                        DeviceName=4 Scene Remote
                        DeviceType=001B
                        EEValues=RBPMask=0,OpFlags1=230
                        FailedInteractions=10
                        FirmwareVer=39
                        HopData=1015,916,84,15
                        LastContact=11/1/2019 3:01:42 PM
                        Link 1=E2 01 34 7A B9 03 1C 01 2
                        Link 2=E2 02 34 7A B9 03 1C 02 3
                        Link 3=E2 03 34 7A B9 03 1C 03 4
                        Link 4=E2 04 34 7A B9 03 1C 04 5
                        Link 5=E2 01 06 56 A5 00 00 01 1
                        LinksDownloaded=1
                        NumLinks=5
                        PollingInterval=0
                        Protocol=3
                        RecentDatabaseDelta=13
                        SyncLinkedDevices=0
                        TotalInteractions=149


                        [Device 14]
                        ChannelName1
                        ChannelName2
                        ChannelName3
                        ChannelName4
                        ChannelName5
                        ChannelName6
                        ChannelName7
                        ChannelName8
                        DatabaseDelta=0
                        DeviceID=44.BA.7A
                        DeviceLocation=House
                        DeviceName=8 Scene Remote
                        DeviceType=001A
                        EEValues=RBPMask=0,OpFlags1=22
                        FailedInteractions=0
                        FirmwareVer=39
                        HopData=67,64,3,0
                        LastContact=11/1/2019 3:21:48 PM
                        Link 1=E2 02 34 7A B9 00 00 02 1
                        Link 2=E2 01 34 7A B9 00 00 01 2
                        Link 3=E2 04 34 7A B9 00 00 04 3
                        Link 4=E2 03 34 7A B9 00 00 03 4
                        Link 5=E2 06 34 7A B9 00 00 06 5
                        Link 6=E2 05 34 7A B9 00 00 05 6
                        Link 7=E2 08 34 7A B9 00 00 08 7
                        Link 8=E2 07 34 7A B9 00 00 07 8
                        LinksDownloaded=1
                        NumLinks=8
                        PollingInterval=0
                        Protocol=3
                        RecentDatabaseDelta=0
                        SyncLinkedDevices=0
                        TotalInteractions=6

                        the links for the 8 btn do not look correct. i would do a factor reset on the device, and then use the plugin to reprogram the device. you do not need delete the device from the plugin to do this.
                        Mark

                        HS3 Pro 3.0.0.435
                        Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                        Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                        Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                        Comment


                        • #13
                          It's working now.
                          Thanks for your advice.

                          Comment


                          • #14
                            Originally posted by Haxster View Post
                            It's working now.
                            Thanks for your advice.
                            thanks for reporting back. i would be interested to know if this process will fix your 4 btn remote as well
                            Mark

                            HS3 Pro 3.0.0.435
                            Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                            Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                            Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                            Comment


                            • #15
                              Yes. Both versions are working well (so far) with the "fix" and using logbuilder's "Insteon Transmits and On Command or Transmits an Off command" suggestion.

                              These Insteon Minis are pretty nice. I just wish they weren't so pricey. (The old similar X-10 remotes or their "palms" could be had for around $5).

                              Comment

                              Working...
                              X