Announcement

Collapse
No announcement yet.

Insteon Plug in stops working after power interruptions (HS3 Rpi3b+)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Brian
    i just remembered i made a change in the linux port management. Please upgrade to the latest beta and monitor the results. it may just fix your problem.

    if you don't mind, set detailed logging in the plugin. this will allow the hs log to capture the detail.

    And the next time you have a power flash/failure, please use the 'generate error report log' from the config page to write the log.

    I need to see a log during a power issue to see how the plugin is responding.
    Mark

    HS3 Pro 3.0.0.534
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

    Comment


    • #32
      Originally posted by mnsandler View Post
      Brian
      i just remembered i made a change in the linux port management. Please upgrade to the latest beta and monitor the results. it may just fix your problem.

      if you don't mind, set detailed logging in the plugin. this will allow the hs log to capture the detail.

      And the next time you have a power flash/failure, please use the 'generate error report log' from the config page to write the log.

      I need to see a log during a power issue to see how the plugin is responding.
      Will do.

      Where do i find the latest Beta?

      Looked around the forum and did not find it when you first mentioned it.

      Comment


      • #33
        Originally posted by ve3bwp View Post

        Will do.

        Where do i find the latest Beta?

        Looked around the forum and did not find it when you first mentioned it.
        you will find it in the Updater which is available on the Plugin/Manage page. See the Additional Interfaces section at the bottom. Then you will see a Beta section. Look for the Insteon BETA 3.0.7.17
        Mark

        HS3 Pro 3.0.0.534
        Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
        Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
        Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

        Comment


        • #34
          Originally posted by mnsandler View Post

          you will find it in the Updater which is available on the Plugin/Manage page. See the Additional Interfaces section at the bottom. Then you will see a Beta section. Look for the Insteon BETA 3.0.7.17
          OK found it... dahh! (I've got 4 different Rpi systems on the go and each one handles beta's differently).

          Will do on the 'generate error report log'.

          It has yet to rise about freezing since last weeks ice storm and they are calling for another 20cm of snow tonight so things should get even more interesting for the power line crews.

          So now we wait?

          Any other due diligence I need to be considering?

          Thanks!

          Click image for larger version

Name:	Screen Shot 2020-01-17 at 11.21.19 AM.png
Views:	47
Size:	292.0 KB
ID:	1354870
          Click image for larger version

Name:	IMG_2404.PNG
Views:	47
Size:	174.8 KB
ID:	1354871
          Attached Files

          Comment


          • #35
            Brian,

            As a controlled test, enable detailed logging within the plugin, cut the breaker to the plm circuit, and watch the hs log to see how the plugin responds. Variations of this test would be to cut the breaker off & on every few seconds.

            Otherwise, we wait.

            ps. nice pic
            Mark

            HS3 Pro 3.0.0.534
            Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
            Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
            Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

            Comment


            • #36
              Originally posted by mnsandler View Post
              Brian,

              As a controlled test, enable detailed logging within the plugin, cut the breaker to the plm circuit, and watch the hs log to see how the plugin responds. Variations of this test would be to cut the breaker off & on every few seconds.

              Otherwise, we wait.

              ps. nice pic
              We just had a good dumping of snow today so I'm going to hold off doing any power fail simulations until things return to normal hopefully sometime next week. They are calling for temps to get above freezing so we may finally get rid of some of that ice. My Ham antennas are all coated so hoping they hang in until a thaw comes. I'll let you know how it goes. Thanks. More to come...

              Comment


              • #37
                Originally posted by ve3bwp View Post

                We just had a good dumping of snow today so I'm going to hold off doing any power fail simulations until things return to normal hopefully sometime next week. They are calling for temps to get above freezing so we may finally get rid of some of that ice. My Ham antennas are all coated so hoping they hang in until a thaw comes. I'll let you know how it goes. Thanks. More to come...
                is no news, good news? anything to report? anything in the hs log?
                Mark

                HS3 Pro 3.0.0.534
                Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                Comment


                • #38
                  Hi Mark, Yup.. no news is good news. Power lines are still loaded with ice but no flickers logged. I was hoping it would have thawed by now.

                  Insteon has been stable so in a few days I'll start simulating some power outages and let you know. Thanks for checking in.

                  Comment


                  • #39
                    Hi Mark, First crash since I loaded the beta. Power had been pretty stable despite the weather. Today there was a power utility truck in our driveway. I went out to ask him what's up and he said he had to replace our smart meter. Apparently they randomly swap out meters and test them for accuracy and my number was up. So I was expecting a power bump but there was nothing that I could detect. Not sure if they have some way of swapping meters without dropping the power. So I can't be sure if that was a factor or not. I'm not even sure he changed the meter. He was gone before I could ask.

                    Anyway I can't be sure exactly when the Insteon plugin locked up. It was sometime in the last 24 hours from what I can tell. I had to set up an insteon hub just to keep the basics running to keep the lights going and the water heater off during peak power hours. I know the Homeseer based SONOS announcements were working yesterday.

                    I tried to get into the plugin to run a support log but it was not offering up the config page. I tried to disable/reenable but homeseer locked up when I tried to slide the switch. I had to cycle power to the Rpi. When HomeSeer came back up the plugin was disabled. I reenabled and got the log (attached). I took a snaphot of the Homeseer log screen as well (attached). I can't really decipher the logs beyond knowing there was an error. Is there someway I could run a loop back test every half hour or so?

                    Please advise.

                    Thanks,
                    Click image for larger version

Name:	Screen Shot 2020-01-30 at 4.39.22 PM.png
Views:	50
Size:	208.9 KB
ID:	1357934Click image for larger version

Name:	Screen Shot 2020-01-30 at 5.14.01 PM.png
Views:	26
Size:	407.5 KB
ID:	1357935

                    Comment


                    • #40
                      the error in the log was generated at startup, and will not cause the plugin to malfunction. The routine that caused the error does an upgrade on any hidden door sensor hs devices. Its enclosed in a try/catch. so that is not the culprit.

                      did you review the hs log using a filter to view only the Insteon entries?

                      i need an error log at the time the plugin crashed. i think its time to simulate some power outages, and watch the hs log to see what the plugin is doing. Enabled detailed logging in the plugin before testing.

                      Mark

                      HS3 Pro 3.0.0.534
                      Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                      Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                      Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                      Comment


                      • #41
                        OK I've got a few things happening here so can't do the power outages for a couple of weeks. . I will action that part and get back to you.

                        But in the meantime: So you need the HS log file filtered for lines with the keyword Insteon and in the date range of say.. January 28th to 30th 5:00PM? Just so we're on the same page, what do you recommend to use as a way to do this so nothing slips through the filters. I have both Mac OS and Windows 10 so let me know what process you have had the most success with. As I recall it was in a database format that did not show everything in a text viewer.

                        Just to be sure...what is the exact name and location of the hs log file you want me to filter?

                        Please advise.

                        Thanks,

                        Brian

                        Comment


                        • #42
                          Can you first just filter the hs Log using the built in Filter feature. Select Type as Insteon then click apply

                          then look through the entries for anything related to the power outage, errors, etc
                          Mark

                          HS3 Pro 3.0.0.534
                          Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                          Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                          Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                          Comment


                          • #43
                            As requested attached. I can't pull up any log activity prior to 5:45PM which is around the time I had to reboot. I set the filters from 1:00AM to 8:00pm which is all it would allow. It won't let me select any dates other then today. WIll there be older data in the hs log db file itself?
                            Attached Files

                            Comment


                            • #44
                              Brian

                              i dont see anything unusual in the log you provided. there might be older hs log database files in the homeseer log folder. you should be able to open them with a sqlite database browser tool.

                              If hs is locking up, there is something else going on. the plugin runs in its own memory space, so if the plugin crashes, it has no impact on HS.

                              I don't know anything about the platform you are running HS on, but you should find some tools that will allow you to monitor running processes, and a tool to review OS logs to see if they can shed any light on what's going on.
                              Mark

                              HS3 Pro 3.0.0.534
                              Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                              Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                              Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                              Comment


                              • #45
                                Most of the crashes just causes loss of Insteon action but not a HomeSeer crash. I can still usually navigate and interact with the plugin.

                                I will go look for older log files.

                                The linux environment and HS3Pi program comes as one image from HomeSeer.

                                Comment

                                Working...
                                X