Announcement

Collapse
No announcement yet.

Syncing 2 Dual-Band LampLinc

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • mnsandler
    replied
    if the two lamplincs are in a group with a controller device, the plugin will try to update them as well. if the controller goes off, the lamplincs will go off

    Leave a comment:


  • steveng
    replied
    That worked they both turn on/off via any method I test (alexa, HS, manually, etc...)

    There is still a ghost that will turn them on then off when I use other insteon switches, I will capture a log with detail as the normal log only shows them turn on and then off after another switch is turned off. Is there possible a group code being sent out they pick up that no other device uses (these are the only 2 plug in dimmer models I have)?

    Thanks for the help
    Steven G

    Leave a comment:


  • mnsandler
    replied
    i posted beta 3.0.7.18 to the beta section of the Updater. Please test and report back

    Leave a comment:


  • mnsandler
    replied
    ok. so that's good to hear. I can fix the plugin based on this information. I'll post an note here once i have a new beta for you to test.

    Leave a comment:


  • steveng
    replied
    IF This event is MANUALLY triggered
    Then Send Living Room Lamp CMD1: 34, CMD2: FC

    Turns on only Living Room Lamp (HS and actual lamp)

    Jan-26 7:17:54 PM Insteon Setting status and value for device 3A.5B.25:1. Old status:0 Old Value:0, New Status:2 New Value:100
    Jan-26 7:17:54 PM Insteon Received a Direct ACK from Living Room Lamp (3A.5B.25): 3A 5B 25 4E AD BA 2F 34 FC
    Jan-26 7:17:54 PM Insteon ..Got Hub Response 02 62 3A 5B 25 0F 34 FC 06
    Jan-26 7:17:54 PM Insteon Received STX 0x50 (Raw Insteon Rec):3A 5B 25 4E AD BA 2F 34 FC
    Jan-26 7:17:54 PM Insteon Sending http://XX.XX.XX.XX:25105/1?XB=M=1
    Jan-26 7:17:54 PM Insteon ..My XML buffer: 02623A5B250F34FC0602503A5B254EADBA2F34FC
    Jan-26 7:17:53 PM Insteon Sending http://XX.XX.XX.XX:25105/3?02623A5B250F34FC=I=3
    Jan-26 7:17:53 PM Insteon Sending command 02 62 3A 5B 25 0F 34 FC to Hub, (Expecting 0 bytes extra back) Pre-Payload ACK:False, NAK is ok:False
    Jan-26 7:17:53 PM Event Event Trigger "Admin New Event"
    Jan-26 7:17:53 PM Event Event Admin New Event triggered by the event page 'Run' button.


    ************************************************************ *******************

    IF This event is MANUALLY triggered
    Then Send Frontdoor Front Lamp CMD1: 34, CMD2: FC

    Turns on only Frontdoor Front Lamp (HS and actual lamp)

    Jan-26 7:18:06 PM Insteon Setting status and value for device 3A.47.93:1. Old status:0 Old Value:0, New Status:2 New Value:100
    Jan-26 7:18:06 PM Insteon Received a Direct ACK from Frontdoor Front Lamp (3A.47.93): 3A 47 93 4E AD BA 2F 34 FC
    Jan-26 7:18:06 PM Insteon Received STX 0x50 (Raw Insteon Rec):3A 47 93 4E AD BA 23 34 FC Debouncing repeat.
    Jan-26 7:18:06 PM Insteon Received STX 0x50 (Raw Insteon Rec):3A 47 93 4E AD BA 2F 34 FC
    Jan-26 7:18:06 PM Insteon ..Got Hub Response 02 62 3A 47 93 0F 34 FC 06
    Jan-26 7:18:06 PM Insteon Sending http://XX.XX.XX.XX:25105/1?XB=M=1
    Jan-26 7:18:06 PM Insteon ..My XML buffer: 02623A47930F34FC0602503A47934EADBA2F34FC02503A47934EADBA2334 FC
    Jan-26 7:18:05 PM Insteon Sending http://XX.XX.XX.XX:25105/3?02623A47930F34FC=I=3
    Jan-26 7:18:05 PM Insteon Sending command 02 62 3A 47 93 0F 34 FC to Hub, (Expecting 0 bytes extra back) Pre-Payload ACK:False, NAK is ok:False
    Jan-26 7:18:05 PM Event Event Trigger "Admin New Event - Copy"
    Jan-26 7:18:05 PM Event Event Admin New Event - Copy triggered by the event page 'Run' button.


    Thanks,
    Steven

    Leave a comment:


  • mnsandler
    replied
    the lamplinc is responding like it executed the command but in actuality, it didnt. this explains why the hs status is getting updated.

    lets try this: change the event action to "insteon send device command" and set the parameters to 34 and FC. then retest to see if the lamplinc responds

    Leave a comment:


  • steveng
    replied
    This does not turn lamps on but it does change status in HS to on.

    Jan-25 10:03:18 PM Insteon Setting status and value for device 3A.47.93:1. Old status:100 Old Value:100, New Status:2 New Value:100
    Jan-25 10:03:18 PM Insteon Received a Direct ACK from Frontdoor Front Lamp (3A.47.93): 3A 47 93 4E AD BA 2F 2E FC
    Jan-25 10:03:18 PM Insteon ..Got Hub Response 02 62 3A 47 93 0F 2E FC 06
    Jan-25 10:03:18 PM Insteon Received STX 0x50 (Raw Insteon Rec):3A 47 93 4E AD BA 2F 2E FC
    Jan-25 10:03:18 PM Insteon Sending http: //XX.XX.XX.XX:25105/1?XB=M=1
    Jan-25 10:03:18 PM Insteon ..My XML buffer: 02623A47930F2EFC0602503A47934EADBA2F2EFC
    Jan-25 10:03:18 PM Insteon Sending http: //XX.XX.XX.XX:25105/3?02623A47930F2EFC=I=3
    Jan-25 10:03:18 PM Insteon Sending command 02 62 3A 47 93 0F 2E FC to Hub, (Expecting 0 bytes extra back) Pre-Payload ACK:False, NAK is ok:False
    Jan-25 10:03:18 PM Event Event Trigger "Admin New Event"
    Jan-25 10:03:18 PM Event Event Admin New Event triggered by the event page 'Run' button


    Jan-25 10:03:55 PM Insteon Setting status and value for device 3A.5B.25:1. Old status:100 Old Value:100, New Status:2 New Value:100
    Jan-25 10:03:55 PM Insteon Received a Direct ACK from Living Room Lamp (3A.5B.25): 3A 5B 25 4E AD BA 2F 2E FC
    Jan-25 10:03:54 PM Insteon Received STX 0x50 (Raw Insteon Rec):3A 5B 25 4E AD BA 2F 2E FC
    Jan-25 10:03:54 PM Insteon ..Got Hub Response 02 62 3A 5B 25 0F 2E FC 06
    Jan-25 10:03:54 PM Insteon Sending http: //XX.XX.XX.XX:25105/1?XB=M=1
    Jan-25 10:03:54 PM Insteon ..My XML buffer: 02623A5B250F2EFC0602503A5B254EADBA2F2EFC
    Jan-25 10:03:53 PM Insteon Sending http: //XX.XX.XX.XX:25105/3?02623A5B250F2EFC=I=3
    Jan-25 10:03:53 PM Insteon Sending command 02 62 3A 5B 25 0F 2E FC to Hub, (Expecting 0 bytes extra back) Pre-Payload ACK:False, NAK is ok:False
    Jan-25 10:03:53 PM Event Event Trigger "Admin New Event - Copy"
    Jan-25 10:03:53 PM Event Event Admin New Event - Copy triggered by the event page 'Run' button.

    Leave a comment:


  • mnsandler
    replied
    Steven
    change the logging in the plugin to Detailed and retest. Post a log snippet of the hs log entries from the event transaction

    Leave a comment:


  • steveng
    replied
    I think you found something

    IF This event is MANUALLY triggered
    Then Set Frontdoor Front Lamp On Level 100% at Rate 6 Sec.

    IF This event is MANUALLY triggered
    Then Set Living Room Lamp On Level 100% at Rate 6 Sec.

    This did not work for either one and no action in log
    (also all motion sensors post double but we will save that for another day)
    Jan-25 4:13:50 PM Event Event Trigger "Admin New Event - Copy"
    Jan-25 4:13:50 PM Event Event Admin New Event - Copy triggered by the event page 'Run' button.
    Jan-25 4:13:45 PM Insteon Device Guest Room Motion Sensor (41.64.46) sent a heartbeat: Battery=Good, Temp=70, Light=0
    Jan-25 4:13:43 PM Insteon Device Guest Room Motion Sensor (41.64.46) sent a heartbeat: Battery=Good, Temp=70, Light=0
    Jan-25 4:13:31 PM Event Event Trigger "Admin New Event"
    Jan-25 4:13:31 PM Event Event Admin New Event triggered by the event page 'Run' button.
    Thanks,
    Steven

    Leave a comment:


  • mnsandler
    replied
    One last thing to try:
    create an event that runs the insteon action "Light on at ramprate", select one of the lamplincs as the device, set some On values, save and test that action

    see if the selected lamplincs actually comes on as expected to the settings

    I dont have a lamplinc w/ fw43 to test this. I tried it on my lamplinc with fw 41 and it worked.

    Leave a comment:


  • steveng
    replied
    Mark,

    The buttons on the devices work they both turn off and on when manually pushed on each.

    [Device 43]
    DatabaseDelta=14
    DeviceID=3A.47.93
    DeviceLocation=Frontdoor
    DeviceName=Front Lamp
    DeviceType=010E
    EEValues=LEDBrightness=0,DefaultOnLevel=254,DefaultRampRate= 28,OpFlags1=96
    FailedInteractions=1
    FirmwareVer=43
    HopData=967,909,31,27
    LastContact=12/1/2019 3:52:07 PM
    Link 1=A2 00 4E AD BA FF 1C 00 3
    Link 2=E2 01 4E AD BA 00 00 01 4
    Link 3=A2 FE 4E AD BA FF 1F 01 5
    Link 4=A2 01 3A 5B 25 FF 1C 01 1
    Link 5=E2 01 3A 5B 25 00 00 01 2
    LinksDownloaded=1
    NumLinks=5
    PollingInterval=0
    Protocol=3
    RecentDatabaseDelta=14
    SyncLinkedDevices=1
    TotalInteractions=246


    [Device 31]
    DatabaseDelta=7
    DeviceID=3A.5B.25
    DeviceLocation=Living Room
    DeviceName=Lamp
    DeviceType=010E
    EEValues=LEDBrightness=0,DefaultOnLevel=255,DefaultRampRate= 31,OpFlags1=96
    FailedInteractions=49
    FirmwareVer=43
    HopData=523,499,5,19
    LastContact=6/21/2018 9:07:59 PM
    Link 1=A2 00 4E AD BA 00 1C 01 1
    Link 2=E2 01 4E AD BA 00 00 01 2
    Link 3=A2 FE 4E AD BA FF 1C 01 3
    Link 4=E2 01 3A 47 93 00 00 01 4
    Link 5=A2 01 3A 47 93 FF 1C 01 5
    LinksDownloaded=1
    NumLinks=5
    PollingInterval=0
    Protocol=3
    RecentDatabaseDelta=7
    SyncLinkedDevices=1
    TotalInteractions=448

    Thanks,
    Steven

    Leave a comment:


  • mnsandler
    replied
    Looks like you have everything setup correctly. it seems like neither lamplinc is responding correctly to the sync command the plugin is sending

    I did notice the Frontdoor Front Lamp doesn't have a firmware version listed, this could be an issue.

    what happens if you control either lamplinc manually? does the opposite light come on?

    can you tell me the devicetype value for each lamplinc? you will need to look in the insteon.ini for this

    Leave a comment:


  • steveng
    started a topic Syncing 2 Dual-Band LampLinc

    Syncing 2 Dual-Band LampLinc

    I have 2 Dual-Band LampLinc that I am trying to turn off/on when either is on/off
    Both are set up with links to each other and have Sync linked responder device checked.

    Frontdoor Front Lamp
    Device Type: Dual-Band LampLinc
    Firmware Version:
    Comm Reliability: 100% (0 failed out of 148 cmds)
    Resume dim mode: False
    Default local on level: 100%

    Device Link Table
    Link #4 Outlet controls Living Room Lamp Outlet (3A.5B.25)
    Link #2 Outlet has local control reporting to HomeSeer
    Link #5 Outlet is controlled by Living Room Lamp (3A.5B.25) - On Level: 100%, Ramp Rate: .5 Sec.
    Link #1 Outlet is controlled by HomeSeer using Hub Group #0 (i2CS Registration Link) - On Level: 100%, Ramp Rate: .5 Sec.
    Link #3 Outlet is controlled by HomeSeer using Hub Group #254 (HomeSeer All Devices Group) - On Level: 100%, Ramp Rate: .5 Sec.

    Living Room Lamp
    Device Type: Dual-Band LampLinc
    Firmware Version: 43
    Comm Reliability: 100% (0 failed out of 388 cmds)
    Resume dim mode: False
    Default local on level: 100%

    Device Link Table
    Link #5 Outlet controls Frontdoor Front Lamp Outlet (3A.47.93)
    Link #2 Outlet has local control reporting to HomeSeer
    Link #4 Outlet is controlled by Frontdoor Front Lamp (3A.47.93) - On Level: 100%, Ramp Rate: .5 Sec.
    Link #1 Outlet is controlled by HomeSeer using Hub Group #0 (i2CS Registration Link) - On Level: 0%, Ramp Rate: .5 Sec.
    Link #3 Outlet is controlled by HomeSeer using Hub Group #254 (HomeSeer All Devices Group) - On Level: 100%, Ramp Rate: .5 Sec.

    When I turn them off (either one) both turn off and HS updates both as off
    When I turn Frontdoor Front Lamp on - only it comes on and both are updated to on in HS
    When i turn Living Room Lamp on - only it comes on and both are updated to on in HS

    LOG:
    Jan-23 11:36:19 PM Insteon Saving comm stats...
    Jan-23 11:36:13 PM Insteon Setting status and value for device 3A.47.93:1. Old status:0 Old Value:0, New Status:2 New Value:100
    Jan-23 11:36:13 PM Insteon Received a Direct ACK from Frontdoor Front Lamp (3A.47.93): 3A 47 93 4E AD BA 2F 2E FF
    Jan-23 11:36:13 PM Insteon Received STX 0x50 (Raw Insteon Rec):3A 47 93 4E AD BA 2F 2E FF
    Jan-23 11:36:13 PM Insteon ..Got Hub Response 02 62 3A 47 93 0F 2E FF 06
    Jan-23 11:36:13 PM Insteon Sending http://XX.XX.XX.XX:25105/1?XB=M=1
    Jan-23 11:36:13 PM Insteon ..My XML buffer: 02623A47930F2EFF0602503A47934EADBA2F2EFF
    Jan-23 11:36:11 PM Insteon Sending http://XX.XX.XX.XX:25105/3?02623A47930F2EFF=I=3
    Jan-23 11:36:11 PM Insteon Sending command 02 62 3A 47 93 0F 2E FF to Hub, (Expecting 0 bytes extra back) Pre-Payload ACK:False, NAK is ok:False
    Jan-23 11:36:11 PM Insteon Sending sync command 46 to linked responder device: Frontdoor Front Lamp (3A.47.93)
    Jan-23 11:36:11 PM Insteon SyncResponderDevices called for device code: 3A.5B.25:1
    Jan-23 11:36:11 PM Insteon Setting status and value for device 3A.5B.25:1. Old status:0 Old Value:0, New Status:2 New Value:100
    Jan-23 11:36:11 PM Insteon Received a Direct ACK from Living Room Lamp (3A.5B.25): 3A 5B 25 4E AD BA 2F 11 FF
    Jan-23 11:36:11 PM Insteon Received STX 0x50 (Raw Insteon Rec):3A 5B 25 4E AD BA 2F 11 FF
    Jan-23 11:36:11 PM Insteon ..Got Hub Response 02 62 3A 5B 25 0F 11 FF 06
    Jan-23 11:36:11 PM Insteon Sending http://XX.XX.XX.XX:25105/1?XB=M=1
    Jan-23 11:36:11 PM Insteon ..My XML buffer: 02623A5B250F11FF0602503A5B254EADBA2F11FF
    Jan-23 11:36:10 PM Insteon Sending http://XX.XX.XX.XX:25105/3?02623A5B250F11FF=I=3
    Jan-23 11:36:10 PM Insteon Sending command 02 62 3A 5B 25 0F 11 FF to Hub, (Expecting 0 bytes extra back) Pre-Payload ACK:False, NAK is ok:False
    Jan-23 11:36:10 PM Insteon CAPIControl: Label=On, Value=100, ControlType=Button
    Jan-23 11:36:10 PM Device Control Device: Downstairs Living Room Lamp to On (100) by/from: CAPI Control Handler
Working...
X