Announcement

Collapse
No announcement yet.

Interface Error after updating to 3.0.0.534 HS3 ZEE S2 (Linux)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Originally posted by mnsandler View Post
    I can't monitor how much space the log files use. each file is capped at 2GB. This is just part of system maintenance.
    Log files are only written when an error/exception occurs. there must be something in your system that is causing this and thus generating the log files.
    Can you review a few of the recent files and see if there is a common error?
    You said capped at 2GB? looks to me like every file is capped at ~2MB (i.e. 1,889 KB, or 2,168 KB).
    Each file is full of hundreds maybe thousands of lines of stuff with dates from 10/15/2019 to 11/15/2019.
    I don't care about that old error info, how do I get rid of it from the Insteon Error Report.Log? I reset and reprogrammed the PLM but I don't think that gets rid of it.

    Comment


      #17
      You're right 2MB, not 2GB. you should be able to delete the old log files via the Linux OS. You are correct, the plm has nothing to do with the error logs.

      What is the error msg of the most recent log file? It should be at the very beginning of the file.
      Mark

      HS3 Pro 3.0.0.534
      Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
      Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
      Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

      Comment


        #18
        Originally posted by mnsandler View Post
        What is the error msg of the most recent log file? It should be at the very beginning of the file.
        This is the top part of the Insteon Error Report.Log 1,889 KB 2/19/2020:

        "Insteon Plug-in Error Log Generated 11/11/2019 9:44:58 PM
        -----------*Error Message*----------------
        Error: Error in X10Event: Conversion from string "" to type 'Integer' is not valid. -- Details System.InvalidCastException: Conversion from string "" to type 'Integer' is not valid. ---> System.FormatException: Input string was not in a correct format.
        at System.Number.StringToNumber (System.String str, System.Globalization.NumberStyles options, System.Number+NumberBuffer& number, System.Globalization.NumberFormatInfo info, System.Boolean parseDecimal) <0x749e0400 + 0x00130> in <filename unknown>:0
        at System.Number.ParseInt32 (System.String s, System.Globalization.NumberStyles style, System.Globalization.NumberFormatInfo info) <0x749df090 + 0x000eb> in <filename unknown>:0
        at System.Int32.Parse (System.String s) <0x749aa628 + 0x0001f> in <filename unknown>:0
        at Microsoft.VisualBasic.CompilerServices.IntegerType.FromStrin g (System.String Value) <0x72ad4ae0 + 0x0003f> in <filename unknown>:0
        --- End of inner exception stack trace ---
        at Microsoft.VisualBasic.CompilerServices.IntegerType.FromStrin g (System.String Value) <0x72ad4ae0 + 0x000e4> in <filename unknown>:0
        at Microsoft.VisualBasic.CompilerServices.Conversions.ToInteger (System.String Value) <0x72ad4aa0 + 0x00013> in <filename unknown>:0
        at HSPI_Insteon.hspiAPI+HSCallback.X10Event (System.String Codes, System.String housecode, System.Int16 command, System.String extra, System.String data2) <0x71fb9110 + 0x001e7> in <filename unknown>:0 -- 11/11/2019 9:44:58 PM"

        I am going to delete the Insteon Error Report.log file. I have Insteon logging turned off anyway right now.

        Comment


          #19
          One of your x10 devices is sending a dim/bright or preset msg which is causing the problem
          Mark

          HS3 Pro 3.0.0.534
          Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
          Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
          Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

          Comment


            #20
            Originally posted by mnsandler View Post
            One of your x10 devices is sending a dim/bright or preset msg which is causing the problem
            So this:
            "HSCallback.X10Event (System.String Codes, System.String housecode, System.Int16 command, System.String extra, System.String data2) <0x71fb9110 + 0x001e7> in <filename unknown>:0 -- 11/11/2019 9:44:58 PM"
            tells you X10 caused the error reports? Is there any info here of which X10 module or command did it? I deleted the Insteon error log from the Zee S2, I can turn Insteon logging back on and see if any errors are reported. It might have been something I was doing last year adding candle events and modules.

            Comment


              #21
              i would need the entire log file to give you more detail.

              Otherwise, enabled detailed logging in the plugin and manually control your x10 devices (one at a time) and see if an error shows up in the hs log

              i'm wondering if you are trying to dim an on/off device, or maybe the preset x10 feature got turned on when the x10 device doesn't support it.

              Mark

              HS3 Pro 3.0.0.534
              Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
              Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
              Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

              Comment

              Working...
              X