Announcement

Collapse
No announcement yet.

Need some help with an Insteon error that won't go away

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Need some help with an Insteon error that won't go away

    The last Insteon command prior to seeing this error is a
    May-23 12:57:59 AM Insteon ** To request help with this problem please post this log file to the forum along with a detailed description of what lead to this problem.
    May-23 12:57:59 AM Insteon ** An error occurred in this plug-in. The details have been written to the log file - /usr/lib/HomeSeer/Config/Insteon Error Report.Log
    May-23 12:57:59 AM Insteon ***:Error in SendDirectMsg: Index was outside the bounds of the array. -- Details System.IndexOutOfRangeException: Index was outside the bounds of the array. at Insteon.Support.Core.InsteonModule.SendDirectMsg (Insteon.Support.Core.InsteonModule+TransmitMsgType Msg) [0x00215] in :0
    These event actions below seem to be related to these errors above that I'm seeing:

    Click image for larger version  Name:	Capture.PNG Views:	0 Size:	28.9 KB ID:	1387951

    Insteon Error Report.log (ZIPPED) attached.

    Any help or guidance appreciated,

    Regards,
    Andrew

    #2
    Andrew,
    thanks for posting the details and log. Would you please try the latest beta in the Updater. I think i may have fixed this issue already. The errors seem to be related to turning off the kitchen lights and updating the status to HS. I think your event is fine
    Mark

    HS3 Pro 3.0.0.534
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

    Comment


      #3
      Originally posted by mnsandler View Post
      Would you please try the latest beta in the Updater. I think i may have fixed this issue already.
      OK, updated. Will monitor tonight. Thanks so much.
      A

      Comment


        #4
        Originally posted by mnsandler View Post
        Would you please try the latest beta in the Updater. I think i may have fixed this issue already.
        OK, got same 4 errors last night:
        May-24 11:34:53 PM Insteon ** To request help with this problem please post this log file to the forum along with a detailed description of what lead to this problem.
        May-24 11:34:53 PM Insteon ** An error occurred in this plug-in. The details have been written to the log file - /usr/lib/HomeSeer/Config/Insteon Error Report.Log
        May-24 11:34:53 PM Insteon ***:Error in SendDirectMsg: Index was outside the bounds of the array. -- Details System.IndexOutOfRangeException: Index was outside the bounds of the array. at Insteon.Support.Core.InsteonModule.SendDirectMsg (Insteon.Support.Core.InsteonModule+TransmitMsgType Msg) [0x00215] in <3cba54d3fa7a43979665d1a70b63590a>:0
        May-24 11:34:51 PM Insteon ** To request help with this problem please post this log file to the forum along with a detailed description of what lead to this problem.
        May-24 11:34:51 PM Insteon ** An error occurred in this plug-in. The details have been written to the log file - /usr/lib/HomeSeer/Config/Insteon Error Report.Log
        May-24 11:34:51 PM Insteon ***:Error in SendDirectMsg: Index was outside the bounds of the array. -- Details System.IndexOutOfRangeException: Index was outside the bounds of the array. at Insteon.Support.Core.InsteonModule.SendDirectMsg (Insteon.Support.Core.InsteonModule+TransmitMsgType Msg) [0x00215] in <3cba54d3fa7a43979665d1a70b63590a>:0
        May-24 11:34:49 PM Insteon ** To request help with this problem please post this log file to the forum along with a detailed description of what lead to this problem.
        May-24 11:34:49 PM Insteon ** An error occurred in this plug-in. The details have been written to the log file - /usr/lib/HomeSeer/Config/Insteon Error Report.Log
        May-24 11:34:49 PM Insteon ***:Error in SendDirectMsg: Index was outside the bounds of the array. -- Details System.IndexOutOfRangeException: Index was outside the bounds of the array. at Insteon.Support.Core.InsteonModule.SendDirectMsg (Insteon.Support.Core.InsteonModule+TransmitMsgType Msg) [0x00215] in <3cba54d3fa7a43979665d1a70b63590a>:0
        May-24 11:34:45 PM Insteon ** To request help with this problem please post this log file to the forum along with a detailed description of what lead to this problem.
        May-24 11:34:45 PM Insteon ** An error occurred in this plug-in. The details have been written to the log file - /usr/lib/HomeSeer/Config/Insteon Error Report.Log
        May-24 11:34:45 PM Insteon ***:Error in SendDirectMsg: Index was outside the bounds of the array. -- Details System.IndexOutOfRangeException: Index was outside the bounds of the array. at Insteon.Support.Core.InsteonModule.SendDirectMsg (Insteon.Support.Core.InsteonModule+TransmitMsgType Msg) [0x00215] in <3cba54d3fa7a43979665d1a70b63590a>:0
        Insteon Error Log attached.
        Attached Files

        Comment


          #5
          did you post the right report file? the last timestamp in the attached log is
          5/24/2020 1:28:05 AM
          the timestamps above are later in the day



          Mark

          HS3 Pro 3.0.0.534
          Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
          Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
          Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

          Comment


            #6
            Originally posted by mnsandler View Post
            did you post the right report file? the last timestamp in the attached log is


            the timestamps above are later in the day


            Ah! My bad. I think when I updated the plugin I forgot to enable logging. What a duzy. OK, next 24 hour cycle! Sorry!

            I did wonder why there was not just a filename "Insteon Error Report". That should have told me right there...

            Comment


              #7
              Originally posted by mnsandler View Post
              did you post the right report file? the last timestamp in the attached log is
              the timestamps above are later in the day
              and Voila! The Error Report now magically has the details from last night... Atatched
              Attached Files

              Comment


                #8
                There is something going on with the kitchen lights specifically (of 2)...(of 5) when they are trying to be turned Off.

                (1) what triggers this?

                (2) do the switches get turned off correctly despite the error?

                (3) are the associated HS devices updated correctly?
                Mark

                HS3 Pro 3.0.0.534
                Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                Comment


                  #9
                  Originally posted by mnsandler View Post
                  There is something going on with the kitchen lights specifically (of 2)...(of 5) when they are trying to be turned Off.

                  (1) what triggers this?
                  Same event as before, except I thought it was the Special Op Flag settings. Here is the event details above the Special Op stuff:

                  Click image for larger version

Name:	Capture.PNG
Views:	53
Size:	41.7 KB
ID:	1388486

                  Originally posted by mnsandler View Post
                  (2) do the switches get turned off correctly despite the error?
                  YUP. All switched off fine.

                  Originally posted by mnsandler View Post
                  (3) are the associated HS devices updated correctly?
                  As far as I know. Here's the entire Insteon config for one of the LampLincs:


                  Click image for larger version

Name:	Capture.PNG
Views:	52
Size:	371.5 KB
ID:	1388487

                  Thanks for all your help on this one, thought it would be simple user error at my end...

                  Andrew

                  Comment


                    #10
                    how about creating one Insteon Group to turn all those devices Off at once instead of a bunch of individual commands. this would be faster and more reliable.

                    as for the insteon special triggers, there is a select item after the standard hs triggers when you start a new trigger
                    Mark

                    HS3 Pro 3.0.0.534
                    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                    Comment


                      #11
                      Originally posted by mnsandler View Post
                      how about creating one Insteon Group to turn all those devices Off at once instead of a bunch of individual commands. this would be faster and more reliable.
                      OK, did that. WIll monitor. Thx

                      Originally posted by mnsandler View Post
                      as for the insteon special triggers, there is a select item after the standard hs triggers when you start a new trigger
                      OK, numpty me, I found it. So other than when HS events don't let you trigger off Button A on a keypad ON, when would you use these instead of generic triggers? I presume a Fast On is a double tap On, correct?

                      Click image for larger version  Name:	Capture.PNG Views:	0 Size:	34.4 KB ID:	1388517

                      Comment


                        #12
                        double tap does produce a Fast On or Off trigger. very convenient to trigger another event. i use it to turn off all the lights in a given room.

                        i use the special triggers exclusively. they are faster to trigger events since the plugin seems them before hs sees a status change.

                        Mark

                        HS3 Pro 3.0.0.534
                        Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                        Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                        Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                        Comment


                          #13
                          Originally posted by mnsandler View Post
                          double tap does produce a Fast On or Off trigger. very convenient to trigger another event. i use it to turn off all the lights in a given room.

                          i use the special triggers exclusively. they are faster to trigger events since the plugin seems them before hs sees a status change.
                          Ah... Curious, but related question. Do the Insteon Switches (not dimmers) support Fast ON. I have timers on vent fans that might benefit from only being enabled with a double tap...

                          Thanks,
                          Andrew

                          Comment


                            #14
                            on/off switches support fast on and fast off as well.
                            Mark

                            HS3 Pro 3.0.0.534
                            Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                            Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                            Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                            Comment


                              #15
                              The switches and dimmers support fast on from the point of view of sending a different code whether you single-click or double-click the paddle (on or off). Turning the load on is local to the switch, so when you tap the paddle, the load goes on at the pre-set ramp rate (dimmers). If you double-tap the paddle, the load goes on at the fastest rate. So, that doesn't work for what you want on your vent fans. What I've done for that is set up an event triggered by Insteon Special Trigger "Transmits an On Command", which turns the switch off. So if someone accidently hits the paddle and turns your fan on, the event immediately shuts it off again. There is a slight blip on between pushing the paddle and the event shutting it off again, but at least it doesn't run at length when not wanted.

                              One of the most useful features of the Insteon Special Triggers "Transmits an xx Command", is that the event will trigger regardless of the current switch condition. So even if the switch is already ON, and you tap the ON paddle, the event will trigger. The regular HS triggers only work if the switch status changes. For example, if the switch is ON and you tap the ON paddle, the event won't trigger unless you tap OFF and then ON again. The Insteon Special Triggers overcome that.

                              Comment

                              Working...
                              X