Announcement

Collapse
No announcement yet.

Reprogram Device

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Reprogram Device

    I was having some trouble with a couple of linked switches so went into the insteon plugin to reprogram them with the Reprogram Device button & never get the Continue Button. It just seems to hang. But watching the log shows "The Insteon device was successfully reprogrammed." I am also seeing an error in the log "Trouble converting [] to integer". Ran on several devices with the same results. Running HS 4.1.0.0.

    #2
    The UI issue is just an incompatibility between the v3 plugin and HS4.

    regarding "Trouble converting [] to integer", can you enable detailed logging within the plugin and capture the same error and post a log snippet
    Mark

    HS3 Pro 3.0.0.534
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

    Comment


      #3
      Thanks,

      Attached the log Files.
      Attached Files

      Comment


        #4
        can you post the list of links from the from the Insteon Laundry Room - Door Switch (48.75.10) device. i can't tell if they have all been read correctly
        Mark

        HS3 Pro 3.0.0.534
        Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
        Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
        Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

        Comment


          #5
          Link #1 Load controls Insteon Laundry Room - Office Switch (2) Load (48.55.1A)
          Link #4 Load has local control reporting to HomeSeer
          Link #5 Load is controlled by Insteon Laundry Room - Office Switch (2) (48.55.1A) - On Level : On
          Link #2 Load is controlled by HomeSeer using RF PLM Group #0 (i2CS Registration Link) - On Level : Off
          Link #3 Load is controlled by HomeSeer using RF PLM Group #24 Registered Group #14 'Insteon All Lights' - On Level : On

          Link #6 Load is controlled by HomeSeer using RF PLM Group #254 (HomeSeer All Devices Group) - On Level : On

          Comment


            #6
            are you still having troubles with the linked switches you originally mentioned?
            Mark

            HS3 Pro 3.0.0.534
            Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
            Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
            Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

            Comment


              #7
              No they are working properly.

              Jim

              Comment


                #8
                But whenever I reprogram a insteon device I see the "Trouble converting [] to integer" in the log. Does not seem to be effecting anything.

                Comment


                  #9
                  have you tried a factory reset on device and then used the reprogram device function to recreate the links?
                  Mark

                  HS3 Pro 3.0.0.534
                  Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                  Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                  Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                  Comment


                    #10
                    Just did a factory reset on a light switch & then used the reprogram device function to recreate the links. The switch reprogrammed properly by still "Trouble converting [] to integer" in the log.

                    Comment


                      #11
                      Very strange. can you post the [device x] section from the insteon.ini for the device you just reset and reprogrammed
                      Mark

                      HS3 Pro 3.0.0.534
                      Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                      Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                      Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                      Comment


                        #12
                        Attached
                        Attached Files

                        Comment


                          #13
                          that all looks fine. if you aren't seeing any other side affects, lets not worry about the error right now.

                          i dont plan to spend time modifying the hs3 plugin for hs4. I'm working on a new hs4 plugin.

                          there are a few other hs4 issues reported that i just can't fix at this point.

                          despite what hst says, hs3 plugins aren't 100% compatible with hs4.
                          Mark

                          HS3 Pro 3.0.0.534
                          Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                          Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                          Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                          Comment


                            #14
                            No other side effects that I can see. I was planning on upgrading to your new HS4 plugin when published. Made to many changes since upgrading to HS4 beta to be able to easily go back to HS3.

                            Comment


                              #15
                              The Motion Sensor II configuration will give this error if nothing is selected in the mode Combox

                              Comment

                              Working...
                              X