Announcement

Collapse
No announcement yet.

Using the Stop Ramp from a dimmer in and HS event.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Using the Stop Ramp from a dimmer in and HS event.

    I have a few insteon dimmers with blow live load triacs so I'm using them to control RBGWW LED strips on a Z-Wave controller. The ON and OFF events work just fine but I can't find a way to set the dimming level using and HS3 event. I see the following in the log:

    Jul-25 1:23:37 PM Insteon Received Kitchen Kitchen - Over Cabinet Lights (18.2E.9F) Stop Ramp
    Jul-25 1:23:35 PM Insteon Received Kitchen Kitchen - Over Cabinet Lights (18.2E.9F) Start Ramp

    but there doesn't seem to be a "Stop Ramp" value I can trigger on so that I can read and set the dimmer value...
    any ideas?
    Thanks

    #2
    try the insteon action lights on at ramp rate
    Mark

    HS3 Pro 3.0.0.534
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

    Comment


      #3
      I know this isn't what you're asking, but the Insteon dimmer Triacs are easily replaceable if you have a soldering iron. I forget the part number, but its readable on the triac and readily available at DigiKey or Mouser. I've done a couple that were taken out by a faulty dimmable CFL bulb.

      Comment


        #4
        Originally posted by Burrington View Post
        I know this isn't what you're asking, but the Insteon dimmer Triacs are easily replaceable if you have a soldering iron. I forget the part number, but its readable on the triac and readily available at DigiKey or Mouser. I've done a couple that were taken out by a faulty dimmable CFL bulb.
        Hi, thank you I think I still have one that was removed and isn't installed somewhere else yet which I will try out. The others are already installed and are perfect for controlling the RGBW dimmers (Qubino).

        Comment


          #5
          Originally posted by mnsandler View Post
          try the insteon action lights on at ramp rate
          Thanks Mark, but forgive me for asking this ... but where is this? Under the "Plugins | Insteon | Configuration", under Events or somewhere else?

          I tried creating an event but I can't figure out how to read the dimming value setting to set the RGBW controller:

          Click image for larger version

Name:	Annotation 2020-07-26 082719.jpg
Views:	49
Size:	66.8 KB
ID:	1405981

          Thanks

          Comment


            #6
            I guess i didn't understand what you were trying to do.

            you will need to write a script command using hs.setdevicevaluebyref to set your rgbw device value to a value of another device. i dont think that functionality exists as native event action
            Mark

            HS3 Pro 3.0.0.534
            Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
            Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
            Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

            Comment


              #7
              That's what I thought Thank you

              Comment


                #8
                Coming back to this thread and sort of related; I just got a KeypadLinc that works but the main load buttons won't dim ... the load is either on or off using the physical buttons and setting the dim value does nothing (unless it is 100%). Any known fix for this? I can't return the item (bought on cheatBay).

                Comment


                  #9
                  Originally posted by lockon View Post
                  Coming back to this thread and sort of related; I just got a KeypadLinc that works but the main load buttons won't dim ... the load is either on or off using the physical buttons and setting the dim value does nothing (unless it is 100%). Any known fix for this? I can't return the item (bought on cheatBay).
                  did you try a factory reset on the device?
                  Mark

                  HS3 Pro 3.0.0.534
                  Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                  Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                  Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                  Comment


                    #10
                    Originally posted by mnsandler View Post

                    did you try a factory reset on the device?
                    yes I now have two improperly working KeypadLincs The original one has intermittent comms and this one that won't dim.

                    Comment


                      #11
                      Originally posted by lockon View Post

                      yes I now have two improperly working KeypadLincs The original one has intermittent comms and this one that won't dim.
                      what is the fw ver of the "new" one?
                      Mark

                      HS3 Pro 3.0.0.534
                      Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                      Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                      Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                      Comment


                        #12
                        Originally posted by lockon View Post
                        Coming back to this thread and sort of related; I just got a KeypadLinc that works but the main load buttons won't dim ... the load is either on or off using the physical buttons and setting the dim value does nothing (unless it is 100%). Any known fix for this? I can't return the item (bought on cheatBay).
                        Are you sure you have the dimmable version? Keypadlincs are sold with Triacs (dimmable), and relays (not dimmable).

                        Comment


                          #13
                          Originally posted by joegr View Post

                          Are you sure you have the dimmable version? Keypadlincs are sold with Triacs (dimmable), and relays (not dimmable).
                          I didn't know that! However, I just confirmed it is supposed to be a dimmable version:

                          Click image for larger version

Name:	2020-07-28 10.59.08s.jpg
Views:	27
Size:	196.8 KB
ID:	1406721

                          Comment


                            #14
                            Originally posted by mnsandler View Post

                            what is the fw ver of the "new" one?
                            Hi Mark,

                            Firmware:45 (HW Rev 8.8 0219)

                            Here is the log from the tap add:


                            Jul-28 12:07:35 PM Insteon Edit Insteon Device #25 Addr: 52.2B.E6, Name:Tap-Added Dual-Band KeypadLinc Dimmer 0, Location:Unknown
                            Jul-28 12:07:23 PM Insteon Tap-add mode added a new Insteon device, #25 at Address 52.2B.E6(Dual-Band KeypadLinc Dimmer)
                            Jul-28 12:07:22 PM Insteon Attempting to update the status for Unknown Tap-Added Dual-Band KeypadLinc Dimmer 0 (52.2B.E6)
                            Jul-28 12:07:21 PM Insteon Found unused link #21 in our address space, assigning for use.
                            Jul-28 12:07:21 PM Insteon Found unused link #20 in our address space, assigning for use.
                            Jul-28 12:07:21 PM Insteon Found unused link #19 in our address space, assigning for use.
                            Jul-28 12:07:21 PM Insteon Found unused link #14 in our address space, assigning for use.
                            Jul-28 12:07:21 PM Insteon Found unused link #13 in our address space, assigning for use.
                            Jul-28 12:07:21 PM Insteon Reloading 25 Insteon device information tables...
                            Jul-28 12:07:21 PM Insteon Reloading 5 Insteon group information tables...
                            Jul-28 12:07:21 PM Insteon ..finished saving comm stats.
                            Jul-28 12:07:21 PM Insteon Saving comm stats...
                            Jul-28 12:07:21 PM Insteon Calling AddRecord for 52.2B.E6 254 False
                            Jul-28 12:07:21 PM Insteon Calling AddRecord for 52.2B.E6 6 True
                            Jul-28 12:07:20 PM Insteon Calling AddRecord for 52.2B.E6 5 True
                            Jul-28 12:07:20 PM Insteon Calling AddRecord for 52.2B.E6 4 True
                            Jul-28 12:07:20 PM Insteon Calling AddRecord for 52.2B.E6 3 True
                            Jul-28 12:07:19 PM Insteon Calling AddRecord for 52.2B.E6 1 True
                            Jul-28 12:07:19 PM Insteon Got Op Flags response from Insteon ID 52.2B.E6, Op Flags 05=0D
                            Jul-28 12:07:19 PM Insteon Got Op Flags response from Insteon ID 52.2B.E6, Op Flags 00=00
                            Jul-28 12:07:12 PM Insteon Calling AddRecord for 52.2B.E6 1 True
                            Jul-28 12:07:12 PM Insteon Attempting to add Device 52.2B.E6
                            Jul-28 12:07:12 PM Insteon Set tap add job data: Name:Tap-Added Dual-Band KeypadLinc Dimmer 0 Type:0142 Firmware:45
                            Jul-28 12:07:12 PM Insteon Considering link complete as a tap-add request from device 52.2B.E6 (Dual-Band KeypadLinc Dimmer)

                            Comment


                              #15
                              what is the default on level for the dimmer? have you tried setting it to 80% and see if the physical switch will respond accordingly

                              Mark

                              HS3 Pro 3.0.0.534
                              Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                              Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                              Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                              Comment

                              Working...
                              X