Announcement

Collapse
No announcement yet.

"Enable the IO interface" - where is that setting in HS4?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    "Enable the IO interface" - where is that setting in HS4?

    New HS4 user (zero previous HS experience). Trying to add MS's Insteon plugin...

    In the "getting started" guide it says:

    4. HS2: Restart HS and goto the HS setup/interface page, and Enable the IO Interface. If you use X10, enable that interface as well.
        HS3: Restart HS, go to the Manage/Plugin page and enable the plugin. Enable X10 on the plugin config page if necessary.


    Does anyone know where to enable the IO interface in HS4?

    #2
    Go to the Plugins menu and select 'installed'
    Jon

    Comment


      #3
      welcome to homeseer and insteon.

      for the record, my hs3 plugin has some UI issues with hs4. i do not guarantee 100% compatibility.

      you should be able to find the plugin Config page from the Manage Plugin hs page.
      Mark

      HS3 Pro 3.0.0.534
      Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
      Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
      Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

      Comment


        #4
        Originally posted by mnsandler View Post
        welcome to homeseer and insteon.

        for the record, my hs3 plugin has some UI issues with hs4. i do not guarantee 100% compatibility.

        you should be able to find the plugin Config page from the Manage Plugin hs page.
        Thanks, Mark - I've been reading through this forum and understand about HS4. My ISY is in the process of dying so unfortunately I don't have the luxury of waiting.

        Here is what I see on my config page for your plugin:



        Comment


          #5
          Double check Windows device manager to make sure where the right Com port is!



          Eman.
          TinkerLand : Life's Choices,"No One Size Fits All"

          Comment


            #6
            Originally posted by Eman View Post
            Double check Windows device manager to make sure where right Com port is!



            Eman.
            Thanks Eman - here is what I see in windows 10:

            Comment


              #7
              Originally posted by greedylittle View Post

              Thanks Eman - here is what I see in windows 10:
              When you click save in HS4 plugin settings do you get the UI page recycle? If it doesn't then that is HS$4 issue!

              Are you using a USB to Serial Converter cable ? : mnsandler ==> (You may need FTDI drivers) post #6 :https://forums.homeseer.com/forum/li...-in#post667587




              Eman.
              TinkerLand : Life's Choices,"No One Size Fits All"

              Comment


                #8
                Originally posted by Eman View Post

                When you click save in HS4 plugin settings do you get the UI page recycle? If it doesn't then that is HS$4 issue!

                Are you using a USB to Serial Converter cable ? : mnsandler ==> (You may need FTDI drivers) :https://forums.homeseer.com/forum/li...-in#post667587

                Eman.
                The page does refresh.

                I'm not certain how I can troubleshoot the connection between the PLM and the computer - any ideas?

                Comment


                  #9
                  Originally posted by Eman View Post

                  Are you using a USB to Serial Converter cable ? : mnsandler ==> (You may need FTDI drivers) post #6 :https://forums.homeseer.com/forum/li...-in#post667587


                  Eman.
                  I completely missed the second portion of your post. Yes, I am using a USB to Serial converter. I've installed the FTDI drivers per Mark's post.

                  No change.

                  The PLM was working fine as recently as this morning with the ISY. This is certainly a frustrating roadblock!

                  Comment


                    #10
                    Originally posted by greedylittle View Post

                    The page does refresh.

                    I'm not certain how I can troubleshoot the connection between the PLM and the computer - any ideas?
                    If you have add a USB to Serial cable to the PLM, then you have to install the FTDI driver before things start communicating but if you did then that's a HS4 issue as mnsandler mentioned earlier that there may be bugs with HS4 (post #3)



                    Eman.
                    TinkerLand : Life's Choices,"No One Size Fits All"

                    Comment


                      #11
                      Originally posted by Eman View Post

                      If you have add a USB to Serial cable to the PLM, then you have to install the FTDI driver before things start communicating but if you did then that's a HS4 issue as mnsandler mentioned earlier that there may be bugs with HS4 (post #3)



                      Eman.
                      I appreciate all the help/suggestions. I had installed the FTDI driver per Mark's getting started directions. I just tried rebooting everything and Im getting the same error. I'll play around with it a bit more and if I can't get it figured out I'll order the Hub and give it a try.

                      Comment


                        #12
                        greedylittle ,

                        If everything has failed then check your PM


                        Eman.
                        TinkerLand : Life's Choices,"No One Size Fits All"

                        Comment


                          #13
                          Is it the correct port? Is the port enabled? Are the settings for the port correct?

                          Here are some ideas:


                          1) Go into Device Manager by: Right-click Start Icon > Device Manager > expand "Ports"
                          Unplug the USB adapter from the PC and watch which port disappears, then reappears when you plug it back in. That will confirm the correct port number for the PLM.

                          2) Make sure there is no " ! " in front of the port name which would mean the port is not working properly.

                          3) Dbl-click "Prolific..." to bring up the port's properties. Make sure it says "This device is working properly." under details in the General Tab.

                          4) Click the "Driver" tab and make sure it shows the "Prolific" driver.

                          5) Go to the "Port Settings" tab and make sure the port is set correctly for the PLM which wants:
                          9600 baud, 8 data bits, No parity, 1 stop bit, no flow control.

                          6) Also in Device manager, expand the "Universal Serial Bus Controllers" list and find the one the PLM is connected to (you might have to pull the plug again). Double-click it for Properties and click the "Power Management" tab. Un-check the box "Allow the computer to turn off this device to save power". If you don't do this, the computer will shut down the PLM during periods of inactivity, but it never seems to turn it on again until you reboot the PC. If you have the USB-Serial adapter connected via a USB Hub instead of directly, you need to do this same thing for the Hub, otherwise the PC will shut off the hub and the PLM will go down with it.

                          Comment


                            #14
                            Thank you Burrington for the actionable advice. I went down your list - everything is as expected/you described until I get to step 6.

                            Nothing changed in the list of the "Universal Serial Bus Controllers" when I unplug the cable (image attached)

                            I guess I either have 1)a driver issue or 2)a bad cable (either ethernet -> serial or serial -> USB)

                            Im a mac power user (this is the first windows computer I've used in 10 years) so all this driver stuff is confusing!! I genuinely appreciate all the tips!

                            Comment


                              #15
                              I've ordered replacement cables (different brands) that will arrive on Wednesday. Will give it a fresh try then...

                              Comment

                              Working...
                              X