Announcement

Collapse
No announcement yet.

Configure FanLinc and Keypad

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Configure FanLinc and Keypad

    I hope you will indulge a newbie's question. I am trying to figure out how to configure a KPL and FanLinc to work via HomeSeer. I am running HS4 v4.1.8.0 and the insteon plugin v.3.0.7.1 . I have these devices set up and working correctly in the Insteon app. I've tried adding these devices to HS via the plugin in various configurations - Just the KLP; just the FanLinc; both. With sync linked responder devices checked an unchecked. The best result I have achieved was a HS "device" that would allow me to control the fan. I have been unable to configure things to show, let alone control, the light. I've tried to research the forum, but most posts appear to address implementations that are far more complex than what I am trying to accomplish. I'm hoping someone can provide a straight forward, step-by-step, list to configure these devices so they will work in HS. I have noted that the plugin "reports" a number of "unregistered Insteon addresses." Three for the FanLinc and two for the Keypad. I have no idea what this is telling me... I appreciate any and all help folks my be able to provide... Best regards - J

    #2
    here are a few related thread

    basically, if you are using a 6 btn kpl as the controller, you will create a radio group with btns a-d to represent high, med, low, off, for the fan speed. create links from each btn to the fanlinc fan device with the approp fan speed setting. the kpl on/off btns will controll the fanlinc light.

    https://forums.homeseer.com/forum/li...eypadlinc-pair

    https://forums.homeseer.com/forum/li...rol-and-events
    Mark

    HS3 Pro 3.0.0.534
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

    Comment


      #3
      Thanks for the quick response! but this is where my "newbie" status comes in to play. Yes, I am using a 6 btn kpl as the controller. Where in the plugin interface do I go to create the radio group? I know nothing about this plugin and need to start from scratch. The "?" help icons do not seem to work so I have no additional information to draw from. When I look at the device link table for the kpl, I see (channels) 1 (Button On/Load), 2 (Button A), 3 Button B), 3 (Button C). So is On/Load actually button D? On this page, I can only set/change button groups for buttons A and B. I do not have this option for On/Load or C. Where/how do I configure the on/off buttons for the light? This is the function I have been unable to create at all. I have been able to create a HS device to control the fan just by adding the FanLinc, but using the HS device to change the fan speed does not change the kpl lights. Help!...

      Click image for larger version

Name:	Insteon Device 1.png
Views:	54
Size:	417.7 KB
ID:	1427424

      Comment


        #4
        from your screen shot, you need to change the button mode of the 4 buttons to radio group, then save the changes. the plugin will program the kpl.

        create a link from the kpl On btn to the fanlinc light device


        Mark

        HS3 Pro 3.0.0.534
        Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
        Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
        Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

        Comment


          #5
          My options for "Button Mode" are "Toggle" or "Non-Toggle On." I have options for "Radio Group" 1 and "Radio Group 2" under "Button Groups." However, I only have these options for Buttons A and B (as reflected in the screen shot). I've also noted that if I change any of these options, I do not get a "Save" Button, I only have the option to "Return to Device List."

          Comment


            #6
            I meant button group, not mode. set the button group like the following and click Save Changes
            Attached Files
            Mark

            HS3 Pro 3.0.0.534
            Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
            Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
            Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

            Comment


              #7
              if you aren't seeing the same thing, can you copy the [device x] section from the config\insteon.ini file for the kpl in question and post it here
              Mark

              HS3 Pro 3.0.0.534
              Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
              Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
              Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

              Comment

              Working...
              X