Announcement

Collapse
No announcement yet.

Well this used to work?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Well this used to work?

    Insteon Plug-in Error Log Generated 1/7/2021 5:36:46 PM
    -----------*Error Message*----------------
    Error: Error in RegisterCallback: Insteon.dll -- Details System.IO.FileNotFoundException: Insteon.dll
    at System.Diagnostics.FileVersionInfo.GetVersionInfo(String fileName)
    at HSPI_INSTEON.HSPI.RegisterCallback(Object& iFrm) -- 1/7/2021 5:36:46 PM
    --------*Initialization Log*--------------
    1/7/2021 5:36:46 PM - Host System: HomeSeer 2.5.0.80
    1/7/2021 5:36:46 PM - Plugin: Insteon.DLL - v2.0.0.38
    1/7/2021 5:36:46 PM - ***:Error in RegisterCallback: Insteon.dll -- Details System.IO.FileNotFoundException: Insteon.dll
    at System.Diagnostics.FileVersionInfo.GetVersionInfo(String fileName)
    at HSPI_INSTEON.HSPI.RegisterCallback(Object& iFrm)

    -----------*Pre-Error Log*----------------
    --------*End Pre-Error Log*--------------

    #2
    did you just upgrade? make sure the insteon.dll is in the homeseer\bin\insteon folder
    Mark

    HS3 Pro 3.0.0.534
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

    Comment


      #3
      No upgrade, just magically stopped working a couple of days ago?

      The DLL was not in the \bin\insteon folder, so I put it there. Still no joy?

      1/8/2021 4:16:12 PM ~!~Startup~!~Checking for available plug-ins
      1/8/2021 4:16:13 PM ~!~Plug-In~!~Found plug-in: Insteon, version: 2.0.0.38
      1/8/2021 4:16:13 PM ~!~Startup~!~Initializing Plug-Ins
      1/8/2021 4:16:13 PM ~!~Insteon~!~Plugin: Insteon.DLL - v2.0.0.38
      1/8/2021 4:16:13 PM ~!~Insteon~!~** An error occurred in this plug-in. The details have been written to the log file - C:\Program Files (x86)\HomeSeer HS2\Config\Insteon Error Report.Log
      1/8/2021 4:16:13 PM ~!~Insteon~!~** To request help with this problem please post this log file to the forum along with a detailed description of what lead to this problem.
      1/8/2021 4:16:13 PM ~!~Plug-In~!~Initializing Plug-in: Insteon
      1/8/2021 4:16:35 PM ~!~Insteon~!~Warning: Unable to connect to the remote server
      1/8/2021 4:16:35 PM ~!~Insteon~!~You need to set the Interface Port on the Config page, and then restart HS.
      1/8/2021 4:16:35 PM ~!~Insteon~!~Warning: Unable to connect to the remote server
      1/8/2021 4:16:35 PM ~!~Insteon~!~You need to set the Interface Port on the Config page, and then restart HS.
      1/8/2021 4:16:56 PM ~!~Insteon~!~Warning: Unable to connect to the remote server
      1/8/2021 4:16:56 PM ~!~Insteon~!~You need to set the Interface Port on the Config page, and then restart HS.
      1/8/2021 4:16:59 PM ~!~Error~!~Initializing interface: Insteon->Could not contact Interface on 10.0.0.15:25105
      1/8/2021 4:16:59 PM ~!~Plug-In~!~Finished initializing plug-in Insteon
      1/8/2021 4:16:59 PM ~!~Plug-In~!~Initializing X10 Plug-in: Insteon On COM Port 4
      1/8/2021 4:16:59 PM ~!~Plug-In~!~Initializing Plug-in: Insteon
      1/8/2021 4:16:59 PM ~!~Insteon~!~Please remember to Enable the Other interface on the Homeseer Setup Interface page.
      1/8/2021 4:16:59 PM ~!~Insteon~!~X10 Protocol Interface Initializing...
      1/8/2021 4:16:59 PM ~!~Plug-In~!~Finished initializing X10 interface Insteon
      1/8/2021 4:16:59 PM ~!~Plug-In~!~Finished initializing infrared interface


      Seriously this has been working for years

      Same error:
      Insteon Plug-in Error Log Generated 1/8/2021 4:16:13 PM
      -----------*Error Message*----------------
      Error: Error in RegisterCallback: Insteon.dll -- Details System.IO.FileNotFoundException: Insteon.dll
      at System.Diagnostics.FileVersionInfo.GetVersionInfo(String fileName)
      at HSPI_INSTEON.HSPI.RegisterCallback(Object& iFrm) -- 1/8/2021 4:16:13 PM
      --------*Initialization Log*--------------
      1/8/2021 4:16:13 PM - Host System: HomeSeer 2.5.0.80
      1/8/2021 4:16:13 PM - Plugin: Insteon.DLL - v2.0.0.38
      1/8/2021 4:16:13 PM - ***:Error in RegisterCallback: Insteon.dll -- Details System.IO.FileNotFoundException: Insteon.dll
      at System.Diagnostics.FileVersionInfo.GetVersionInfo(String fileName)
      at HSPI_INSTEON.HSPI.RegisterCallback(Object& iFrm)

      -----------*Pre-Error Log*----------------
      --------*End Pre-Error Log*--------------

      does it follow a path that is set somewhere or is it hardcoded to a certain directory?

      Comment


        #4
        i didn't realize you are still running HS2

        move the insteon.dll back to the homeseer root folder

        what version of the hspi_insteon.dll is listed?

        i wonder if the insteon.dll is corrupt? can you restore a version from a backup
        Mark

        HS3 Pro 3.0.0.534
        Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
        Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
        Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

        Comment


          #5
          Restored from a HS2INSTEON subdir.

          Still no joy.

          hspi_insteon.dll (2.0.0.38) 5/23/2019 7:22am

          Insteon Plug-in Error Log Generated 1/8/2021 8:16:02 PM
          -----------*Error Message*----------------
          Error: Error in RegisterCallback: Insteon.dll -- Details System.IO.FileNotFoundException: Insteon.dll
          at System.Diagnostics.FileVersionInfo.GetVersionInfo(String fileName)
          at HSPI_INSTEON.HSPI.RegisterCallback(Object& iFrm) -- 1/8/2021 8:16:02 PM
          --------*Initialization Log*--------------
          1/8/2021 8:16:02 PM - Host System: HomeSeer 2.5.0.80
          1/8/2021 8:16:02 PM - Plugin: Insteon.DLL - v2.0.0.38
          1/8/2021 8:16:02 PM - ***:Error in RegisterCallback: Insteon.dll -- Details System.IO.FileNotFoundException: Insteon.dll
          at System.Diagnostics.FileVersionInfo.GetVersionInfo(String fileName)
          at HSPI_INSTEON.HSPI.RegisterCallback(Object& iFrm)

          -----------*Pre-Error Log*----------------
          --------*End Pre-Error Log*--------------
          --------*Start C:\Program Files (x86)\HomeSeer HS2\Config\Insteon.ini*--------------
          [Config]
          LastInterfaceAddress=
          MaxHops=2
          NumRetries=5
          WaitTimeout=3
          DetailedLog=2
          DoCleanups=1
          GroupBaseCode=]
          DeviceLocationFilterIndex=0
          NumDevices=24
          DeviceBaseCode=[
          InterfaceCapability=5
          NumInterfaceLinks=36
          UseLocation2=0
          DisablePolling=0
          SortDeviceLinks=0
          InterfacePort=10.0.0.15:25105
          InterfaceModel=

          Comment


            #6
            first backup your entire homeseer folder. you need to make sure to backup the insteon.lf (license file). if this gets corrupt, you will lose access to the plugin.

            attached is the original files. shutdown hs, unzip the files into the homeseer root folder replace the existing ones.

            make sure you have free space on the drive. remove any old config\insteon error report.log files
            Attached Files
            Mark

            HS3 Pro 3.0.0.534
            Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
            Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
            Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

            Comment


              #7
              Still doesnt work?

              05/22/2019 03:47 PM 145,428 updater.txt
              05/22/2019 04:07 PM <DIR> backup2.5.0.60
              05/22/2019 04:08 PM <DIR> Updates2
              05/23/2019 05:45 AM <DIR> backup2.5.0.81
              05/23/2019 06:22 AM 3,120 Insteon.lf
              05/23/2019 06:22 AM <DIR> 20190523
              11/19/2020 08:41 AM 0 test.txt
              01/08/2021 08:51 PM 70,144 HSPI_Insteon.dll
              01/08/2021 08:51 PM 70,656 FTD2XX_NET.dll
              01/08/2021 08:51 PM 501,760 Insteon.dll
              01/08/2021 08:52 PM <DIR> ..
              01/08/2021 08:52 PM <DIR> .
              01/08/2021 08:54 PM <DIR> Config
              01/08/2021 08:55 PM 7,751 HomeSeer.LOG
              40 File(s) 20,641,357 bytes

              The new files are marked with today's date, so it appears the copy of the 3 files was successful?

              I added c:\program files(x86)\Homeseer HS2\ to the path env variable (just in case)

              and yet the error remains the same?

              Insteon Plug-in Error Log Generated 1/8/2021 8:54:41 PM
              -----------*Error Message*----------------
              Error: Error in RegisterCallback: Insteon.dll -- Details System.IO.FileNotFoundException: Insteon.dll
              at System.Diagnostics.FileVersionInfo.GetVersionInfo(String fileName)
              at HSPI_INSTEON.HSPI.RegisterCallback(Object& iFrm) -- 1/8/2021 8:54:41 PM
              --------*Initialization Log*--------------
              1/8/2021 8:54:41 PM - Host System: HomeSeer 2.5.0.80
              1/8/2021 8:54:41 PM - Plugin: Insteon.DLL - v2.0.0.38
              1/8/2021 8:54:41 PM - ***:Error in RegisterCallback: Insteon.dll -- Details System.IO.FileNotFoundException: Insteon.dll
              at System.Diagnostics.FileVersionInfo.GetVersionInfo(String fileName)
              at HSPI_INSTEON.HSPI.RegisterCallback(Object& iFrm)

              -----------*Pre-Error Log*----------------
              --------*End Pre-Error Log*--------------


              Could the hunt for a DLL use a different path variable? (not that most programs dont look in the current directory before checking the PATH env)

              Comment


                #8
                hs has its own search path. but it will follow instructions in the following HSPI_Insteon.dll.config

                is there a file named HSPI_Insteon.dll.config?

                in hs2 i didn't customize this file, but i did in hs3. we could try it.

                in your .config file, after the <configuration> tag, add the following

                <runtime>
                <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
                <probing privatePath="bin\insteon;bin/insteon"/>
                </assemblyBinding>
                </runtime>
                then move the insteon.dll to the bin\insteon folder

                i really have no idea if this will work; just a guess

                Mark

                HS3 Pro 3.0.0.534
                Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                Comment


                  #9
                  No HSPI_insteon.dll.config.

                  I've been playing with different settings and locations. Tried running it from a command line and as the HomeSeerService.exe.

                  Still No Joy.

                  is there any way to turn on even more logging in the DLL? (But I assume since it's basically saying the DLL doesn't exist, extra logging wont be helpful)

                  "hs has its own search path." any hints as to what that may be? maybe I could drop the insteon.dll (and it's supporting files somewhere else)?

                  Comment


                    #10
                    you can search the other hs forums detailed hs logging.

                    could you try copying your homeseer folder to another computer and see if you get the same results?
                    Mark

                    HS3 Pro 3.0.0.534
                    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                    Comment


                      #11
                      Just as a conclusion to this odyssey, I finally bit the bullet and moved the 3 insteon dlls into \windows\system32. After a reboot, all appears good. It is definitely a PATH problem somewhere (thus moving the files fixes it) but I dont quite understand WHY having the dlls directly in the directory with the executable doesn't work?

                      I'm also fairly confident that I didn't change any path variables (but god knows what windows updates might have done)

                      This is not a complete solution (since I dont understand WHY it stopped working) but sometimes you just have to move forward.

                      Thanks for the help Mark

                      Comment


                        #12
                        very interesting solution. thanks for posting.
                        Mark

                        HS3 Pro 3.0.0.534
                        Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                        Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                        Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                        Comment

                        Working...
                        X