Announcement

Collapse
No announcement yet.

Feature Requests for the Mark Sandler Insteon PLM Plug-In

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by madigan View Post
    I just found Smarthome's INSTEON 2475DA2 0-10VDC BALLAST DIMMER (DUAL-BAND) http://www.smarthome.com/insteon-247...dual-band.html
    which would greatly simplify automating my kitchen fluorescents.

    Does your plug-in support this unit?

    Thanks
    Jim Madigan
    Jim,
    I have a beta unit for the device, and started adding support but i never finished it.

    Other than dimming, I'm not sure how one would use this over a standard on/off switch

    can you expand on your use or setup
    Mark

    HS3 Pro 3.0.0.534
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

    Comment


      Well - on/off and dimming is the point, as long as your plug-in works with it - don't know what else it could give me over that.

      I can't use a in-wall dimmer, as there's no neutral in any of my kitchen switchboxes, which I'd need to use a Cooper RF9537-N. Right now I have an old X-10 LampLinc hidden in one of the fixtures, and it supplies power to my two line-level Mark 10 electronic ballasts. It's the last of my horrible old -Linc devices, and I want to get rid of it and replace it with something else. Can't find an equivalent Z-Wave product, and I've just gone to Insteon for FanLincs and MiniControllers (same issue in those rooms - no neutral available in the switchboxes). Replace my line level ballasts with Advance Mark 7 10V units, put in the ballast dimmer, and I'm set.

      As long as I have on/off/dimming and remote programming I'm good to go - too many bad memories of Lincs losing their programming over power line transients, and getting up into a ceiling fluorescent fixture to hold down the programming button is not my idea of a good time!

      Comment


        Mark, I too have one of these from the beta and believe there were no changes before being put to market.

        We use the device to control Two flourcent fixtures in our garage. Each fixture has its own ballast and can be controlled separately with one Insteon ballast controller when you wire them on their own output. We use a Insteon Dimmer Switch wired parallel with the load wire capped, and once installed you can turn Both fixtures on/off with a double tap (fast on command) or just control on with a regular tap.

        I did have an issue with one event tied to theses when I was running HS2. Once the event was run, so other devices not tied to the event would keep turning off. Later this week I'll be redoing those events being I have HS3 now running. If j have more issues I'll report a bug.

        We don't plan on adding anymore of these to our home. Nothing to do with Insteon but rather the large amount of electricity that these lights use. The garage and closets will get 6" recessed cans with LEDs and the kitchen is going to get LED tape lights. Just our kitchen uses something like 500 watts when the lights are on.
        HSPro: 3.0.0.194
        PL: Insteon PLM 3.0.5.20,Insteon Thermostat 3.0.1.1 , UltraM1G, RainRelay8, UltraECM3, UltraPioneerAVR3, BLBackup, weatherXML, Jon00 Network & PC Monitor
        HW : Win 7 64bit, Intel i7-2600, 16 GB DDR3 Ram, 60 Plus Insteon Dual Band Devices, Rain8 Pro2, Elk M1 Gold, Brueltech GreenEye.

        Comment


          Originally posted by CharlieWayne View Post
          Mark, I too have one of these from the beta and believe there were no changes before being put to market.

          We use the device to control Two flourcent fixtures in our garage. Each fixture has its own ballast and can be controlled separately with one Insteon ballast controller when you wire them on their own output. We use a Insteon Dimmer Switch wired parallel with the load wire capped, and once installed you can turn Both fixtures on/off with a double tap (fast on command) or just control on with a regular tap.

          I did have an issue with one event tied to theses when I was running HS2. Once the event was run, so other devices not tied to the event would keep turning off. Later this week I'll be redoing those events being I have HS3 now running. If j have more issues I'll report a bug.

          We don't plan on adding anymore of these to our home. Nothing to do with Insteon but rather the large amount of electricity that these lights use. The garage and closets will get 6" recessed cans with LEDs and the kitchen is going to get LED tape lights. Just our kitchen uses something like 500 watts when the lights are on.
          Charlie,

          did you try registering the device in the plugin to see what worked and didn't?

          i don't have a dimmable fluorescent to test?
          Mark

          HS3 Pro 3.0.0.534
          Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
          Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
          Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

          Comment


            Originally posted by madigan View Post
            Well - on/off and dimming is the point, as long as your plug-in works with it - don't know what else it could give me over that.

            I can't use a in-wall dimmer, as there's no neutral in any of my kitchen switchboxes, which I'd need to use a Cooper RF9537-N. Right now I have an old X-10 LampLinc hidden in one of the fixtures, and it supplies power to my two line-level Mark 10 electronic ballasts. It's the last of my horrible old -Linc devices, and I want to get rid of it and replace it with something else. Can't find an equivalent Z-Wave product, and I've just gone to Insteon for FanLincs and MiniControllers (same issue in those rooms - no neutral available in the switchboxes). Replace my line level ballasts with Advance Mark 7 10V units, put in the ballast dimmer, and I'm set.

            As long as I have on/off/dimming and remote programming I'm good to go - too many bad memories of Lincs losing their programming over power line transients, and getting up into a ceiling fluorescent fixture to hold down the programming button is not my idea of a good time!
            well you might just have to give the device a try with the plugin and see if it does what you need. I can make changes as necessary
            Mark

            HS3 Pro 3.0.0.534
            Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
            Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
            Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

            Comment


              I don't have dimmable fluorescents either. Thing with this device seem to behave better in HS3 than HS2. Only experiencing one small issue and will start a new tread on that so we dont convert this thread.
              HSPro: 3.0.0.194
              PL: Insteon PLM 3.0.5.20,Insteon Thermostat 3.0.1.1 , UltraM1G, RainRelay8, UltraECM3, UltraPioneerAVR3, BLBackup, weatherXML, Jon00 Network & PC Monitor
              HW : Win 7 64bit, Intel i7-2600, 16 GB DDR3 Ram, 60 Plus Insteon Dual Band Devices, Rain8 Pro2, Elk M1 Gold, Brueltech GreenEye.

              Comment


                Hey Mark
                it seems that sometimes the plugin will loose connection to the PLM.
                it will give the "cannot reach interface......"

                usually a disable of the plugin and enabling it will resolve this issue.
                can you add it to the insteon special actions? so not only if the plugin will crash but also if it looses connection to the PLM?
                that way i can make an event to email me if the HUB is disconnected.


                thanks

                Comment


                  Originally posted by ez1976 View Post
                  Hey Mark
                  it seems that sometimes the plugin will loose connection to the PLM.
                  it will give the "cannot reach interface......"

                  usually a disable of the plugin and enabling it will resolve this issue.
                  can you add it to the insteon special actions? so not only if the plugin will crash but also if it looses connection to the PLM?
                  that way i can make an event to email me if the HUB is disconnected.


                  thanks
                  there is already a trigger called 'interface stops responding" that you can use.
                  Mark

                  HS3 Pro 3.0.0.534
                  Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                  Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                  Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                  Comment


                    yep i though that as well but if i run have it in an event, it never triggers.

                    Comment


                      hey Mark
                      i saw that when i create links with battery operated devices such as scene remotes or motion sensors / leak sensors i can see i can do a cross link.

                      i set button 4 on my remote to close all the shades in the hose, i put the remote into link state and did a link between the shades.
                      today i went into one of the settings in one of the shades and saw this:


                      Link #7 Load controls Living Room Remote Button 4 (1C.51.53)
                      Link #2 Load is controlled by Living Room Remote Button 4 (1C.51.53) - Command: On

                      do i really need the open/close module to send a command to the remote control which wont reply anyway?

                      maybe you can remove this like you did with the fanlinc.


                      just my thoughts.

                      thanks

                      Comment


                        Originally posted by ez1976 View Post
                        hey Mark
                        i saw that when i create links with battery operated devices such as scene remotes or motion sensors / leak sensors i can see i can do a cross link.

                        i set button 4 on my remote to close all the shades in the hose, i put the remote into link state and did a link between the shades.
                        today i went into one of the settings in one of the shades and saw this:


                        Link #7 Load controls Living Room Remote Button 4 (1C.51.53)
                        Link #2 Load is controlled by Living Room Remote Button 4 (1C.51.53) - Command: On

                        do i really need the open/close module to send a command to the remote control which wont reply anyway?

                        maybe you can remove this like you did with the fanlinc.


                        just my thoughts.

                        thanks
                        I'll take a look
                        Mark

                        HS3 Pro 3.0.0.534
                        Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                        Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                        Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                        Comment


                          Hi Mark,

                          I've been using your plugin for about 4 months and I think it's amazingly flexible and easy to use. I've been creating scenes lately, and have a feature suggestion. I have been going to the switches, setting dim levels how I like them, then writing down the current levels from the devices screen so I can transfer them into the group settings. The alternative is to just pick a dim level that you think will be about right in the group setup screen, and do trial and error adjustment of the dim levels to see how they look.

                          It would be nice to have a "Capture" button to read the current dim levels into the "Add New Group"/"Edit Group" screen for any devices I select with the check boxes. This would basically snapshot the current settings of the selected dimmers so I can use that as a starting point and all I have to do is tweak the ramp rates. It would be nice to capture the ramp rates for the devices too, but since the group ramp rate can't be adjusted at the switch I don't think it's needed. If that can be read, too, it would seem you'd want the default ramp rate captured when initially creating the group, but once programmed in the group to leave the ramp rate setting alone if capturing new dim levels while adjusting an existing group. Again, nothing would be read other than those that are checked. I'd be interested in hearing what you and others who use the plugin think about that.
                          Last edited by dzee; June 14, 2015, 02:42 PM.

                          Comment


                            RE-Program the same device after ram clear

                            Hi Mark,
                            I would like to request a new feature of your plugin. I have, on several occasions, needed to clear ram/factory default a device. To be fair, it seems to always be keypadlinc's.

                            I have tried the Replace device with a new device routine, but it fails when it checks that I have the same insteon address for both the old and new device.

                            I would like to request removing this check if possible? Or maybe a new button to RE-PROGRAM SAME DEVICE, right below the REPLACE DEVICE button?

                            It would be much easier to reset up a cleared keypadlinc that has 40+ links if you could just send that device all the links already in the database.

                            Thanks in advance, and BTW, great Job on this plugin!

                            Michael

                            Comment


                              Originally posted by swanie2000 View Post
                              ... Or maybe a new button to RE-PROGRAM SAME DEVICE, right below the REPLACE DEVICE button?...
                              I'd like this one too...

                              Comment


                                Originally posted by swanie2000 View Post
                                Hi Mark,
                                I would like to request a new feature of your plugin. I have, on several occasions, needed to clear ram/factory default a device. To be fair, it seems to always be keypadlinc's.

                                I have tried the Replace device with a new device routine, but it fails when it checks that I have the same insteon address for both the old and new device.

                                I would like to request removing this check if possible? Or maybe a new button to RE-PROGRAM SAME DEVICE, right below the REPLACE DEVICE button?

                                It would be much easier to reset up a cleared keypadlinc that has 40+ links if you could just send that device all the links already in the database.

                                Thanks in advance, and BTW, great Job on this plugin!

                                Michael
                                I'll put this towards the top of the list. thanks
                                Mark

                                HS3 Pro 3.0.0.534
                                Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                                Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                                Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                                Comment

                                Working...
                                X