Announcement

Collapse
No announcement yet.

Feature Requests for the Mark Sandler Insteon PLM Plug-In

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by mnsandler View Post
    when does the following occur? when you add a device, or when?



    can you post a screen shot of the issue
    Sure, In the HS settigns I have "Location 1" set to "Device Classification" and Location 2" set to "Room". I have attached 3 screenshots.

    1) HS custom tab settings for location names
    2) The settings for a device
    3) The device management screen with that same device.
    Attached Files
    MeiAutomtion Home

    Comment


      Frank,
      i think you are the only user not using Location 1 for Room. Most do, and then use Location 2 for floor, device classification, circuit, etc.

      the plugin does allow you to enable Location 2 when displaying device names in lists, etc.

      i can change the "device location" label within the plugin to use the hs custom value, but swapping location 1 and location 2 might be a lot of work.
      Mark

      HS3 Pro 3.0.0.534
      Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
      Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
      Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

      Comment


        Originally posted by mnsandler View Post
        Frank,
        i think you are the only user not using Location 1 for Room. Most do, and then use Location 2 for floor, device classification, circuit, etc.

        the plugin does allow you to enable Location 2 when displaying device names in lists, etc.

        i can change the "device location" label within the plugin to use the hs custom value, but swapping location 1 and location 2 might be a lot of work.
        In that case case there be an option to not update the device location with that value?

        Sent from my Pixel 2 XL using Tapatalk
        MeiAutomtion Home

        Comment


          Originally posted by sirmeili View Post
          In that case case there be an option to not update the device location with that value?

          Sent from my Pixel 2 XL using Tapatalk
          I may actually just go through my system and update all of them to be room as location 1. i'm not sure why I did it the way I did except that I think in the default HS touch it does it by location 2 then location 1, which is what I wanted (room, then device type)
          MeiAutomtion Home

          Comment


            Originally posted by sirmeili View Post
            I may actually just go through my system and update all of them to be room as location 1. i'm not sure why I did it the way I did except that I think in the default HS touch it does it by location 2 then location 1, which is what I wanted (room, then device type)
            hs touch use location 2 then location 1 which annoys me to no end. we should put in a request to HST to have hstouch follow their hs option "Display Location 1 First"

            i think this hstouch issue can be fixed, if you modify the hstouch project but i've never tried.
            Mark

            HS3 Pro 3.0.0.534
            Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
            Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
            Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

            Comment


              Comment


                should be easy enough. i will add this to the list
                Mark

                HS3 Pro 3.0.0.534
                Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                Comment


                  Mark,

                  I see that when I change the name of a device in yoru plugin, it updates the name of the device in HS with the name format "[Device Name] - [Channel Name]" unless I change the Channel name, then it removes the "[Device Name] - " part. Can this be made to always prepend it? It appears to only prepend it if the Channel name i the default.
                  MeiAutomtion Home

                  Comment


                    Originally posted by sirmeili View Post
                    Mark,

                    I see that when I change the name of a device in yoru plugin, it updates the name of the device in HS with the name format "[Device Name] - [Channel Name]" unless I change the Channel name, then it removes the "[Device Name] - " part. Can this be made to always prepend it? It appears to only prepend it if the Channel name i the default.
                    can you give me an example or two of what you are looking for. the general idea is the plugin creates default device names but lets you completely override them.
                    Mark

                    HS3 Pro 3.0.0.534
                    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                    Comment


                      I would like to request an option in Insteon config that will allow the plugin to send an update value to HS so that HS can decide whether or not to update the Last Change date, and also so I can make use of event triggers such as 'Set' even when the value does not change. I know there are workarounds for these things but this seems to be the way the rest of the devices in HS operate so it'd be nice if Insteon devices operated the same way. Aside from that, with some devices such as temperature or light sensors, it is nice to know the value is not stale and communication is working, and updating the Last Change date whenever it reports would help accomplish that.

                      I realize making this change could cause people events to change, so that is why I suggest it be an option.

                      Side note: HomeSeer should change the name of that column to "Last Update" since that's covers the scenario when the value doesn't change.

                      Thanks!
                      Last edited by mrceolla; August 29, 2018, 11:35 PM.
                      HomeSeer 3, Insteon, Z-wave, USB-UIRT, Google Hub/Chromecasts/Smart Speakers, Foscam cameras, Amcrest camera, RCA HSDB2a doorbell
                      Plugins: BLLAN, BLOccupied, BLUSBUIRT, Chromecast, Insteon, Jon00 Homeseer/Echo Skill Helper, Jon00 DB Charting, MediaController, NetCAM, PHLocation2, Pushover 3P, weatherXML, Z-wave

                      Comment


                        Mark,
                        I like the new tab on the device page to jump to the plugin settings for that device. It makes it a lot faster to get to the settings from the device page. But jumping back from the insteon settings pages back to the device page isn't there. I can't help but wonder if you couldn't just create two tabs (one for each of the two links, Device Settings, and Links) on the device pages and contain the content of the other page into the tab itself. That would preserve the tab at the top of the page so you can quickly jump back and forth between the Insteon specific and non-insteon tabs.

                        Comment


                          Originally posted by Jon View Post
                          Mark,
                          I like the new tab on the device page to jump to the plugin settings for that device. It makes it a lot faster to get to the settings from the device page. But jumping back from the insteon settings pages back to the device page isn't there. I can't help but wonder if you couldn't just create two tabs (one for each of the two links, Device Settings, and Links) on the device pages and contain the content of the other page into the tab itself. That would preserve the tab at the top of the page so you can quickly jump back and forth between the Insteon specific and non-insteon tabs.
                          Jon
                          i can only create One tab (my Insteon tab) on the hs device page. I could link back to the hs edit tabs using something like "deviceutility?ref=123&edit=1", but i don't think i can go to a specific hs tab. what do you think?
                          Mark

                          HS3 Pro 3.0.0.534
                          Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                          Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                          Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                          Comment


                            Originally posted by mnsandler View Post

                            Jon
                            i can only create One tab (my Insteon tab) on the hs device page. I could link back to the hs edit tabs using something like "deviceutility?ref=123&edit=1", but i don't think i can go to a specific hs tab. what do you think?
                            How about embedding the content of the Device Settings page into your Insteon tab. Those are the settings you're more likely to interact with anyhow. Also, this page already contains a section that displays the link table gives you a button to edit the links. I don't know how many people actually edit links manually, but I'd suspect it's a smaller subset than those who edit the device settings. I don't think you need to treat the two pages as if they're at the same level.

                            Comment


                              Originally posted by Jon View Post

                              How about embedding the content of the Device Settings page into your Insteon tab. Those are the settings you're more likely to interact with anyhow. Also, this page already contains a section that displays the link table gives you a button to edit the links. I don't know how many people actually edit links manually, but I'd suspect it's a smaller subset than those who edit the device settings. I don't think you need to treat the two pages as if they're at the same level.
                              Jon, i don't want to invest a lot of time in the HS3 interface at this point
                              Mark

                              HS3 Pro 3.0.0.534
                              Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                              Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                              Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                              Comment


                                Of course I don’t know anything about your plugin code, but it seems like you can take what you already have as the plugin’s device settings page and make that what appears in the Insteon tab of the device page. I guess that assumes that the tab is a container or frame that can simply display/contain the page you’re already creating. Is that actually more complex than I’m making it sound?


                                Sent from my iPhone using Tapatalk

                                Comment

                                Working...
                                X