Announcement

Collapse
No announcement yet.

Migrating from the PLC to the PLM or Swapping PLMs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Migrating from the PLC to the PLM or Swapping PLMs

    Here are the basic steps:

    1.shutdown hs or the plugin (For PLC users: uninstall the SDM and the PLC hspi_insteon.dll

    2.connect the new plm or hub (for usb PLMs note the com port created in the windows device manage)

    3.restart hs or the plugin (For PLC users: install the new insteon plugin)

    4.set the com port on the plugin config page if the com port changed or you are switching to the Hub

    5.execute the Program Replacement/Swapped Interface function from the main config page (you will need to enter the insteon address of the OLD device)

    6. you may run the swap again if it wasn't successful on certain devices. the routine only programs devices with the plm id. The plugin will wait for you to put RF devices into link mode, and then ask you to press a Continue button

    7.once the swap is complete, reprogram existing groups from the Manage Groups page. select all the groups and click reprogram

    8.click update insteon interface address database from main config page (this may not be necessary; will add missing links)

    9.visit existing devices and delete any unnecessary links or reprogram the device if it is still referencing the old PLM address

    10.wireless devices (MSs, TLs, etc) will have to reprogrammed one by one manually: delete existing links and reprogram the device for homeseer


    Done.

    Troubleshooting if communcations is not working as expected

    1. click the hardware reset and reprogram interface btn from the main config page
    2. reread and verify the links for the devices in question. reprogram as necessary.


    Hope this helps.
    Last edited by mnsandler; March 18, 2018, 07:28 AM.
    Mark

    HS3 Pro 3.0.0.534
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

    #2
    Mark,
    It's hard to teach an old dog new tricks!
    Can you please when you have time,explain to me how to go about removing the old insteon plug in file with the new DLL. file that you sent me in hs.
    sorry to be a pain. Thank You
    Dean Holzmann Sr.

    Comment


      #3
      Sean,
      this is a general process for updating any plugin...

      1. shutdown hs
      2. open your "c:\program files\homeseer 2" directory or whereever you installed hs2.
      3. backup the existing dll with the same name as the one you are going to install. In this case hspi_insteon.dll
      4. copy the new hspi_insteon.dll to the folder replacing the existing dll
      5. restart hs

      that's it.
      Mark

      HS3 Pro 3.0.0.534
      Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
      Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
      Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

      Comment


        #4
        Plc -> plm

        Migrated about a week ago and everything is running reliable, stable and fast.
        The one problem I had was the old PLC was not removed, so the old IP showed as an unknown device and had to manually be removed.

        I deleted and manually reinstalled my motion sensor devices and they work properly, as does the outdoor appliancelinc.

        Thanks again for your help and excellent development effort.

        Comment


          #5
          Originally posted by Sonnyh View Post
          Migrated about a week ago and everything is running reliable, stable and fast.
          The one problem I had was the old PLC was not removed, so the old IP showed as an unknown device and had to manually be removed.

          I deleted and manually reinstalled my motion sensor devices and they work properly, as does the outdoor appliancelinc.

          Thanks again for your help and excellent development effort.
          glad to hear everything is working.

          thanks for your support
          Mark

          HS3 Pro 3.0.0.534
          Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
          Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
          Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

          Comment


            #6
            1.shutdown hs
            2.connect the new plm (for usb plms note the com port created in the windows device manage)
            3.install the new plm plugin
            4.restart hs
            5.set the com port on the hs setup/interface page
            6.enable the plugin
            7.execute the interface swap function from the main config page
            8.reprogram existing groups
            9.visit existing devices and delete any unnecessary links
            There are a few things unclear to me about this procedure:

            a) With the existing PLC device, do I leave it plugged in? If not, when to I pull it? Just after #1?

            b) Same question with the current PLC plugin. Do I disable it before #1? I don't want it complaining about no PLC when I restart, but before changing the com port.

            c) #2 is always a mystery to me. I'm going to use one of those USB to Serial adaptors, and it is alway very difficult for me to figure out which COM port it is hooked up to. Any advice about this?

            d) So, #7 assumes that the PLC device has been disconnected?

            e) I'm not sure about #8. I haven't explicitly created any groups with my current set up. And my Manage Groups button in the current plugin shows nothing. So, I can ignore this, right?

            f) So, in the existing plugin, the links aren't shown, but now with the PLM, they will be, right?

            Sorry to be so anal about this, but I know if not done correctly, I could end up screwed.

            Thanks,
            The Listener

            PS: running current everything

            Comment


              #7
              Originally posted by The Listener View Post
              There are a few things unclear to me about this procedure:
              a) With the existing PLC device, do I leave it plugged in? If not, when to I pull it? Just after #1?

              disconnect the PLC after you shutdown hs

              b) Same question with the current PLC plugin. Do I disable it before #1? I don't want it complaining about no PLC when I restart, but before changing the com port.

              yes you can disable before shutting down

              c) #2 is always a mystery to me. I'm going to use one of those USB to Serial adaptors, and it is alway very difficult for me to figure out which COM port it is hooked up to. Any advice about this?

              look in the windows device manager to see the new Port added. should only be one new port. Maybe look at the list before added the plm. this should make it easier to see what is new.

              d) So, #7 assumes that the PLC device has been disconnected?

              yes the plc is gone and the plm is connected when you restart hs with the new plugin. the plm plugin won't care about the plc.

              e) I'm not sure about #8. I haven't explicitly created any groups with my current set up. And my Manage Groups button in the current plugin shows nothing. So, I can ignore this, right?

              correct, ignore this step

              f) So, in the existing plugin, the links aren't shown, but now with the PLM, they will be, right?

              Yes the individual device links will show. I though they did with the plc, guess not; no big deal

              Hope this clears it up. Maybe you could document all your steps and i could incorporate it into this How-To.
              Mark

              HS3 Pro 3.0.0.534
              Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
              Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
              Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

              Comment


                #8
                I have swapped my PLC for PLM and am up to step 8 "reprogram existing groups" What exactly do I need to do with the groups? I have 12 groups and after the interface reprogram they seem to be already setup ok??
                HS 3.0.0.435 (PRO)
                Hardware: Napco GEM-P9600 | VenstarT1800 w/Insteon 2441V adapter | Insteon PLM
                Plugins HS3: Napco Gemini (mine) | Insteon Thermostat (mine) | Insteon Plug-in (mnsandler) | HSTouch Server (HST)
                Platform: Windows 10 Pro 64bit, core2 duo 2.0Ghz, 4GB memory
                http://www.kazteel.com/

                Comment


                  #9
                  Originally posted by nfrobertson View Post
                  I have swapped my PLC for PLM and am up to step 8 "reprogram existing groups" What exactly do I need to do with the groups? I have 12 groups and after the interface reprogram they seem to be already setup ok??
                  edit each group in the plugin, and click the Reprogram Group btn to recreate the links
                  Mark

                  HS3 Pro 3.0.0.534
                  Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                  Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                  Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                  Comment


                    #10
                    Hi,

                    I am following your steps to swap out my PLC and start to use my new PLM instead. I have changed the DLL and the .LF file. According to the Plug-In interfaces screen, I am running version 1.5.6.0. It shows as enabled and Unregistered and the Plug-In status shows Interface OK. However, I cannot get at any of my Insteon configuration screens.

                    Is there a step that I have missed?

                    Thank you

                    Brian

                    Comment


                      #11
                      Originally posted by brmeeke View Post
                      Hi,

                      I am following your steps to swap out my PLC and start to use my new PLM instead. I have changed the DLL and the .LF file. According to the Plug-In interfaces screen, I am running version 1.5.6.0. It shows as enabled and Unregistered and the Plug-In status shows Interface OK. However, I cannot get at any of my Insteon configuration screens.

                      Is there a step that I have missed?

                      Thank you

                      Brian
                      did you give it a com port on the setup/interface page? if you don't know what to put, check your device manager for Ports and see what looks new. Its probably the last com port (biggest #)

                      can you tell me what plc plugin ver you were running
                      Mark

                      HS3 Pro 3.0.0.534
                      Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                      Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                      Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                      Comment


                        #12
                        I am using a 2413U PLM. When I connected the device, Windows 7 searched and installed drivers with a message to say that my device was installed and working properly.

                        On the Plug-In interface screen, COM Port was set to 1. I checked my Device Manager and found that it shows that I have a USB Serial Port on COM4. Have changed the port on Interface screen to 4 and done a save. Everything still the same as it was.

                        Comment


                          #13
                          everthing sounds right. please restart hs
                          Mark

                          HS3 Pro 3.0.0.534
                          Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                          Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                          Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                          Comment


                            #14
                            Think I found a clue about what is going on....

                            I went to the Updater and installed the software for the PLM. Restarted Homeseer and everything seemed OK. The Insteon configuration button was there as I expected. However it had an old version of the software for the Insteon interface. So I shutdown Homeseer and copied the DLL and Insteon.LF file to the Homeseer directory and restarted the software. The Log file showed said that it could not find the license file.

                            Log file:

                            9/23/2011 5:08:54 PM - Startup - Checking for available plug-ins
                            9/23/2011 5:08:54 PM - Plug-In - Found plug-in: X10 CM11A/CM12U, version: 1.0.1.0
                            9/23/2011 5:08:54 PM - Plug-In - Found plug-in: X10 CM15AUSB, version: 1.0.0.3
                            9/23/2011 5:08:54 PM - Plug-In - Found plug-in: HSTouch Server, version: 1.0.0.42
                            9/23/2011 5:08:54 PM - Plug-In - Found plug-in: HSTouch Android, version: 1.0.0.0
                            9/23/2011 5:08:54 PM - Plug-In - Found plug-in: HSTouch iPhone, version: 1.0.0.0
                            9/23/2011 5:08:54 PM - Error - License file Insteon.lf does not exist, please reinstall the plugin
                            9/23/2011 5:08:54 PM - Plug-In - Found plug-in: Insteon, version: 1.5.6.0
                            9/23/2011 5:08:54 PM - Plug-In - Found plug-in: iTunes, version: 2.5.0.13
                            9/23/2011 5:08:54 PM - Plug-In - Found plug-in: Media Player, version: 2.5.0.16
                            9/23/2011 5:08:54 PM - Plug-In - Found plug-in: UPB, version: 1.0.2.7
                            9/23/2011 5:08:55 PM - Startup - Initializing Plug-Ins
                            9/23/2011 5:08:55 PM - Error - (1) Unable to initialize interface Insteon :Either no license or trial has expired
                            9/23/2011 5:08:55 PM - Plug-In - Finished initializing plug-in Insteon
                            9/23/2011 5:08:55 PM - Plug-In - Finished initializing X10 interface
                            9/23/2011 5:08:55 PM - Plug-In - Finished initializing infrared interface
                            9/23/2011 5:08:55 PM - Error - (1) Unable to initialize interface Insteon :Either no license or trial has expired
                            9/23/2011 5:08:55 PM - Plug-In - Finished initializing plug-in Insteon


                            What do you think??

                            Brian

                            Comment


                              #15
                              the license file goes in your config folder

                              restart hs after you drop the file there
                              Mark

                              HS3 Pro 3.0.0.534
                              Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                              Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                              Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                              Comment

                              Working...
                              X