Announcement

Collapse
No announcement yet.

Can't Turn on long list of devices

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Can't Turn on long list of devices

    I created an event that (tried to) turn on 45 devices. Most are X10 and some are Insteon.

    A number of them had their status changed to "on", but didn't turn on.

    In the log, the event fired and all the "ON" commands are listed.

    Some of the lights trigger "auto off" events when they go on.

    One of those events was triggered and then I saw this error:

    Error Calling SetIOMulti in plugin Insteon:Object reference not set to an instance of an object.

    Then, another "auto off" event was triggered and I saw this "warning":

    Warning Plugin Insteon is not responding but it is still running, not restarting yet.

    I was able to control lights (even the ones that didn't go on when the event tried to turn them on) after this.

    I really need one event to turn on all these devices and one to turn them all off (I'm doing it in response to a device value changing to on/off).

    I'm running 3.0.5.3 of the plug-in -- I know there are newer versions, but haven't been able to get them to install.

    I'm running HS3 3.0.0.152 on Windows 7.

    #2
    for the insteon devices, you need to create a group so they will all respond at once.

    for the x10 device you should use the all lights on function. For example 'all lights on' for house code A. that said, not sure if this implemented in the hs3 plugin

    one by one is not going to be reliable.
    Mark

    HS3 Pro 3.0.0.534
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

    Comment


      #3
      Right. In HS2, I would just create a script and do the "all lights on" or "all units off".

      But, I don't see any way to do that in HS3.

      Comment


        #4
        Originally posted by sumoldgai View Post
        Right. In HS2, I would just create a script and do the "all lights on" or "all units off".

        But, I don't see any way to do that in HS3.
        I would have to add at least two event actions to make this happen.

        Any chance you have access to another x10 controller compatible with one of the free x10 plugins
        Mark

        HS3 Pro 3.0.0.534
        Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
        Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
        Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

        Comment


          #5
          I have an older Smarthome controller, but there's no support on Windows 7 for it.

          Is there a way to script it with your plugin???

          Comment


            #6
            Originally posted by sumoldgai View Post
            I have an older Smarthome controller, but there's no support on Windows 7 for it.

            Is there a way to script it with your plugin???
            scripting may be a possibility but i think i can add event actions for these x10 cmds
            Mark

            HS3 Pro 3.0.0.534
            Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
            Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
            Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

            Comment


              #7
              do you have time to test a new version with a few x10 event actions? let me know and I'll post a version here
              Mark

              HS3 Pro 3.0.0.534
              Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
              Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
              Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

              Comment


                #8
                Sure. I should be able to try it out over the next few days.

                Comment


                  #9
                  Originally posted by sumoldgai View Post
                  Sure. I should be able to try it out over the next few days.
                  here you go, couple of notes:

                  in addition to sending the x10 cmd, the plugin will turn on/off the x10 hs devices associated with the All Lights On/Off command/housecode selected.

                  i added the "all units off" x10 cmd as well but it really doesn't act any different than the all lights off in that it will turn all associated x10 hs devices off. I have no way of knowing a light vs a unit with x10 devices.

                  please let me know how it goes. I did a little testing with a single A1 and B1 device.
                  Attached Files
                  Mark

                  HS3 Pro 3.0.0.534
                  Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                  Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                  Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                  Comment


                    #10
                    Any special instructions on installing or just replace the files?

                    Comment


                      #11
                      Originally posted by sumoldgai View Post
                      Any special instructions on installing or just replace the files?
                      backup your existing insteon.ini, homeseer db and old plugin dlls, then shutdown hs and replace files and restart
                      Mark

                      HS3 Pro 3.0.0.534
                      Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                      Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                      Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                      Comment


                        #12
                        anything to report?
                        Mark

                        HS3 Pro 3.0.0.534
                        Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
                        Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
                        Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

                        Comment

                        Working...
                        X