Announcement

Collapse
No announcement yet.

Recovery?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Recovery?

    Last month our PLM died. Replacement and configuration was easily accomplished.

    Last week the hard drive in our Homeseer PC locked up tight. Unfortunately the backup was foolishly stored on another partition of the same drive.

    Anyway, replaced the drive, Homeseer is back up but all the Insteon devices, naturally, are gone.

    Unfortunately I'm not the person who setup up the system initially. I have no clue how to install Insteon devices. I get as far as "Tap-Add New Insteon Devices" in the plug-in.

    Can someone please post a simple step-by-step? Does it work the same for simple switches and 8 button keypads?

    TIA

    #2
    George,

    if you any old version of the insteon.ini, it will help get you started. The plugin will recreate the devices as necessary when HS starts up. But if you have to start from zero here is the short version:

    1. from the plugin, Manage Device Page, click the "Tap-Add New Device"
    2. Put a device into linking mode (see the device manual, this is different for different device types)
    3. after the plugin contacts the device, and programs it , repeat #2 for another device
    4. Click the Finish button

    the devices will be added with generic names. if you add several devices (during each tap-add series) you will need to keep track of the order so you can update the device names after the fact.

    You might do one device first as a test. Just click Finish after the first device so you can see what is created.
    Mark

    HS3 Pro 3.0.0.534
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

    Comment


      #3
      Thank you Mark!

      Should the PLM be reset first?

      I have no manuals for these devices and do not know the model numbers.

      So when the plugin is listening I press and hold set until it beeps. Sounds simple.

      What about 8 button devices? For example, I have one that uses 2 buttons that do light on and off, and 4 buttons for fan low, medium, high and off. If I hold set then the plugin will detect an 8 button switch?

      Thanks again!

      Edit: Nope, no ini.

      Comment


        #4
        George,
        smarthome maintain manuals at http://www.insteon.com/support/ and on the smarthome site

        the plugin will recognize the 8 btn kpl and 6 btns as well. you only need to tap-add once, the plugin will do the reset

        resetting the PLM is a good idea before starting.

        typically a switch and kpl can btn put into linking mode by pressing the 'on' paddle or btn until it beeps. the set btn doesn't always start linking mode.
        Mark

        HS3 Pro 3.0.0.534
        Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
        Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
        Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

        Comment


          #5
          Cool thanks.

          Comment


            #6
            Mark,

            I successfully registered 3 devices:



            The 2 SwitchLinc devices work fine. Oddly one required using the On paddle, the other the Set button.

            The KeypadLink does not function. Pressing any On or Off button for any of the 8 Keypadlink buttons on the Home tab will change only the light bulb on the left but does not turn the actual light or fan on and off.

            In addition pressing physical KeypadLinc buttons changes the state of the light bulb icons in Homeseer and works the light and fan.

            In both cases the log displays:

            Device Control Device: Geos Room Light/Fan - Button A/Load (^2) ON

            Is there another step for KeypadLinc to control devices? The light and fan are a ceiling fan.

            What am I missing?

            Comment


              #7
              Originally posted by George56 View Post
              Mark,

              I successfully registered 3 devices:



              The 2 SwitchLinc devices work fine. Oddly one required using the On paddle, the other the Set button.

              The KeypadLink does not function. Pressing any On or Off button for any of the 8 Keypadlink buttons on the Home tab will change only the light bulb on the left but does not turn the actual light or fan on and off.

              In addition pressing physical KeypadLinc buttons changes the state of the light bulb icons in Homeseer and works the light and fan.

              In both cases the log displays:

              Device Control Device: Geos Room Light/Fan - Button A/Load (^2) ON

              Is there another step for KeypadLinc to control devices? The light and fan are a ceiling fan.

              What am I missing?
              use the 'program device for homeseer' btn on the kpl edit device page from the plugin. As i recall, using the tap-add does not add the links
              Mark

              HS3 Pro 3.0.0.534
              Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
              Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
              Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

              Comment


                #8
                He missing linc

                Thank you for all your help Mark and for your nifty plug-in!

                My problem wasn't with the KeypadLinc. I finally realized that the KeypadLinc was is controlling a Dual-Band FanLinc. Once I added the FanLinc's address to the plug-in I'm able to control the light and fan via HomeSeer.

                I still can not control the light or fan by commands to KeypadLinc. Send commands to the FanLinc works perfectly.

                Thanks again.

                Comment

                Working...
                X