Announcement

Collapse
No announcement yet.

KPL Errors

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Originally posted by CharlieWayne View Post
    The other day I emailed you copy of the crash log that was generated automatically. Did you receive that?

    Attached is the new Log I manually created from within your device.

    Ill follow this reply with a general report on how various other devices are functioning.

    Thanks

    Charlie
    i received the other log (via email). The following were the most recently errors. They are not pertinent to the function of the plugin. you might check these links on this device [device 2] in the insteon.ini

    4/23/2015 10:13:17 PM - ***:Error in DisplayLinkTable.Generate for Device: 2, Link: 27: Index was outside the bounds of the array. -- Details System.IndexOutOfRangeException: Index was outside the bounds of the array.
    at Insteon.Support.WebInterface.DisplayLinkTable(String& data, Boolean ShowChecks)
    4/23/2015 10:13:17 PM - ***:Error in DisplayLinkTable.Generate for Device: 2, Link: 28: Index was outside the bounds of the array. -- Details System.IndexOutOfRangeException: Index was outside the bounds of the array.
    at Insteon.Support.WebInterface.DisplayLinkTable(String& data, Boolean ShowChecks)
    4/23/2015 10:13:17 PM - ***:Error in DisplayLinkTable.Generate for Device: 2, Link: 29: Index was outside the bounds of the array. -- Details System.IndexOutOfRangeException: Index was outside the bounds of the array.
    at Insteon.Support.WebInterface.DisplayLinkTable(String& data, Boolean ShowChecks)
    4/23/2015 10:13:17 PM - ***:Error in DisplayLinkTable.Generate for Device: 2, Link: 30: Index was outside the bounds of the array. -- Details System.IndexOutOfRangeException: Index was outside the bounds of the array.
    at Insteon.Support.WebInterface.DisplayLinkTable(String& data, Boolean ShowChecks)
    4/23/2015 10:13:17 PM - ***:Error in DisplayLinkTable.Generate for Device: 2, Link: 31: Index was outside the bounds of the array. -- Details System.IndexOutOfRangeException: Index was outside the bounds of the array.
    at Insteon.Support.WebInterface.DisplayLinkTable(String& data, Boolean ShowChecks)
    4/23/2015 10:13:17 PM - ***:Error in DisplayLinkTable.Generate for Device: 2, Link: 32: Index was outside the bounds of the array. -- Details System.IndexOutOfRangeException: Index was outside the bounds of the array.
    at Insteon.Support.WebInterface.DisplayLinkTable(String& data, Boolean ShowChecks)
    here is my concern:

    4/27/2015 11:03:00 AM - PLMBuffer_Clean - Cleared FF to locate next possible STX
    4/27/2015 11:03:00 AM - PLMBuffer_Clean - Cleared 80 to locate next possible STX
    i wonder if this is noise from the PLM or on the insteon network.

    btw. the register call back issue seems to have gone away for you. I saw a successful startup with issue with v3.0.5.21
    Mark

    HS3 Pro 3.0.0.534
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

    Comment


      #17
      Great,

      I went around and turned on at least 10 different dimmers and keypads without one showing a status change within the HS Log. I am able to control each device via HS without issue and that action is logged within the log.

      My PLM is 3 month old now and I'll look it over. Its been plugged into the same outlet for over a year without issue so I'm guessing placement is ruled out.

      Let me try and do some simple tests like unplug and reboot. Other than that, do you have suggestions?

      Charlie
      HSPro: 3.0.0.194
      PL: Insteon PLM 3.0.5.20,Insteon Thermostat 3.0.1.1 , UltraM1G, RainRelay8, UltraECM3, UltraPioneerAVR3, BLBackup, weatherXML, Jon00 Network & PC Monitor
      HW : Win 7 64bit, Intel i7-2600, 16 GB DDR3 Ram, 60 Plus Insteon Dual Band Devices, Rain8 Pro2, Elk M1 Gold, Brueltech GreenEye.

      Comment


        #18
        Originally posted by CharlieWayne View Post
        Great,

        I went around and turned on at least 10 different dimmers and keypads without one showing a status change within the HS Log. I am able to control each device via HS without issue and that action is logged within the log. ...
        Hey, I've had something like that before. Try "Reset and Reprogram Interface" and see if that causes the status changes to start working. If it does, there may be a new PLM in your future.

        Comment


          #19
          Thanks to both of you things are back up and running.

          Pretty much I unpluged the PLM and the wires, pluged it back in, performed the reset and reprogram, and Presto!!!

          Did see the old dll version ID in the log.

          PHP Code:
          Apr-27 2:44:17 PM         NO ECHO    No Echo for Game Room Motion Sensor Occupancy Sensor, Echo (29 secs)
          Apr-27 2:44:17 PM         Event    Event Trigger "Motion Control Game Room Lights Off by NO Motion"
          Apr-27 2:44:17 PM         Insteon    Received 31.81.42:(Game Room Motion Sensor Occupancy SensorGo OFF
          Apr
          -27 2:43:47 PM         ECHO    Echo for Game Room Motion Sensor Occupancy SensorNo Echo (8 days23 hrs5 mins4 secs)
          Apr-27 2:43:47 PM         Event    Event Trigger "Timers Game Room Timer"
          Apr-27 2:43:47 PM         Insteon    Received 31.81.42:(Game Room Motion Sensor Occupancy SensorGo ON
          Apr
          -27 2:42:44 PM         Info    System connected to MyHomeSeer Service successfully.
          Apr-27 2:42:44 PM         Info    System connected to MyHomeSeer Servicewaiting for acknowledge...
          Apr-27 2:42:41 PM         Info    System connected to MyHomeSeer Service successfully.
          Apr-27 2:42:40 PM         Info    System connected to MyHomeSeer Servicewaiting for acknowledge...
          Apr-27 2:41:53 PM         Error    Creating connection to MyHS servicethere may be a problem with the server or the Internet connectionThe connection will be attempted again shortly.
          Apr-27 2:41:31 PM         Insteon    Received 29.53.8C:(Kitchen Fluorescent Counter VR Button On/LoadGo ON
          Apr
          -27 2:40:34 PM         Insteon    Reset and Reprogram Complete.
          Apr-27 2:40:19 PM         Insteon    Received 25.48.85:(Attic LightsGo OFF Fast
          Apr
          -27 2:39:07 PM         Insteon    Now reprogramming the interface link database...
          Apr-27 2:38:52 PM         Insteon    Now resetting your interface. This will take about 15 secs...
          Apr-27 2:36:36 PM         Plug-In    Finished initializing plug-in Insteon
          Apr
          -27 2:36:36 PM         Insteon    External Device Registration complete.
          Apr-27 2:36:36 PM         Insteon    Waiting to initialize External Devices...
          Apr-27 2:36:34 PM         Insteon    RF PLM contacted on COM4 with an Insteon address of 30.DB.E2 and firmware version 9E
          Apr
          -27 2:36:33 PM         HSTouch ServerError    HSTouch had an Error retrieving the capabilities with Error Object reference not set to an instance of an objectService VersionNO_VERSION
          Apr
          -27 2:36:33 PM         Insteon    Insteon Support library (Insteon.dllversion1.0.5.21
          Apr
          -27 2:36:33 PM         Info    Plugin Insteon has connectedIP:127.0.0.1:64639
          Apr
          -27 2:36:03 PM         Info    Plugin Insteon with instancehas disconnected
          Apr
          -27 2:36:03 PM         Plug-In    Shutting down Plug-InInsteon 
          HSPro: 3.0.0.194
          PL: Insteon PLM 3.0.5.20,Insteon Thermostat 3.0.1.1 , UltraM1G, RainRelay8, UltraECM3, UltraPioneerAVR3, BLBackup, weatherXML, Jon00 Network & PC Monitor
          HW : Win 7 64bit, Intel i7-2600, 16 GB DDR3 Ram, 60 Plus Insteon Dual Band Devices, Rain8 Pro2, Elk M1 Gold, Brueltech GreenEye.

          Comment


            #20
            Glad you got it working.
            Mark

            HS3 Pro 3.0.0.534
            Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
            Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
            Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

            Comment

            Working...
            X