Announcement

Collapse
No announcement yet.

Enable Interface problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Enable Interface problem

    Mark,
    I have been testing an interface that detects power loss in the electrical circuit that the PLM is connected to. The interface activates a virtual device in HS3, which initiates an event to disable your interface on power loss. When power is restored, the device will enable your interface. All is functioning properly but I do have an issue when the interface is re-enabled. Some times, but not every time, I get a message:
    "Error: Could not open COM6 - Access to the port 'COM6' is denied". When this happens, I have found that if I wait about 15 minutes, I can manually invoke the event to re-enable the interface and it will come back with the proper message and all is ok. My question is are you aware of some minimum time that should be transpire before enabling the interface. Any thoughts on this issue would be appreciated. Also, how soon after an outage would you recommend that the interface should be disabled. Thanks much!

    #2
    This msg "Error: Could not open COM6 - Access to the port 'COM6' is denied" usually means the port is stuck in some state that only a reboot can fix. Interesting that your found the 15 wait time to be sufficient for the OS to unlock/release the port.

    I would disable the PLM once the power has been off for more than a minute otherwise it will just start throwing errors.

    You could put a 15 min wait in the event to restart the port so you don't run into this issue.
    Mark

    HS3 Pro 3.0.0.534
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

    Comment


      #3
      Originally posted by mnsandler View Post
      This msg "Error: Could not open COM6 - Access to the port 'COM6' is denied" usually means the port is stuck in some state that only a reboot can fix. Interesting that your found the 15 wait time to be sufficient for the OS to unlock/release the port.

      I would disable the PLM once the power has been off for more than a minute otherwise it will just start throwing errors.

      You could put a 15 min wait in the event to restart the port so you don't run into this issue.
      thanks for the quick reply. I'll go with those times. the only downside I can see is if any event were supposed to run during that 15 min period, I'd loose it, but then again if the power were out for some period of time, I'd loose those events also...
      thanks again..

      Comment

      Working...
      X