Announcement

Collapse
No announcement yet.

Trouble Getting X10 Commands Sent

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Trouble Getting X10 Commands Sent

    I am having trouble send or receiving x10 commands. I am running HS3 3.0.0.181, HSTouch 3.0.0.68, and Insteon 3.0.5.20, and SimpleHomeNet 2.0.0.0. When using an X10 controller the Appliance Module (AM466) works fine. It's Code is B8. It hasn't worked for at least a couple of years but now I have need of using a few X10 devices in addition to about 70 Insteon individual devices.

    I turned on detailed logging and received the following and using the Tools/Control Panel I am sending an on and off command to a x10 appliance module. It never changes state. I have the Insteon config set for "Enable X10" and I clicked on "Update X10 Devices". What else must I do?

    Jun-11 9:19:55 AM Insteon Starting Scheduled Polling...

    Jun-11 9:19:55 AM Insteon Timed poll for Insteon device Workshop Light (23.F3.7F), Last contact 6/11/2015 8:59:40 AM. Polling interval of 20 min. reached, polling...

    Jun-11 9:19:55 AM Insteon Requesting Insteon status (Polling) for device Workshop Light (23.F3.7F)

    Jun-11 9:19:55 AM Insteon Attempting to update the status for Workshop Light (23.F3.7F)

    Jun-11 9:19:55 AM Insteon Sending command 02 62 23 F3 7F 0A 19 00 to RF PLM, (Expecting 0 bytes extra back) Pre-Payload ACK:False, NAK is ok:False

    Jun-11 9:19:55 AM Insteon ..Got RF PLM Response 02 62 23 F3 7F 0A 19 00 06

    Jun-11 9:19:57 AM Insteon Received STX 0x50 (Raw Insteon Rec):23 F3 7F 2B 91 E1 23 04 00

    Jun-11 9:19:57 AM Insteon [CheckDeltas] Database recently heard delta value for device 23.F3.7F is current.

    Jun-11 9:19:57 AM Insteon Database delta value of 4 for device 23.F3.7F is current. No changes since last database update.

    Jun-11 9:19:57 AM Insteon Received message from Workshop Light (23.F3.7F) taking hops: 3

    Jun-11 9:19:57 AM Insteon StandardDeviceClass ProcessStatus called with Level:0

    Jun-11 9:19:57 AM Insteon Received a Direct ACK from Workshop Light (23.F3.7F)

    Jun-11 9:19:57 AM Insteon Setting status and value for device 23.F3.7F:1. Old status:0 Old Value:0, New Status:3 New Value:0

    Jun-11 9:19:57 AM Insteon Received STX 0x50 (Raw Insteon Rec):23 F3 7F 2B 91 E1 23 04 00 Debouncing repeat.

    Jun-11 9:19:58 AM Insteon ..Finished Scheduled Polling for 1 devices.

    Jun-11 9:20:10 AM Insteon Starting Scheduled Polling...

    Thanks,
    Bruce
    Last edited by bilesb; June 11, 2015, 09:33 AM. Reason: Forgot to mention I have a 2413U Rev 1.B

    #2
    this is all insteon traffic

    x10 msgs have the following outbound format

    02 63 XX YY

    can you check the hs startup log and see if the x10 protocol is initialized

    try pressing an on/off btn associated with appliance module
    Mark

    HS3 Pro 3.0.0.534
    Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
    Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
    Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

    Comment


      #3
      Log results

      The following is my log results. I see no showing of statement of initializing X10.

      Thanks Mark for looking at this.

      Bruce

      6/11/2015

      Jun-11 1:59:13 PM Startup Settings Loaded.

      Jun-11 1:59:13 PM Startup

      Jun-11 1:59:13 PM Startup ************************************************************ ********************

      Jun-11 1:59:13 PM Startup HomeSeer version 3.0.0.181 Edition: HS3 Standard Starting Now

      Jun-11 1:59:13 PM Startup ************************************************************ ********************

      Jun-11 1:59:13 PM Startup

      Jun-11 1:59:13 PM Startup Creating Class Objects...

      Jun-11 1:59:13 PM Startup COM port classes started.

      Jun-11 1:59:13 PM Startup Application interface class started.

      Jun-11 1:59:13 PM Startup Web server class started.

      Jun-11 1:59:13 PM Startup E-Mail SEND class started.

      Jun-11 1:59:13 PM Startup E-Mail RECEIVE class started.

      Jun-11 1:59:13 PM Startup Plug-In Interface class started.

      Jun-11 1:59:13 PM Startup HSPhone external interface class started.

      Jun-11 1:59:13 PM Startup Local voice recognition class started.

      Jun-11 1:59:13 PM Startup Database SAVE process started.

      Jun-11 1:59:13 PM Startup Loading configuration file ...

      Jun-11 1:59:13 PM Database Opening (Mode=Read Only) up HomeSeer database C:\Program Files (x86)\HomeSeer HS3\Data\HomeSeerData-2015-06-08.hsd

      Jun-11 1:59:13 PM Database Loading Devices...

      Jun-11 1:59:13 PM Load Config 193 total devices loaded.

      Jun-11 1:59:13 PM Load Config Loading Event Groups...

      Jun-11 1:59:13 PM Load Config Loading Events...

      Jun-11 1:59:13 PM Load Config 78 total events loaded.

      Jun-11 1:59:13 PM Load Config Loading COUNTERS...

      Jun-11 1:59:13 PM Load Config Loading TIMERS...

      Jun-11 1:59:13 PM Startup HomeSeer version is: 3.0.0.181

      Jun-11 1:59:13 PM Startup Creating Speaker Client Interface Object...

      Jun-11 1:59:13 PM Startup This version of HomeSeer is registered as a HS3STANDARD version.

      Jun-11 1:59:16 PM Info Remote plug-in API interface started on port 10400

      Jun-11 1:59:16 PM Startup Checking for available plug-ins

      Jun-11 1:59:16 PM Plug-In Found plug-in: HSTouch Server, version: 3.0.0.68

      Jun-11 1:59:16 PM Plug-In Found plug-in: Insteon, version: 3.0.5.20

      Jun-11 1:59:16 PM Plug-In Found plug-in: SimpleHomeNet, version: 2.0.0.0

      Jun-11 1:59:16 PM Startup Initializing Plug-Ins

      Jun-11 1:59:16 PM Info Plugin HSTouch Server has connected. IP:127.0.0.1:62884

      Jun-11 1:59:17 PM Plug-In Finished initializing plug-in HSTouch Server

      Jun-11 1:59:17 PM Info Plugin Insteon has connected. IP:127.0.0.1:62886

      Jun-11 1:59:17 PM Insteon Insteon Support library (Insteon.dll) version: 1.0.5.20

      Jun-11 1:59:18 PM Insteon RF PLM contacted on COM3 with an Insteon address of 2B.91.E1 and firmware version 9B

      Jun-11 1:59:22 PM Insteon Waiting to initialize External Devices...

      Jun-11 1:59:22 PM Plug-In Finished initializing plug-in Insteon

      Jun-11 1:59:22 PM Info Plugin SimpleHomeNet has connected. IP:127.0.0.1:62889

      Jun-11 1:59:22 PM SimpleHomeNet InitIO called, plug-in is being initialized...

      Jun-11 1:59:22 PM Plug-In Finished initializing plug-in SimpleHomeNet

      Jun-11 1:59:22 PM Web Server Local IP address (subnet) is: 192.168.0.19 (255.255.255.0)

      Jun-11 1:59:22 PM Web Server UPNP Discovery started

      Jun-11 1:59:22 PM Web Server Web Server started on port 80

      Jun-11 1:59:24 PM Startup Creating ASP.NET application host...

      Jun-11 1:59:25 PM Startup Start automation engine...

      Jun-11 1:59:25 PM Startup Initializing Speaker Client Interface

      Jun-11 1:59:25 PM Speech Listening for remote speaker connections on port 10401

      Jun-11 1:59:25 PM Database Opening (Mode=Read/Write) up HomeSeer Energy database C:\Program Files (x86)\HomeSeer HS3\Data\Energy\Energy.hsd

      Jun-11 1:59:25 PM Startup Updater services starting...

      Jun-11 1:59:25 PM Startup Starting DDNS service...

      Jun-11 1:59:25 PM HSTouch Server Server started on port 10200

      Jun-11 1:59:25 PM Startup Running the startup script Startup.vb

      Jun-11 1:59:25 PM Insteon External Device Registration complete.

      Jun-11 1:59:26 PM Startup Starting Event Scheduler...

      Jun-11 1:59:26 PM Startup (Startup.vb script) Scripting is OK and is now running Startup.vb

      Jun-11 1:59:26 PM Startup (Startup.vb script) No speaker clients detected, waiting up to 30 seconds for any to connect...

      Jun-11 1:59:26 PM Startup HSSentry is disabled in Setup, sentry will not be started.

      Jun-11 1:59:26 PM Startup Start up complete.

      Jun-11 1:59:26 PM Info System connected to MyHomeSeer Service, waiting for acknowledge...

      Jun-11 1:59:26 PM Info System connected to MyHomeSeer Service successfully.

      Jun-11 1:59:26 PM Insteon External device name 28.AB.98 (Address:28.AB.98) has registered as external device #1

      Jun-11 1:59:28 PM Web Server Web Server authorized local login successful from: 192.168.0.19 User: brucebiles@cox.net

      Jun-11 1:59:57 PM TTS Speak ():Welcome to Home-Seer

      Jun-11 2:00:02 PM Speaker Speaker host added, Name: BILES-HP Instance: Default IP address: 127.0.0.1

      Jun-11 2:02:18 PM Insteon Starting Scheduled Polling...

      Jun-11 2:02:25 PM Device Control Device: Library Appliance Module for Testing to On (100) by/from: CAPI Control Handler

      Jun-11 2:02:25 PM Insteon CAPIControl: Label=On, Value=100, ControlType=Button

      Jun-11 2:02:25 PM Insteon Immediate Send X10 Command: B8 Cmd:2 Pcnt:100 Data1: 0 Data2:0

      Jun-11 2:02:25 PM Insteon Sending command 02 63 ED 00 to RF PLM, (Expecting 0 bytes extra back) Pre-Payload ACK:False, NAK is ok:False

      Jun-11 2:02:25 PM Insteon ..Got RF PLM Response 02 63 ED 00 06

      Jun-11 2:02:25 PM Insteon Sending command 02 63 E2 80 to RF PLM, (Expecting 0 bytes extra back) Pre-Payload ACK:False, NAK is ok:False

      Jun-11 2:02:25 PM Insteon ..Got RF PLM Response 02 63 E2 80 06

      Jun-11 2:02:30 PM Device Control Device: Library Appliance Module for Testing to Off (0) by/from: CAPI Control Handler

      Jun-11 2:02:30 PM Insteon CAPIControl: Label=Off, Value=0, ControlType=Button

      Jun-11 2:02:30 PM Insteon Immediate Send X10 Command: B8 Cmd:3 Pcnt:0 Data1: 0 Data2:0

      Jun-11 2:02:30 PM Insteon Sending command 02 63 ED 00 to RF PLM, (Expecting 0 bytes extra back) Pre-Payload ACK:False, NAK is ok:False

      Jun-11 2:02:30 PM Insteon ..Got RF PLM Response 02 63 ED 00 06

      Jun-11 2:02:31 PM Insteon Sending command 02 63 E3 80 to RF PLM, (Expecting 0 bytes extra back) Pre-Payload ACK:False, NAK is ok:False

      Jun-11 2:02:31 PM Insteon ..Got RF PLM Response 02 63 E3 80 06

      Jun-11 2:02:33 PM Insteon Starting Scheduled Polling...

      Jun-11 2:02:48 PM Insteon Starting Scheduled Polling...

      Comment


        #4
        well i don't see the startup msgs, but i do see msgs of the plugin sending x10 cmds to the plm and the plm responding; so that is good.

        so i would suggest moving an x10 device closer to the plm and see if the x10 module responds.
        Mark

        HS3 Pro 3.0.0.534
        Hardware: Insteon Serial PLM | AD2USB for Vista Alarm | HAI Omnistat2 | 1-Wire HA7E | RFXrec433 | Dahua Cameras | LiftMaster Internet Gateway
        Plugins: Insteon (mine) | Vista Alarm (mine) | Omnistat 3 (by Kirby) | Ultra1Wire3 | RFXCOM | NetCAM | MyQ | BLRadar | BLDenon | Jon00 Charting
        Platform: HP h8-1360t, Windows Server 2012 R2, i7-3.4GHz, 16GB memory

        Comment

        Working...
        X