Announcement

Collapse
No announcement yet.

HS Insteon Plugin hangs when PowerLinc 2413U tries AddDevice

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • homeautomationinct
    replied
    I couldn't get Homeseer to work well under recent updates of Windows 10, similar issues, the USB Insteon interface was not working. I'm trying the Raspberry Pi version, which seems at least stable for Inseton. The USB interface used to work even under Windows 10. My guess is Microsoft "improved" something which hasn't been recognized yet.

    Leave a comment:


  • scottg
    started a topic HS Insteon Plugin hangs when PowerLinc 2413U tries AddDevice

    HS Insteon Plugin hangs when PowerLinc 2413U tries AddDevice

    I'm doing a trial upgrade HS2 to HS3 and can't get my existing Insteon devices working using the included HomeSeer 1.0.0.9 Insteon plugin (not the Mark Sandler paid plugin).

    The plugin is communicating with the PowerLinc and can retrieve a list of nodes. But when I try my first Tap Link to add a ICON SwitchLinc Dimmer, the plugin hangs in HS3 and the only way to clear it is to shutdown HS3 and restart it. Here's a log snippet with the last debug entry before the plugin hangs. HS3 still responds and I can navigate to other menu options. But when I navigate back to PLUG-INS | HSInsteon | Config, the only thing showing on the Devices tab is a never-ending spinner with a label "Programming Device. Please Wait..."



    Code:
    Feb-05 10:10:52 AM	 	HSInsteon	DEBUG PLM: 02 62 03 D3 F5 1F 2F 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 06 ACK
    Feb-05 10:10:52 AM	 	HSInsteon	DEBUG PROCESSOR: Echo '62 03 D3 F5 1F 2F 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00' matched
    Feb-05 10:10:52 AM	 	HSInsteon	DEBUG RX: 02 62 03 D3 F5 1F 2F 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 06
    Feb-05 10:10:52 AM	 	HSInsteon	DEBUG TX: 02 62 03 D3 F5 1F 2F 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    Feb-05 10:10:52 AM	 	HSInsteon	DEBUG Device 03.D3.F5 received message IncrementEndBroadcast
    Feb-05 10:10:52 AM	 	HSInsteon	DEBUG PROCESSOR: Message '50 03 D3 F5 00 00 01 C7 18 00' processed... MessageId=50 MessageType=IncrementEndBroadcast FromAddress=03D3F5 MessageFlagsMaxHops=03 MessageFlagsRemainingHops=01 MessageFlagsExtendedFlag=00 MessageFlagsAck=00 MessageFlagsAllLink=01 MessageFlagsBroadcast=01 Cmd1=18 Cmd2=00 Group=01
    Feb-05 10:10:52 AM	 	HSInsteon	DEBUG RX: 02 50 03 D3 F5 00 00 01 C7 18 00 (appended)
    Feb-05 10:10:52 AM	 	HSInsteon	DEBUG RX: 02 50 03 D3 F5
    Feb-05 10:10:52 AM	 	HSInsteon	DEBUG Device 03.D3.F5 TryReadALDBRecords
    Feb-05 10:10:52 AM	 	HSInsteon	DEBUG Device 03.D3.F5 GetEngineVersion returning 00
    Feb-05 10:10:52 AM	 	HSInsteon	DEBUG Device 03.D3.F5 received message Ack
    Feb-05 10:10:52 AM	 	HSInsteon	DEBUG PROCESSOR: Message '50 03 D3 F5 2B 92 28 27 0D 00' processed... MessageId=50 MessageType=Ack FromAddress=03D3F5 MessageFlagsMaxHops=03 MessageFlagsRemainingHops=01 MessageFlagsExtendedFlag=00 MessageFlagsAck=01 MessageFlagsAllLink=00 MessageFlagsBroadcast=00 ToAddress=2B9228 Cmd1=0D Cmd2=00
    Feb-05 10:10:52 AM	 	HSInsteon	DEBUG RX: 02 50 03 D3 F5 2B 92 28 27 0D 00
    Feb-05 10:10:51 AM	 	HSInsteon	DEBUG PLM: 02 62 03 D3 F5 0F 0D 00 06 ACK
    Feb-05 10:10:51 AM	 	HSInsteon	DEBUG PROCESSOR: Echo '62 03 D3 F5 0F 0D 00' matched
    Feb-05 10:10:51 AM	 	HSInsteon	DEBUG RX: 02 62 03 D3 F5 0F 0D 00 06
    Feb-05 10:10:51 AM	 	HSInsteon	DEBUG TX: 02 62 03 D3 F5 0F 0D 00
    Feb-05 10:10:51 AM	 	HSInsteon	DEBUG Device 03.D3.F5 GetEngineVersion
    Feb-05 10:10:51 AM	 	HSInsteon	DEBUG Controller received message DeviceLink
    Feb-05 10:10:51 AM	 	HSInsteon	DEBUG PROCESSOR: Message '53 01 01 03 D3 F5 01 03 27' processed... MessageId=53 MessageType=DeviceLink LinkType=01 LinkGroup=01 Address=03D3F5 DevCat=01 SubCat=03 FirmwareVersion=27
    Feb-05 10:10:51 AM	 	HSInsteon	DEBUG RX: 02 53 01 01 03 D3 F5 01 03 27
    Feb-05 10:10:42 AM	 	HSInsteon	DEBUG WARNING: Unknown device 03.D3.F5 received message IncrementBeginBroadcast
    Feb-05 10:10:42 AM	 	HSInsteon	DEBUG PROCESSOR: Message '50 03 D3 F5 00 00 01 C7 17 01' processed... MessageId=50 MessageType=IncrementBeginBroadcast FromAddress=03D3F5 MessageFlagsMaxHops=03 MessageFlagsRemainingHops=01 MessageFlagsExtendedFlag=00 MessageFlagsAck=00 MessageFlagsAllLink=01 MessageFlagsBroadcast=01 Cmd1=17 Cmd2=01 Group=01 IncrementDirection=01
    Feb-05 10:10:42 AM	 	HSInsteon	DEBUG RX: 02 50 03 D3 F5 00 00 01 C7 17 01
    Feb-05 10:10:31 AM	 	HSInsteon	DEBUG PLM: 02 64 03 01 06 ACK
    Feb-05 10:10:31 AM	 	HSInsteon	DEBUG PROCESSOR: Echo '64 03 01' matched
    Feb-05 10:10:31 AM	 	HSInsteon	DEBUG RX: 02 64 03 01 06
    Feb-05 10:10:31 AM	 	HSInsteon	DEBUG TX: 02 64 03 01
    Feb-05 10:10:31 AM	 	HSInsteon	DEBUG Controller 2B.92.28 EnterLinkMode(mode:Either, group:01)


    Thanks everyone/anyone. I've been a long-time lurker. But now I need support.


    Current Date/Time: 2/5/2017 11:07:11 AM
    HomeSeer Version: HS3 Pro Edition 3.0.0.298
    Operating System: Microsoft Windows Home Server 2011 - Server
    System Uptime: 0 Days 0 Hours 0 Minutes 20 Seconds
    IP Address: 192.168.0.16
    Number of Devices: 10
    Number of Events: 1
    Available Threads: 200

    Enabled Plug-Ins
    1.0.0.9: HSInsteon
    3.0.1.87: Z-Wave
    Attached Files
Working...
X