Announcement

Collapse
No announcement yet.

Can't find Bridge

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • NickTheGreat
    replied
    I'll have to look into this. Wim and went back and forth for many days or weeks and never got it to work. It got to the point where it wasn't worth my time, just for 3 light bulbs.

    I like the idea of having Hue stuff in my house, so I may dredge this back up. Just not wild about paying for a plugin if it ends up not working for me.

    Leave a comment:


  • Viper8726
    replied

    Leave a comment:


  • NickTheGreat
    replied
    Thanks Wim. I emailed you the log file just a minute or so ago.

    Leave a comment:


  • w.vuyk
    replied
    Nick,

    Could you do the following for me? On the configuration page of the plugin and enable both deep logging and log to file. Then restart the plugin and let it run for 20 minutes or so. Then disable deep loggin and log to file in the configuration page.
    you will find a log in the logs subdirectory of your HS3 installation directory. Could you send the JowiHue.log file to me, so I can have a deeper look?

    Send it to w dot vuyk at upcmail dot nl?

    Thanks,

    Wim

    Leave a comment:


  • NickTheGreat
    replied
    Code:
    Feb-09 6:00:36 PM	 	JowiHue	Warning: MainWatchThread: No bridge found, plugin will scan until found
    Feb-09 5:59:06 PM	 	JowiHue	Error: (BridgeFound):Conversion from type 'DBNull' to type 'String' is not valid.
    Feb-09 5:58:36 PM	 	JowiHue	Warning: MainWatchThread: No bridge found, plugin will scan until found
    Feb-09 5:56:36 PM	 	JowiHue	Warning: MainWatchThread: No bridge found, plugin will scan until found
    Feb-09 5:54:36 PM	 	JowiHue	Warning: MainWatchThread: No bridge found, plugin will scan until found
    Feb-09 5:54:06 PM	 	JowiHue	Error: (BridgeFound):Conversion from type 'DBNull' to type 'String' is not valid.
    Feb-09 5:52:36 PM	 	JowiHue	Warning: MainWatchThread: No bridge found, plugin will scan until found
    Feb-09 5:50:36 PM	 	JowiHue	Warning: MainWatchThread: No bridge found, plugin will scan until found
    Feb-09 5:49:06 PM	 	JowiHue	Error: (BridgeFound):Conversion from type 'DBNull' to type 'String' is not valid.
    Feb-09 5:48:36 PM	 	JowiHue	Warning: MainWatchThread: No bridge found, plugin will scan until found
    Feb-09 5:46:36 PM	 	JowiHue	Warning: MainWatchThread: No bridge found, plugin will scan until found
    Feb-09 5:44:36 PM	 	JowiHue	Warning: MainWatchThread: No bridge found, plugin will scan until found
    Feb-09 5:44:06 PM	 	JowiHue	Error: (BridgeFound):Conversion from type 'DBNull' to type 'String' is not valid.
    Feb-09 5:42:35 PM	 	JowiHue	Warning: MainWatchThread: No bridge found, plugin will scan until found
    Feb-09 5:40:35 PM	 	JowiHue	Warning: MainWatchThread: No bridge found, plugin will scan until found
    Feb-09 5:39:06 PM	 	JowiHue	Error: (BridgeFound):Conversion from type 'DBNull' to type 'String' is not valid.
    Feb-09 5:38:35 PM	 	JowiHue	Warning: MainWatchThread: No bridge found, plugin will scan until found
    Feb-09 5:36:35 PM	 	JowiHue	Warning: MainWatchThread: No bridge found, plugin will scan until found
    Feb-09 5:34:35 PM	 	JowiHue	Warning: MainWatchThread: No bridge found, plugin will scan until found
    Feb-09 5:34:06 PM	 	JowiHue	Error: (BridgeFound):Conversion from type 'DBNull' to type 'String' is not valid.
    Feb-09 5:32:35 PM	 	JowiHue	Warning: MainWatchThread: No bridge found, plugin will scan until found
    Feb-09 5:30:35 PM	 	JowiHue	Warning: MainWatchThread: No bridge found, plugin will scan until found
    Feb-09 5:29:06 PM	 	JowiHue	Error: (BridgeFound):Conversion from type 'DBNull' to type 'String' is not valid.
    Feb-09 5:28:35 PM	 	JowiHue	Warning: MainWatchThread: No bridge found, plugin will scan until found
    Feb-09 5:26:35 PM	 	JowiHue	Warning: MainWatchThread: No bridge found, plugin will scan until found
    Feb-09 5:24:35 PM	 	JowiHue	Warning: MainWatchThread: No bridge found, plugin will scan until found
    Feb-09 5:24:06 PM	 	JowiHue	Error: (BridgeFound):Conversion from type 'DBNull' to type 'String' is not valid.
    Feb-09 5:22:35 PM	 	JowiHue	Warning: MainWatchThread: No bridge found, plugin will scan until found
    Feb-09 5:20:35 PM	 	JowiHue	Warning: MainWatchThread: No bridge found, plugin will scan until found
    Feb-09 5:19:06 PM	 	JowiHue	Error: (BridgeFound):Conversion from type 'DBNull' to type 'String' is not valid.
    Feb-09 5:18:36 PM	 	JowiHue	Warning: MainWatchThread: No bridge found, plugin will scan until found
    Feb-09 5:18:36 PM	 	Plug-In	Finished initializing plug-in JowiHue
    Feb-09 5:18:35 PM	 	JowiHue	InitIO:Plugin basic initialisation done
    Feb-09 5:18:35 PM	 	JowiHue	Starting plugin JowiHue 1.1.2.8 on Windows
    Feb-09 5:18:35 PM	 	Info	Plugin JowiHue has connected. IP:127.0.0.1:50123
    Feb-09 5:18:34 PM	 	Plug-In	Interface JowiHue is running as a trial, 29 days remaining.
    This is the log from last night. It did this pretty much all night and morning long.

    But I did notice this line later on
    Code:
    Feb-09 7:10:36 PM	 	JowiHue	Warning: MainWatchThread: No bridge found, plugin will scan until found
    Feb-09 7:10:15 PM	 	Warning	Error handling UPNP request: Unable to write data to the transport connection: An established connection was aborted by the software in your host machine.
    Feb-09 7:09:06 PM	 	JowiHue	Error: (BridgeFound):Conversion from type 'DBNull' to type 'String' is not valid.
    Feb-09 7:08:36 PM	 	JowiHue	Warning: MainWatchThread: No bridge found, plugin will scan until found
    Which maybe points to a situation with my router? I just checked and UPNP is 'enabled' on my router.

    Not sure what to make of all this. Appreciate your help and advice.

    *edit. I did try to disable my antivirus and my windows firewall and get the same messages.
    Last edited by NickTheGreat; February 10th, 2017, 09:26 AM. Reason: added info

    Leave a comment:


  • NickTheGreat
    replied
    Originally posted by w.vuyk View Post
    Nick,

    Sorry, Missed to answer your question yesterday. There should be no need to reset the hub for the plugin in anyway. But something went wrong. Why is a question that is still here.
    • On what OS are you running the plugin? Windows or Linux.
    • Which version of the plugin are you running? If needed upgrade to 1.1.2.8 which is quite new and solved some issues.
    • What is showing in your log when you start the plugin? (you can filter on "JowiHue" in the log. You could post that log here, I will need to see entries from the start to more or less 30 minutes of running?
    • You might want to check if UPNP is enabled on your router. The plugin is depending on it.
    • If you are running on Windows, you might need to allow the plugin through the Windows Firewall. It asks for that on the first run, but if you denied that, the plugin will not find the bridges. You can test this by temporary disabling the windows firewall


    Let me know your results?

    Thanks,

    Wim
    Thanks for the reply, Wim.

    I have using HS3 on a Windows 10 NUC.
    I'm not at the machine right now, so I'm not sure on the version of hte plugin. I installed from the "store" a few days ago, so I'd like to think it's the most recent.

    I did let the plugin through the firewall and did try disabling the firewall the other day with no success.

    Not sure on the UPNP. I don't recall disabling it, but I'll check for sure tonight.

    I disabled the plugin last night, but I'll start it tonight and try to post the whole log. It seemed to show the same lines I posted in my OP every two minutes, but I dont' know what it said on startup.

    Thanks for answering, and I'll try to come back with details.

    Leave a comment:


  • w.vuyk
    replied
    Originally posted by NickTheGreat View Post
    Does this make sense to anyone else? I'll check when I get home from work later today, but I don't know what else I can really "do."

    Do I need to factory reset the Hue Hub or do something else? The instructions for the plugin basically say to install and it'll work on it's own.
    Nick,

    Sorry, Missed to answer your question yesterday. There should be no need to reset the hub for the plugin in anyway. But something went wrong. Why is a question that is still here.
    • On what OS are you running the plugin? Windows or Linux.
    • Which version of the plugin are you running? If needed upgrade to 1.1.2.8 which is quite new and solved some issues.
    • What is showing in your log when you start the plugin? (you can filter on "JowiHue" in the log. You could post that log here, I will need to see entries from the start to more or less 30 minutes of running?
    • You might want to check if UPNP is enabled on your router. The plugin is depending on it.
    • If you are running on Windows, you might need to allow the plugin through the Windows Firewall. It asks for that on the first run, but if you denied that, the plugin will not find the bridges. You can test this by temporary disabling the windows firewall


    Let me know your results?

    Thanks,

    Wim

    Leave a comment:


  • NickTheGreat
    replied
    Does this make sense to anyone else? I'll check when I get home from work later today, but I don't know what else I can really "do."

    Do I need to factory reset the Hue Hub or do something else? The instructions for the plugin basically say to install and it'll work on it's own.

    Leave a comment:


  • NickTheGreat
    started a topic Can't find Bridge

    Can't find Bridge

    It's probably operator error, but I can't get the plugin to find my bridge. I install it and the log never shows it being found.

    Just get these messages

    Feb-07 9:20:16 PM JowiHue Warning: MainWatchThread: No bridge found, plugin will scan until found
    Feb-07 9:19:46 PM JowiHue Error: (BridgeFound):Conversion from type 'DBNull' to type 'String' is not valid.
    Feb-07 9:18:16 PM JowiHue Warning: MainWatchThread: No bridge found, plugin will scan until found
    Feb-07 9:16:16 PM JowiHue Warning: MainWatchThread: No bridge found, plugin will scan until found
    I can't even try to manually add the bridge with the INI file, because I don't have the INI file in my install directory?

    AM I not installing correctly? I'm new to HS, and frankly having a real tough time getting any plug in to work.

    Thanks to any and all advice
Working...
X