Announcement

Collapse
No announcement yet.

Beta JowiHue: adding support for RaspBee and ConBee gateway

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • I have dedicated a rpi3 to deConz and the RaspBee. I have a small network of Hue lights, sensors and switches and a couple of other Zigbee lights. But the load average doesn't go above 0.15 and the deConz cpu stays below 10%. I am thinking of using that rpi3 to do other tasks, possibly run the JowiHue plug-in remotely.

    Comment


    • Originally posted by mhn View Post
      Hi Wim.

      Change to router and back - leave and rejoin.

      No luck and CPU high again.

      I will send you detailed log om mail.

      Regards
      Morten
      With the help of Morton we have found the issue.
      Registration of the deCONZ gateway on a different webport is what went wrong. This is corrected now in 2.0.0.21, which I will send to the updater today!

      Thanks,

      Wim
      -- Wim

      Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
      650 devices ---- 336 events ----- 40 scripts

      Comment


      • Hi - is there any way to get the new version before it arrives in the updater? My ConBee arrived today and I can't register the DeConZ gateway as a bridge with the plugin. It's on port 8080.

        (Alternatively, is there a way to change the port DeConZ uses? and if so, which port is JowHue looking for?)

        Thanks,

        Jon.

        Comment


        • Jon,

          Yeah, for some reason HST is taking more time to publish the new beta.
          The port is chosen by deCONZ and is not yet configurable by the user. The request for that is out already, but not yet honoured.

          The plugin can handle the different port perfectly, but indeed missed on the registration part. I have send you a PM on that.

          Thanks,

          Wim
          -- Wim

          Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
          650 devices ---- 336 events ----- 40 scripts

          Comment


          • All,

            the new beta, 2.0.0.21 is published now. This solves an issue with the deCONZ interface using a non 80 port. This would cause registration of the gateway to go wrong. It now should be ok, with deCONZ choosing its own port.

            Wim
            -- Wim

            Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
            650 devices ---- 336 events ----- 40 scripts

            Comment


            • Wim, I have the qt5 version of deCONZ installed (so as to run it on a pi pi with debian strecth). I'm going slow, but everything seems to work, well. I migrated my first light and it showed up perfrctly in JowiHue!

              Comment


              • Originally posted by w.vuyk View Post
                Diderik,

                Keep us posted here, I am guessing others might want to know too here

                Wim
                Unfortunately, I cannot find a way to serialize (over ser2net) the ConBee. I am keeeping plugged in on the same machine as I have deCONZ running. I am unsing a pi 2 I hade lying around. deCONZ runs well, and I also serialize the UZB! z-wave stick as well as the rfxtrx to the server from the same pi.

                Comment


                • Originally posted by w.vuyk View Post
                  The port is chosen by deCONZ and is not yet configurable by the user. The request for that is out already, but not yet honoured.
                  I think you can change the port for deCONZ by editing
                  Code:
                  /usr/bin/deCONZ-autostart.sh
                  and adding
                  HTML Code:
                  --http-port=80
                  or whichever port you prefer.

                  Comment


                  • Diderik,

                    The manual port adding seems not to work - at least that is I read on the github... there is an method but then you have to recompile? Anyway, it is on the list for a future version.

                    Hope you get everything over... if you have sensore, those are the biggest win on deCONZ For me the remote from IKEA and the Xiaomi cube are my favorites now

                    Thanks,

                    Wim
                    -- Wim

                    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                    650 devices ---- 336 events ----- 40 scripts

                    Comment


                    • Originally posted by w.vuyk View Post
                      Hope you get everything over... if you have sensore, those are the biggest win on deCONZ For me the remote from IKEA and the Xiaomi cube are my favorites now
                      Ooooh, I'm so looking forward to make that work!

                      One firmware update away...
                      HSPro 3.0.0.458, Z-NET with Z-wave plugin 3.0.1.190, RFXCOM + 2x RFXtrx433E, HSTouch, Squeezebox plugin, iTach IP/WF2IR & GC-100-6 with UltraGCIR, BLDenon, NetcamStudio, Jon00s Webpage builder, Harmony Hub plugin, SCSIP (with FreePBX), Arduino plugin, IFTTT, Pushalot plugin, Device History plugin.
                      Running on Windows 10 (64) virtualized
                      on ESXi (Fujitsu Primergy TX150 S8).
                      WinSeer (for Win10) - TextSeer - FitbitSeer - HSPI_MoskusSample

                      Are you Norwegian (or Scandinavian) and getting started with HomeSeer? Read the "HomeSeer School"!

                      Comment


                      • Originally posted by w.vuyk View Post
                        The manual port adding seems not to work - at least that is I read on the github... there is an method but then you have to recompile?
                        I am running in port 80. Not quite sure how I endred up there.

                        Originally posted by Moskus View Post
                        Ooooh, I'm so looking forward to make that work!
                        Me too! I can't wait to get my hands on zigbee sensors and remotes! For now I only have Hue lights that I am transferring.

                        Comment


                        • Hi Wim.

                          I had a lot of trouble getting Ikea Remote and PIR on deCONZ today.

                          I succeded at last but got errors in the HS log. ( No detailed sorry.)

                          okt-07 17:39:18 JowiHue Extra info: 0-0-1174-3
                          okt-07 17:39:18 JowiHue Error: (HSEvent):Error running config change:Min (7) must be less than or equal to max (-1) in a Range object.
                          okt-07 17:39:17 JowiHue Motion devices created for TRADFRI motion sensor
                          okt-07 17:39:17 JowiHue Battery device created for sensor TRADFRI motion sensor
                          okt-07 17:39:16 JowiHue Motion device created for sensor TRADFRI motion sensor
                          okt-07 17:34:13 JowiHue Extra info: 0-0-1173-3
                          okt-07 17:34:13 JowiHue Error: (HSEvent):Error running config change:Min (6) must be less than or equal to max (-1) in a Range object.

                          Theres no batteri device for the remote.

                          Everything seems to work.

                          Bulbs where no trouble.

                          Regards
                          Morten

                          Comment


                          • Morten,

                            Indeed I had my set of difficulties adding the motion sensor and remote of IKEA... Especially when you have the old firmware it can take quite some tries to join the devices with deCONZ. What I learned was that it is good to wathc the deCONZ device map at the same time. Quite often the device is already present but you need to press buttons/keep moving to let all the capabilities arrive in deCONZ, if you press the right (almost invisible) circle on the device in the interface you will get to see the endpoints discovered.

                            As long it did not yet get all the properties, the plugin will not be able to 'see' the new device yet.

                            The errors you are seeing are coming somehow through the HSEVENT actions of Homeseer. It could be initial responses while the sensors are not yet fully defined in the plugin. Will play with that by removing/adding sensors here. I should be able to copy the issues here.....

                            I will also check why the remote does not come with the battery device, I have the battery device here, so maybe I missed it due to some of my later changes.

                            Thanks,

                            Wim
                            -- Wim

                            Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                            650 devices ---- 336 events ----- 40 scripts

                            Comment


                            • Hi,

                              I am running the latest beta from the updater (v2.0.0.21) and deCONZ on the same machine as Homeseer. I had the bridge scanned and registered but on restarting Homeseer, the plugin is unable to see the bridge again.

                              I can remove, re-scan and re-register the deCONZ bridge again, but the plugin then immediately logs an error:

                              Oct-10 12:46:03 JowiHue Warning: IP address 192.168.3.135 reachable, known as ip address for a bridge, but is no longer recognised as bridge....
                              Oct-10 12:45:48 JowiHue Registration of bridge was succesfull
                              Oct-10 12:45:16 JowiHue ============================================================ ================================
                              Oct-10 12:45:16 JowiHue ------------------------------------------NEW Bridge ---------------------------------------
                              Oct-10 12:45:16 JowiHue Info: Unregistered bridge found at IP address 192.168.3.135
                              Oct-10 12:45:16 JowiHue Please register this bridge in the configuration page
                              Oct-10 12:45:16 JowiHue ============================================================ ================================
                              Oct-10 12:45:13 JowiHue Pressed button for immediate scan for bridges - scanning started


                              deCONZ is running on port 8080. I changed the HS SSL port to 444 to make sure that was 'out of the way' but still can't retain a connection between the plugin and deCONZ...

                              Any ideas?

                              Thanks,

                              Jon.

                              Comment


                              • Jon,

                                Yes, I already found the issue here. I need to iron out the last bits here, then I will send you a pm how to download the new version to test... should be in a few hours ok?

                                Wim
                                -- Wim

                                Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                                650 devices ---- 336 events ----- 40 scripts

                                Comment

                                Working...
                                X