Announcement

Collapse
No announcement yet.

Beta JowiHue: adding support for RaspBee and ConBee gateway

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #91
    Originally posted by Summerguy View Post
    Thank you so much for those informations ! I did buy some gear to test the hue system

    -3x gen3 colors bulb with the gen 3 hub
    -1x sensor
    -and 1x dimmer.

    i will see how how is is working! if i do not like it i'll return it.



    i have some other questions:


    1. Do you know why i can't discover my hue divices in alexa direcly from homeseer?

    2. When I ''turn on'' for ex, all my living room lights, the hue lights do not turn on at 100% like all my other lights, they turn at the last setting level.
    Is there a workaround for this? Do i need to create a virtual device ?
    2.1 In fact, i just want all my lights to behave the same way when i turn on a group a light. So i need to find a way to modify the lutron switch behavior.. or the philips light.


    thank you again!
    edit : i think i will stay with the hue bridge. The delay for the motionsensor is almost instant/ or is enough for my need.
    The light sensor on the same device take like 15-20 secs to update in homeseer... but i do not think i will use it


    do you think i will be able to see my philips hue devices in ALEXA with the ConBee USB gateway ?
    Last edited by MattL0; September 12th, 2017, 01:35 AM.

    Comment


    • #92
      Originally posted by Summerguy View Post
      i have some other questions:

      1. Do you know why i can't discover my hue divices in alexa direcly from homeseer?

      2. When I ''turn on'' for ex, all my living room lights, the hue lights do not turn on at 100% like all my other lights, they turn at the last setting level.
      Is there a workaround for this? Do i need to create a virtual device ?
      2.1 In fact, i just want all my lights to behave the same way when i turn on a group a light. So i need to find a way to modify the lutron switch behavior.. or the philips light.

      3. can a philips hue motion sensor act as a relay the the zigbenetwork ? or it is just the bulbs?
      because i placed the motion sensor in the middle of my appartment to be sure i the mesh network is reliable.
      I don't know how alexa works as it is not available here, it is only for US,UK and Germany I think. So I hope others can help you with that?

      If you turn on a bulb by event on the device itself(not the JowiHue actions) it should go on at 100% I think?
      When set through the JowiHue actions and you do not add the bright command, it will go on at last known level.

      Wim
      -- Wim

      Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
      650 devices ---- 336 events ----- 40 scripts

      Comment


      • #93
        Originally posted by Summerguy View Post
        edit : i think i will stay with the hue bridge. The delay for the motionsensor is almost instant/ or is enough for my need.
        The light sensor on the same device take like 15-20 secs to update in homeseer... but i do not think i will use it


        do you think i will be able to see my philips hue devices in ALEXA with the ConBee USB gateway ?
        I like the lightsensor my self. It does not updat very often, but it is not needed. But I use it to set lights in different rooms when it is not dark really yet. When a cloud passes by in front of the house for example, the kitchen light goes on, but the living room not yet. Works nice.

        One extra advise, the motion device is a battery operated devices and does not join for the meshing, because that would drain the batterry quite quickly I think?

        Also for the conbee, I do not know how Alexa works with that - I guess it should work woth the Homeseer skill, but I cannot confirm it?

        Wim
        -- Wim

        Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
        650 devices ---- 336 events ----- 40 scripts

        Comment


        • #94
          Originally posted by HamsterHauge View Post
          Hi

          If I restart RaspBee, the motion-detector does not goes "online" again, it's online in deCONZ, but keep "Unreachable" in the Jowihue. I have waited 30 minutes to try if it's a timeout.

          Remotes are ok, it's only motion there have this problem.

          After restart Jowihue, it's ok, all online again.

          /Jan
          Jan,

          And before the restart did you try to trigger it? As that should update the status I think? I will check why it is not updating by itself here. Did not see the same here yet. I have one sensor that is on the edge of the house and that is sometimes unreachable too, but I think it updates when it comes back.

          *edit* while reviewing the code I think I found a possibility where the update to reachable could be missed. I will include this in the next beta update.


          Thanks,

          Wim
          Last edited by w.vuyk; September 12th, 2017, 03:52 AM.
          -- Wim

          Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
          650 devices ---- 336 events ----- 40 scripts

          Comment


          • #95
            All,

            The release candidate, 2.0.0.17, has just been published in the beta section. For details, check the first post of this thread.

            Thanks,

            Wim
            -- Wim

            Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
            650 devices ---- 336 events ----- 40 scripts

            Comment


            • #96
              Hi Win.

              Just installed it.

              I had a couple of errors. Unknown devices?

              Regards
              Morten

              sep-14 20:24:29 JowiHue Plugin succesfully started
              sep-14 20:24:29 JowiHue ============================================================ ==================================
              sep-14 20:24:29 JowiHue Device of reporting bridge and light firmware updates is enabled
              sep-14 20:24:29 JowiHue 1 Animations available for use in this plugin
              sep-14 20:24:29 JowiHue 17 Local scenes available for use in the JowiHue plugin
              sep-14 20:24:29 JowiHue 22 Presets available for use in the JowiHue plugin
              sep-14 20:24:29 JowiHue -------------------------------------Plugin info ---------------------------------------------
              sep-14 20:24:29 JowiHue 1 Remote switch(s) found on bridge 'RaspBee-GW' with 1 supporting HS device(s)
              sep-14 20:24:29 JowiHue 3 Groups available on bridge 'RaspBee-GW'
              sep-14 20:24:29 JowiHue 1 lights connected to bridge 'RaspBee-GW'
              sep-14 20:24:29 JowiHue -------------------------------------Bridge info ---------------------------------------------
              sep-14 20:24:29 JowiHue ============================================================ ==================================
              sep-14 20:24:29 JowiHue 2 Generic status sensor found on bridge 'HN hue'
              sep-14 20:24:29 JowiHue 1 Daylight sensor found on bridge 'HN hue'
              sep-14 20:24:29 JowiHue 2 Remote switch(s) found on bridge 'HN hue' with 2 supporting HS device(s)
              sep-14 20:24:29 JowiHue 2 TAP(s) found on bridge 'HN hue' with 2 supporting HS device(s)
              sep-14 20:24:29 JowiHue 9 Groups available on bridge 'HN hue'
              sep-14 20:24:29 JowiHue 7 lights connected to bridge 'HN hue'
              sep-14 20:24:29 JowiHue -------------------------------------Bridge info ---------------------------------------------
              sep-14 20:24:29 JowiHue ============================================================ ==================================
              sep-14 20:24:27 JowiHue Error: (InitDevices):Gathering information from device Legerum skrivebord dimmer 2 ref:889 of type Sensor
              sep-14 20:24:27 JowiHue Error: (InitDevices):Sequence contains no elements
              sep-14 20:24:27 JowiHue Error: (InitDevices):Gathering information from device Vinterhave spisebord dimmer 3 ref:888 of type Sensor
              sep-14 20:24:27 JowiHue Error: (InitDevices):Sequence contains no elements
              sep-14 20:24:19 JowiHue Error: INITDevices: unknown related device found: Bridge update ref:517 with devicetype: Scene
              sep-14 20:24:13 JowiHue Upgrading devices to latest version 10
              sep-14 20:24:12 JowiHue * Connected to bridge RaspBee-GW at 192.168.x.x
              sep-14 20:24:12 JowiHue * Connected to bridge HN hue at 192.168.x.x
              sep-14 20:24:04 JowiHue Refresh bridge RaspBee-GW set to 30 seconds after establishing direct connection
              sep-14 20:24:03 JowiHue socket opened for RaspBee-GW on 192.168.x.x:443
              sep-14 20:24:00 Plug-In Finished initializing plug-in JowiHue
              sep-14 20:24:00 JowiHue Importing lamp and sensor Types
              sep-14 20:24:00 JowiHue InitIO:Plugin basic initialisation done
              sep-14 20:24:00 JowiHue Starting plugin JowiHue 2.0.0.17 on Windows
              sep-14 20:24:00 JowiHue Upgrading database to version 4
              sep-14 20:23:59 Info Plugin JowiHue has connected. IP:127.0.0.1:60268

              Comment


              • #97
                Morten,

                what is the device with reference number 517? The plugin does not work with devicetype scene as far I know?

                Also, does a new start of the plugin show the same errors? IN that case could you do a detailed trace for me to the log and send it to me? Make sure you catch the start of the plugin.

                Thanks,

                Wim
                Last edited by w.vuyk; September 15th, 2017, 03:28 AM. Reason: adding extra question
                -- Wim

                Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                650 devices ---- 336 events ----- 40 scripts

                Comment


                • #98
                  Hi Wim.

                  517 Update for Bridge update Hue BridgeUpdate Hue BridgeUpdate 03-08-2016 17:00:25



                  sep-15 15:20:44 JowiHue Plugin succesfully started
                  sep-15 15:20:44 JowiHue ============================================================ ==================================
                  sep-15 15:20:44 JowiHue Device of reporting bridge and light firmware updates is enabled
                  sep-15 15:20:44 JowiHue 1 Animations available for use in this plugin
                  sep-15 15:20:44 JowiHue 17 Local scenes available for use in the JowiHue plugin
                  sep-15 15:20:44 JowiHue 22 Presets available for use in the JowiHue plugin
                  sep-15 15:20:44 JowiHue -------------------------------------Plugin info ---------------------------------------------
                  sep-15 15:20:44 JowiHue 1 Remote switch(s) found on bridge 'RaspBee-GW' with 1 supporting HS device(s)
                  sep-15 15:20:44 JowiHue 3 Groups available on bridge 'RaspBee-GW'
                  sep-15 15:20:44 JowiHue 1 lights connected to bridge 'RaspBee-GW'
                  sep-15 15:20:44 JowiHue -------------------------------------Bridge info ---------------------------------------------
                  sep-15 15:20:44 JowiHue ============================================================ ==================================
                  sep-15 15:20:44 JowiHue 2 Generic status sensor found on bridge 'HN hue'
                  sep-15 15:20:44 JowiHue 1 Daylight sensor found on bridge 'HN hue'
                  sep-15 15:20:44 JowiHue 2 Remote switch(s) found on bridge 'HN hue' with 2 supporting HS device(s)
                  sep-15 15:20:44 JowiHue 2 TAP(s) found on bridge 'HN hue' with 2 supporting HS device(s)
                  sep-15 15:20:44 JowiHue 9 Groups available on bridge 'HN hue'
                  sep-15 15:20:44 JowiHue 7 lights connected to bridge 'HN hue'
                  sep-15 15:20:44 JowiHue -------------------------------------Bridge info ---------------------------------------------
                  sep-15 15:20:44 JowiHue ============================================================ ==================================
                  sep-15 15:20:44 JowiHue Error: (InitDevices):Gathering information from device Legerum skrivebord dimmer 2 ref:889 of type Sensor
                  sep-15 15:20:44 JowiHue Error: (InitDevices):Sequence contains no elements
                  sep-15 15:20:44 JowiHue Error: (InitDevices):Gathering information from device Vinterhave spisebord dimmer 3 ref:888 of type Sensor
                  sep-15 15:20:44 JowiHue Error: (InitDevices):Sequence contains no elements
                  sep-15 15:20:44 JowiHue Upgrading devices to latest version 10
                  sep-15 15:20:44 JowiHue Error: INITDevices: unknown related device found: Bridge update ref:517 with devicetype: Scene
                  sep-15 15:20:43 JowiHue * Connected to bridge RaspBee-GW at 192.168.0.40
                  sep-15 15:20:43 JowiHue * Connected to bridge HN hue at 192.168.0.12
                  sep-15 15:20:34 JowiHue Refresh bridge RaspBee-GW set to 30 seconds after establishing direct connection
                  sep-15 15:20:33 JowiHue socket opened for RaspBee-GW on 192.168.0.40:443
                  sep-15 15:20:31 Plug-In Finished initializing plug-in JowiHue
                  sep-15 15:20:31 JowiHue InitIO:Plugin basic initialisation done
                  sep-15 15:20:31 JowiHue Starting plugin JowiHue 2.0.0.17 on Windows
                  sep-15 15:20:30 Info Plugin JowiHue has connected. IP:127.0.0.1:55698


                  Not much time tonight unfortunately.

                  Regards
                  Morten

                  Edit: Detailed send via mail on HS forum user.
                  Last edited by mhn; September 15th, 2017, 09:01 AM.

                  Comment


                  • #99
                    Morton,

                    Did get your message indeed. Wil look into it, to see what is happening. Are these two dimmers both on the Philips bridge?

                    Thanks,

                    Wim
                    -- Wim

                    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                    650 devices ---- 336 events ----- 40 scripts

                    Comment


                    • Yes.

                      Comment


                      • Hi

                        Now with the newest deCONZ and newest JowiHue, I can see the IKEA dimmer..

                        Then there is hope for this remote

                        Extra: "buttonevent":####

                        1001 and 1003 when turning clockwise, 1001 1003 1001 1003.... <- wrong, ANTIclockwise
                        2001 and 2003 when turning anticlockwise, 2001 2003 2001 2003.... <- wrong, clockwise

                        When turning fast anticlockwise, then code 1000 (works like off when connected to a bulb)

                        Best regards
                        Jan
                        Attached Files
                        Last edited by HamsterHauge; September 16th, 2017, 11:46 AM. Reason: Extra info

                        Comment


                        • Jan,

                          that is good news. Am a bit surprised to see the status, which should have been a value instead of text. could you post the graphics tab of the device? And then, after that remove all values in this tab and replace it with a new range value, starting at say -3000 to +9000. Then you can play with the device and see which values are coming from dimmers and set events on those. And of couse I would like to know the values you see when using the device.

                          Thanks!

                          Wim
                          -- Wim

                          Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                          650 devices ---- 336 events ----- 40 scripts

                          Comment


                          • Hi

                            Dump of the graphics tab.

                            And after change the values to 1000 - 2005, I can make events

                            1001, 1003 anticlockwise
                            1000 fast anticlockwise (off)
                            2001, 2003 clockwise

                            Sorry, wrong in my prev. message.

                            The values in my prev. mesage, was from the debug-log
                            Attached Files

                            Comment


                            • Jan,

                              Yikes, made an error while creating the new device. Should have read -Low number, +High number. Will change that. I will also add your values to the plugin... only need the modelid, so the plugin will recognise it, could you please check on the Jowihue tab for me, so I have the modelid too?

                              Thanks,

                              Wim
                              -- Wim

                              Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                              650 devices ---- 336 events ----- 40 scripts

                              Comment


                              • Hi

                                As req
                                Attached Files

                                Comment

                                Working...
                                X