Announcement

Collapse
No announcement yet.

Beta JowiHue: adding support for RaspBee and ConBee gateway

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hi Wim.

    My HS updated to HS3 Pro Edition 3.0.0.368 (Windows) yesterday. So I watch it a bit more than usual.

    I noticed JowiHue use a lot of CPU on my i5-4200U?

    Regards
    Morten
    Attached Files

    Comment


    • Originally posted by mhn View Post
      Hi Wim.

      I bought a Conbee and I am a bit in trouble.

      I installed deConz 2.04.74 on my HS PC.

      I can browse it on port 8090. However I cannot get it registered in JowiHue.

      By pressing "Unlock" and starting a scan for Bridge JowiHue finds it.

      sep-30 18:32:42 JowiHue ------------------------------------------NEW Bridge ---------------------------------------
      sep-30 18:32:42 JowiHue ============================================================ ================================
      sep-30 18:32:42 JowiHue Please register this bridge in the configuration page
      sep-30 18:32:42 JowiHue Info: Unregistered bridge found at IP address 192.168.x.x
      sep-30 18:32:42 JowiHue ============================================================ ================================
      sep-30 18:32:40 JowiHue Pressed button for immediate scan for bridges - scanning started

      I have to refresh the HS webpage to get a "Register Bridge" button.

      But now I get in trouble. I press "Unlock" on deConz and "Register Bridge" on JowiHue but it never gets registered.

      Regards
      Morten
      Morten,

      Did you preconfigure the deCONZ for the ConBee to act as coordinator with a different network ID? Check your settings and rejoin the network after changes. I expect you are still configured as router, which will not work for the plugin.
      I tested this with the situation when it came available. Will check here also to see if it still works.

      Thanks,

      Wim
      -- Wim

      Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
      650 devices ---- 336 events ----- 40 scripts

      Comment


      • Originally posted by mhn View Post
        Hi Wim.

        My HS updated to HS3 Pro Edition 3.0.0.368 (Windows) yesterday. So I watch it a bit more than usual.

        I noticed JowiHue use a lot of CPU on my i5-4200U?

        Regards
        Morten
        Morten,

        I am still keeping my distance from the 3.0.0.368 release as I am seeing to many remarks on CPU usage. When I look at your HS3 process I really start to worry. Here on a Zotac PICO (1.68 Ghz only) machine with Windows 10, HS3 3.0.0.357 installed I see HS3 at 6 to 18 procent.
        JowiHue is then using 0 to 6 percent. JowiHue in the beta is using a lot less CPU then the release version here. It will drop even more once you lower the refreshrate for Philips bridges as no sensors are on it anymore.

        How were these values on the last HS3 release?


        Wim
        Last edited by w.vuyk; October 1st, 2017, 03:36 AM.
        -- Wim

        Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
        650 devices ---- 336 events ----- 40 scripts

        Comment


        • Morten,

          Here after setting the ConBee/deCONZ to coordinator registration works as expected. If it still won't work for you, could you send me a detailed log - from start of the plugin and the registration process (including refresh of the page?)

          Thanks,

          Wim
          -- Wim

          Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
          650 devices ---- 336 events ----- 40 scripts

          Comment


          • Originally posted by w.vuyk View Post
            Morten,

            I am still keeping my distance from the 3.0.0.368 release as I am seeing to many remarks on CPU usage. When I look at your HS3 process I really start to worry. Here on a Zotac PICO (1.68 Ghz only) machine with Windows 10, HS3 3.0.0.357 installed I see HS3 at 6 to 18 procent.
            JowiHue is then using 0 to 6 percent. JowiHue in the beta is using a lot less CPU then the release version here. It will drop even more once you lower the refreshrate for Philips bridges as no sensors are on it anymore.

            How were these values on the last HS3 release?


            Wim
            Hi Wim.

            Unfortunally I don't know what it was before the upgrade.

            Regards
            Morten

            Comment


            • Hi Wim.

              My deCONZ/ConBee is Coordinator.

              I am not sure about the Network ID? Where do I find that?

              Other settings that might say something:

              Predefined PAN ID

              Security Mode: High - No MAster but TC Link Key

              Regards
              Morten

              Comment


              • Hi Wim.

                I tried to diable JowiHue. Now HS goes to 3,4% from around 40%.

                Sorry to say but somethings not good with JowiHue RC and .368 here.

                Regards
                Morten
                Attached Files

                Comment


                • Enabling again and it's good.

                  Maybe my Bridge Including problems where hanging?
                  Attached Files

                  Comment


                  • Morten,

                    That is good news for now. Seems something triggered both the plugin and HS3. No idea what, just keep an eye on it

                    I will try to gather some info on the coordinator here, there are some distinct settings that differ between router and coordinator.... I am not sure if they matter in this case....

                    Wim
                    -- Wim

                    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                    650 devices ---- 336 events ----- 40 scripts

                    Comment


                    • Morten,

                      Tested here with an initial installation.
                      The interface shows the ConBee is coordinator at initial installation, but that is not true. Once you look in the configuration, you see it is configured as router instead. After configuring the network settings you HAVE to hit Save, and only after that you choose the button Done.
                      After you have changed the settings, you have to press on "Join Network" (if it is already Joined, choose Leave, wait 10 seconds and press Join again).

                      Check the image for the settings to notice - Network ID should not be the same as the other deCONZ gateway. Let me know f this works for you?

                      Thanks,

                      Wim
                      Attached Files
                      -- Wim

                      Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                      650 devices ---- 336 events ----- 40 scripts

                      Comment


                      • Hi Wim.

                        Change to router and back - leave and rejoin.

                        No luck and CPU high again.

                        I will send you detailed log om mail.

                        Regards
                        Morten

                        Comment


                        • Wim,

                          this is absolutely wonderful work!

                          The Con-/RaspBee is out of stock (here in Norway), and I am tapping my fingers as I wait for it. I am trying to prepare as much as possible in advance, though. To test, I've installed deCONZ both on a pi and on my main linux server running JowiHue, but without the hardware I'm stuck at this point.

                          Do you know if it is possible to have the deCONZ software running on the main server, but the ConBee connected to a pi, using ser2net to serialize the connection? That way, advantage can be taken of the CPU on the main server, and the radio (ConBee) can be strategically placed?
                          Or is the only way to have to have deCONZ and the Rasp-/ConBee on the same box?

                          Thanks!

                          Comment


                          • Diderik,

                            You got me... I am not much of a tinkerer with the raspbee or Linux here, so I do not really know if this would work of not. It sounds interesting though for others who already have the raspbee but not enough cpu/memory left.


                            I am here using the ready installed raspbee, so that tells something about me there

                            Wim
                            -- Wim

                            Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                            650 devices ---- 336 events ----- 40 scripts

                            Comment


                            • Thanks, Wim!

                              I'll see if I can sort this out when I receive my ConBee. Hopefully soon...

                              Comment


                              • Diderik,

                                Keep us posted here, I am guessing others might want to know too here

                                Wim
                                -- Wim

                                Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                                650 devices ---- 336 events ----- 40 scripts

                                Comment

                                Working...
                                X