Announcement

Collapse
No announcement yet.

Xiaomi ZigBee devices Con-/RaspBee

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Xiaomi ZigBee devices Con-/RaspBee

    I just received the Xiaomi Cube and Xiaomi Aqara Wireless Double Switch to test with ConBee/JowiHue. I was not able to add any of them to the deCONZ web interface, but the Cube shows up in JowiHue (and seems to work). The wireless double switch neither shows up in the deCONZ web interface nor in JowiHue.

    This is the switch: https://www.aliexpress.com/item/Xiaomi-Smart-home-Aqara-Smart-Light-Control-ZiGBee-Wireless-Key-switch-and-Wall-Switch-Via-Smarphone/32761798246.html?spm=a2g0s.9042311.0.0.AaUyQ7

    Doing some googling, I am not sure the switch is supported? Is it? Any plans?
    The switch seems very nice. I actually broke one of the plastic knobs one of the several times I reassembled it after removing the battery, but I would get another one if it it actually is, or will be supported.

  • #2
    Diderik,

    The cube is supported, am using it here. Adapted it for my grandchildren.. when they shake the cube the Roomba will either start or go home

    When they double tap a side, one of the lights will go on and a voice will tell which light they control. If they twist the cube light will go up or down, depening on the rotation they do. And if they move the cube, the light will start a color loop.... All moves are guided by voice

    They are playing a lot with it and are teasing us with it

    As for the Xiaomi aqara, there is hope deCONZ might support it. Check this github selection. It seems the developer is waiting for his test device - or he is just busy with all the other stuff - lots is still on the way....

    Wim
    -- Wim

    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
    650 devices ---- 336 events ----- 40 scripts

    Comment


    • #3
      Thanks, a lot Wim!

      I'll make sure to keep track of that thread, and waiting for the switch, I'll keep playing with the Cube.

      Comment


      • #4
        This is perfect.

        Just ordered some Cubes. They sounds like a fun way for the kids to control stuff.

        Comment


        • #5
          I ordered a cube and a double switch and a temp sensor.

          Comment


          • #6
            Bill,

            The extra sensors might not work yet out of the box - or maybe it does as I had some preperations done but without the possibilities to test

            I guess if they do not work nice, just mail me with details so we can make them work ok?

            Thanks,

            Wim
            -- Wim

            Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
            650 devices ---- 336 events ----- 40 scripts

            Comment


            • #7
              Edit: Forget my question. :-|

              JowiHue see the Cube. But I cannot see it in deCONZ. Strange.


              I just got my Xiaomi Cube. But I can not figure out how to add it to RaspBee.

              Help? :-)

              Regards
              Morten
              Last edited by mhn; November 17th, 2017, 09:48 AM.

              Comment


              • #8
                *trying to forget*
                -- Wim

                Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                650 devices ---- 336 events ----- 40 scripts

                Comment


                • #9
                  Just a quick follow up on this. I read somewhere that the Aqara switch is now supported. I have updated to deCONZ beta *.90 and the latest JowiHue, and I was able to add the switch without any problems.
                  As far as I can tell, it reports three values: button 1, button 2 and both buttons pressed simultaneously.

                  Comment


                  • #10
                    I got the cube and the switch. I can't get either one to work. deCONZ finds them, but never opens up the second circle with the clusters. I followed the setup instructions for the switch on github. I've tried "add senesors" from both the beta webapp and JowiHue. I'm running the latest deCONZ (.92). Any suggestions?

                    Comment


                    • #11
                      Bill,

                      I have the cube only until now. I remember it was a bit of a hassle to get all the info in deCONZ. I needed to shake the cube for quite some time before deCONZ could complete the device and before it was sent through the REST API to the plugin.
                      don't know about the switch, but I assume it will be the same, keep waking the battery devices until deCONZ has the info it needs. If you do not do this, the battery device will try to go to sleep soon for saving battery time

                      Wim
                      -- Wim

                      Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                      650 devices ---- 336 events ----- 40 scripts

                      Comment


                      • #12
                        Wim,

                        I've spent hours trying to get the switch and the cube to work. I am more than tired of clicking and shaking.

                        I did see one comment that suggested that the sensor connecting to a light rather than to the gateway was a possible issue. So that means removing power from all my lights (and hope they come back without a lot of work like the last power failure I had). I will try that and if it doesn't work I'm giving up. As interesting as the cube is, and as nice as the switch looks, I don't have time to continue to mess around when I have other working solutions available to me.

                        Bill

                        Comment


                        • #13
                          Bill,

                          Resetting all the bulbs is not fun, use it only as a last resort, for sure if you moved all the hardwired switched away I was advised a few times to reset all too and it made me crawl along all lights I have and having to reset the mains too. I discovered that a few lights only will change a lot once restarted this way, so hold a tablet looking at deconze while working on it, take the most suspicious lights first, as these might act up. Yiu could look at the nearby lights of the cube too as those - if the cube is connected directly - are the most likely candidates.

                          But if you did not do this yet, you could better try this first:

                          If the cube or switch is connected to the light and not to the gateway you should be able to make that conclusion by looking at the deCONZ interface.
                          The device in there that represents the cube for example would show a blinking spot when you shake the cube, if it does not, than the device is no longer connected to the gateway.

                          In that case, delete the device in deconz (I always do a restart to confirm deCONZ does not use/see the device anymore.
                          Then remove the battery from the cube and hold the cube near the raspbee. Open the network, either through the plugin (both scan devices and scan sensors should work) and also put the battery back in place - no need for the link button! The link button will connect to a bulb I think and that is not what we need here.

                          Once you see the cube appearing in deconz, keep shaking the cube regulary. Three to 5 minutes should be really enough. While shaking check the deCONZ inteface to see if the device is also having a blinking dot - this shows they are communicating.

                          I have tested this here with my cube and it worked like a charm... hope this will help you a bit?

                          Wim
                          -- Wim

                          Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                          650 devices ---- 336 events ----- 40 scripts

                          Comment


                          • #14
                            Wim,

                            Not working for me. If I don't push the link button the cube is never discovered, even with constant shaking. And the little blue light on the cube blinks as I move it around, so it should be working. If I push the link button, it sometimes links with a bulb. But there is never any further communication. There is not a colored dot, and not even the one circle. I am going to take a break and try again in a couple of days. Very frustrating.

                            Bill

                            Comment


                            • #15
                              I tried one more time without pushing the link button. Nothing happened. I walked away and came back an hour later and it was linked to a light, the colored dot is black, no blinking, and there is the one circle.

                              Comment

                              Working...
                              X