Announcement

Collapse
No announcement yet.

This is exciting stuff

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • This is exciting stuff

    I just purchased this PI and ordered a R3 along with the raspbee zigbee addon board. I'm fascinated by all the zigbee things that just might play nice with all the z-wave devices.

    I see I have to somehow get deConz up and running. What else???

  • #2
    Make sure you setup deCONZ with the beta version available. There is no release yet that supports the current possiblities. Also make sure you get the firmware version on level, but the Webapp or Phoscon pages should warn you once you log on to that.

    Other then that I would not know. But I have been azy and bought the ready made RaspBee, so I might skipped a few steps in preperation of course.

    Wim
    -- Wim

    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
    650 devices ---- 336 events ----- 40 scripts

    Comment


    • #3
      Thanks for the reply. Yes, I'm buying a CanaKit that should be ready to go and a https://www.amazon.com/gp/product/B0...E0JY4R2Y&psc=1 zigbee addon card.

      The deConz installation will be a bit more of a challenge, but I'll seek out help if (when) I get stuck.

      Comment


      • #4
        I got my Zigbee card from Amazon yesterday. Plugged it into a Raspberry Pi two, and I just installed the Raspbee gateway image onto the Raspberry pi.

        https://www.dresden-elektronik.de/fu...ard-image/?L=1

        Then, I mapped it to a static IP in my router and I was able to add it to Homeseer thru the Jowi plugin.

        I have no Zigbee devices (yet), but it seems to recognize the RaspBee bridge this way.
        HS3 Pro Edition 3.0.0.435 (Windows Server 8.1 on ESXi box)

        Plug-Ins Enabled:
        Z-Wave:,RaspberryIO:,AirplaySpeak:,Ecobee:,
        weatherXML:,JowiHue:,APCUPSD:,PHLocation:,Chromecast:,EasyTr igger:

        Comment


        • #5
          wpiman,

          Make sure you update deCONZ to the latest beta (2.04.99). Also, be aware that if you want to use sensors, you need to have at least one light connected to make the sensors actually work.

          Have fun!!

          Wim
          -- Wim

          Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
          650 devices ---- 336 events ----- 40 scripts

          Comment


          • #6
            I have the zigbee card installed and deCONZ 2.04.99 up and running. deCONZ sees the card. Jowihue sees the RPi since it identified the correct ip address of the RPi.

            So the next thing would be to "Register Bridge". However, clicking the radio box shows "Registering Bridge - Press button on bridge" What button?

            Comment


            • #7
              In the deCONZ web app under "settings" there is an "Unlock Gateway" button.

              Comment


              • #8
                In the deCONZ web app under "settings" there is an "Unlock Gateway" button.
                Houston, we have lift-off.

                Comment


                • #9
                  I couldn't stand the suspense of waiting for the plane from China so I went to HD and bought a Philips Hue RGB Bulb. After clicking Connect a Device the bulb appeared in the WebApp and the Phoscon App where I added it to my first group.

                  In JowiHue I can control the bulb through a myriad of colors, brightnesses and saturation though it's not easy to follow which slider does what. But it does work!

                  Could the Phoscon and JowiHue possibly conflict if both are up and running? Should I only keep deCONZ active?

                  Comment


                  • #10
                    Racefern,

                    for a color bulb from Philips there will be 4 devices. The main device being the on/off device, where you can dim the the light. There is a Hue device, that is controlling the color. This deivce works in close harmony with the saturation device. With the saturation device you can control the color strength of the Hue setting, where 1 is lightest (whites) and 254 most saturated (strongest saturated color).
                    Aside from these device you have the CT device, where you can set the colortemperature of the bulb (whites) wich you can use to change from warm white to cold whites.

                    As for combining the Philips bridge and the deCONZ gateways, you can use any combination in any number without issues for the plugin. So if you'd like to use two Philips Hue bridges with three Raspbee/Conbee combination, it should just work. No issues as long you realise that each geteway needs at least one light to function properly with sensors.
                    Also you can use an app or phoscon to change the settings, the plugin should just update with the new settings.

                    Wim
                    -- Wim

                    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                    650 devices ---- 336 events ----- 40 scripts

                    Comment


                    • #11
                      I'll try wrapping my head around it. I guess part of what's confusing is the group. If I want another light in the same room to have a different hue, do I need to have it in a different group? It seems whatever I do in any of the three devices, changes the others the same. I don't have any zigbee gateways other than the raspberry addon from dresden.

                      It's also confusing that color selection is decimal for Phoscon and hex for JowiHue. The range numbers are also different.
                      Attached Files
                      Last edited by racerfern; January 16th, 2018, 08:57 PM. Reason: add

                      Comment


                      • #12
                        Aside from the group control, you also can control the bulb itself (the devices in the bottom of your image), so if you have more then one bulb in a group (which is normal) you can control each bulb individually for brightness or color.
                        You do not need to control the group devices, but you can.

                        As for setting the light color, if you change the hue, you can do this by setting the decimal value (slider or event) as well as hex. Range values do not differ internally, but is depending on the settings in the plugin (linke dimming values as percentage or range 1 to 254? Or showing the CT as myred or Kelvin?)

                        You should be able to adjust it to your needs.

                        Wim
                        -- Wim

                        Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                        650 devices ---- 336 events ----- 40 scripts

                        Comment


                        • #13
                          I've simplified my setup, just one zigbee controller and no grouping so I can try and wrap my head around the color controls.

                          The issue is using the slide control, I moved and picked the "red". Then I clicked OK. The light goes to red but the status of the light shows something else. So I have to go into the other room to confirm if it changed or not.

                          Looking at the device you would never know. The upper picture is what I selected and the bottom picture is what is displayed on the device screen. It changes to the bottom picture by itself after just a couple of seconds.

                          Help please.
                          Attached Files

                          Comment


                          • #14
                            To put it another way, clicking red on the JowiHue > Creativity> Presets tab, yields the red bulb but the device shows differently.
                            Attached Files

                            Comment


                            • #15
                              The colorpicker has changed in the HS3 beta. In the current production version of HS3, the colorpicker is always of value #FFFFFF (white). Now it seems HS3 is doing an estimation based on one value only.

                              The RGB values of the Zigbee devices are calculated from the combination brightness, Hue and saturation. There is no way HS3 can estimate that color correctly. So please ignore the color on the device utility page as it will not be correct ever? I will ask HST to remove that color from the beta or let the plugin set the color, there is no way HS3 can estimate it.

                              Wim
                              Last edited by w.vuyk; January 27th, 2018, 04:33 AM.
                              -- Wim

                              Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                              650 devices ---- 336 events ----- 40 scripts

                              Comment

                              Working...
                              X