Announcement

Collapse
No announcement yet.

Dim lights with V3 api

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • vbhoj74
    replied
    Hi Travis, I'm facing a similar issue, I have a virtual level switch to send IR commands to my AC, this is now broken. If I sent a single range to Dim, it works but is not accurate, say of I ask to turn the switch to 25, it turns to 26. Since I'm controlling temperature, I need it to be precise.

    Similarly, I have other switches linked to Alexa routines, which helps me trigger events, these r now broken too.

    Leave a comment:


  • Daweeze
    replied
    Update: There can be only Single Value or Range Value that has a Control Use of "Dim" per device. I didn't need my custom Single Value Dim entries to be "Dim" to perform the function and I set them to "Not Specified" per Wade's recommendation and all is well with my dimming and events.

    -Travis

    Leave a comment:


  • Daweeze
    replied
    Originally posted by ldplusse View Post
    Alexa is still having lots of trouble with my lights.
    But there is also problems with z-waves dimmers.
    So dont think the problem lies at the Jowihue plugin.

    The Alexa app can only turn lights on/off, dim does not work.
    FYI, my experience with this in troubleshooting a similar issue with the v3 API my problem is that I setup multiple DIM assignments for my lighting. One was a range (1-99) and two were single value (33 and 66). v2 was fine with this but v3 doesn't like it. If you have multiple DIM Control Use assignments, try enabling only the one with the range. It worked for me and dimming was restored with V3 but broke the reason I was doing what I was doing so I am waiting for HS to comment before I remove all of my custom DIM Control entries.

    -Travis

    Leave a comment:


  • w.vuyk
    replied
    Alright, then I am back in my cave for a bit.
    Rich has replied and the only item needed would be the ControlUse part in the value graphics, wich is set for the JowiHue devices correctly. Only if a light is NOT dimmable we have to set the islight attribute, which notifies Alexa to control this device if a command for all lights is given.

    So far I think the plugin has the correct settings to enable the dim option for alexa. But I will keep an eye on how things go

    Thanks,

    Wim

    Leave a comment:


  • ldplusse
    replied
    Alexa is still having lots of trouble with my lights.
    But there is also problems with z-waves dimmers.
    So dont think the problem lies at the Jowihue plugin.

    The Alexa app can only turn lights on/off, dim does not work.

    Leave a comment:


  • ldplusse
    replied
    Now the 'Is dimmable' is checked.

    Leave a comment:


  • w.vuyk
    replied
    Lars,

    this option sets the isdimmable option for the devices. But I think that you need to restart the amazon skill (or HS3) after that to make it effective. As I understand the options are only read during startup (of the skill?)

    Wim

    Leave a comment:


  • ldplusse
    replied
    I am not sure what you ask for.
    I have tryed enabling the can_dim.

    If i control lights from the Alexa app, i cannot control DIM.
    It also gives alot of 'Server is unresponsive' alerts.
    But it can control them with on/off.

    Leave a comment:


  • w.vuyk
    replied
    Lars,

    I found where I enabled the function of isdimmable. You can set it on the first tab of the configuration screen of the plugin.
    Almost forgot it is there!

    Could you test and set this option? than we'll know if this is sufficient. Would like to know also how the "is light" is influencing your repsonses.

    Wim
    Attached Files

    Leave a comment:


  • w.vuyk
    replied
    I have send Rich a mail to see if he has any official updates for the developers. For me this is too much of a guessing game, so I wait for his answers here.

    Wim

    Leave a comment:


  • ldplusse
    replied
    The 'IsDimmabe' option is very much in use by HST. They have said that on the forum.
    But they have stated that if a light is operated by a on/off swicth, it is NOT recognised as a light automatic. Therefore they have made the 'Is Light' switch option in the beta.

    All these changes is because of the new V3 Alexa skill called 'HomeSeer SmartHome'.

    Leave a comment:


  • w.vuyk
    replied
    The is light option is not present here, so I am guessing HST has been changing things in this area. Maybe they just disable the isdimmable by default now?

    Sad part in this that documentation is not updated yet by HST. Even worse, there is a developer mailing list, so HST could have warned all beforehand for the changes that are coming. Guess that is a missed chance?

    We will have to wait for the updates coming from HST then.

    Wim

    Leave a comment:


  • ldplusse
    replied

    Leave a comment:


  • w.vuyk
    replied
    On second check I still have a tradfri light here and it is set correctly:
    Attached Files

    Leave a comment:


  • w.vuyk
    replied
    Lars,

    What type of light is this? as isdimmable should have been enabled. I have it here on my philips bulbs... Maybe I missed it for the tradfri?

    Wim

    Leave a comment:

Working...
X