Announcement

Collapse
No announcement yet.

JowiHue crashing HS3?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • w.vuyk
    replied
    Like I said, HS3 was closing. It is hard to guess from here what is happening on your system. Glad you found it

    Wim

    Leave a comment:


  • ttantalol
    replied
    Originally posted by w.vuyk View Post
    Hi,

    this has been asked before in this forum. If you check the Windows logs, you'll see that HS3 goes down ate first and is causing the JowiHue plugin to close also.

    But that is a timing issue with that and a fault occurs during the close down of the plugin.
    This line:

    Code:
    at HSPI_JowiHue.HueTools+_Closure$__._Lambda$__R75-3(System.Object)
    Shows that the plugin is in close down process when the error occurs. Check why HS3 is closing down?

    Wim
    Why would this be the only plugin error in windows events?
    There is no hs3 error reported like you said.
    I'm confused as to what's going on here please explain !

    Task scheduler was set to stop hs3 after 3 days .
    That explains why hs3 was not in error.
    Sorry for the mix up.
    Last edited by ttantalol; February 24th, 2018, 01:37 PM. Reason: found answer on different thread

    Leave a comment:


  • ttantalol
    replied
    Originally posted by Michelob View Post
    Hello,

    A quick Google search with

    assembly_nativeimages_v4.0.30319_32

    that is mentioned in your message as "Faulting module path", gives this :

    http://www.greatis.com/appdata/d/Win...319_32.exe.htm

    I don't know if this is relevant, but be careful. You could have some trojan in your computer.
    There is no such file in my computer ,but thanks for the warning.

    Leave a comment:


  • w.vuyk
    replied
    Hi,

    this has been asked before in this forum. If you check the Windows logs, you'll see that HS3 goes down ate first and is causing the JowiHue plugin to close also.

    But that is a timing issue with that and a fault occurs during the close down of the plugin.
    This line:

    Code:
    at HSPI_JowiHue.HueTools+_Closure$__._Lambda$__R75-3(System.Object)
    Shows that the plugin is in close down process when the error occurs. Check why HS3 is closing down?

    Wim

    Leave a comment:


  • Michelob
    replied
    Hello,

    A quick Google search with

    assembly_nativeimages_v4.0.30319_32

    that is mentioned in your message as "Faulting module path", gives this :

    http://www.greatis.com/appdata/d/Win...319_32.exe.htm

    I don't know if this is relevant, but be careful. You could have some trojan in your computer.

    Leave a comment:


  • ttantalol
    replied
    Application: HSPI_JowiHue.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: System.NullReferenceException
    at System.Runtime.Remoting.Messaging.LogicalCallContext.Propaga teIncomingHeadersToCallContext(System.Runtime.Remoting.Messa ging.IMessage)
    at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(Syst em.Runtime.Remoting.Proxies.MessageData ByRef, Int32)
    at HomeSeerAPI.IHSApplication.WriteLog(System.String, System.String)
    at HSPI_JowiHue.utils.Log(System.String, LogLevel)
    at HSPI_JowiHue.HueTools.UpdateStatusTimer()
    at HSPI_JowiHue.HueTools+_Closure$__._Lambda$__R75-3(System.Object)
    at System.Threading.TimerQueueTimer.CallCallbackInContext(Syste m.Object)
    at System.Threading.ExecutionContext.RunInternal(System.Threadi ng.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
    at System.Threading.ExecutionContext.Run(System.Threading.Execu tionContext, System.Threading.ContextCallback, System.Object, Boolean)
    at System.Threading.TimerQueueTimer.CallCallback()
    at System.Threading.TimerQueueTimer.Fire()
    at System.Threading.TimerQueue.FireNextTimers()
    at System.Threading.TimerQueue.AppDomainTimerCallback()


    Faulting application name: HSPI_JowiHue.exe, version: 2.0.1.6, time stamp: 0x5a25aa35
    Faulting module name: mscorlib.ni.dll, version: 4.7.2633.0, time stamp: 0x5a4ed383
    Exception code: 0xc0000005
    Fault offset: 0x003b2352
    Faulting process id: 0x2690
    Faulting application start time: 0x01d3aaaf8ada191d
    Faulting application path: C:\Program Files\HomeSeer HS3\HSPI_JowiHue.exe
    Faulting module path: C:\WINDOWS\assembly\NativeImages_v4.0.30319_32\mscorlib\7a53 e85a72080284c5b5cd703dd282cb\mscorlib.ni.dll
    Report Id: 09c21511-493f-44c3-93d8-05a9a8e5a0a5
    Faulting package full name:
    Faulting package-relative application ID:

    Any thoughts on this?

    Leave a comment:


  • anstosa
    replied
    Too early to tell. It's taken about 24 hours to crash in the past.

    Thank you for your help!

    Leave a comment:


  • w.vuyk
    replied
    And the upgrades did not help?
    From here I cannot see the issue either. My best advice is to monitor both memory and CPU and keep an eye on the beta threads.

    Wim

    Leave a comment:


  • anstosa
    replied
    I was having the crash problems on the stable build as well. Only upgraded to the beta at the instruction of HS support.

    I've tried upgrading Z-Wave and JowiHue to beta as well to see what happens

    Leave a comment:


  • w.vuyk
    replied
    anstosa,

    I think you have a high CPU issue maybe? As the system clock is changing several times in the part of log you posted:

    "System clock changed from: 1/22/2018 5:19:44 PM to: 1/22/2018 5:19:46 PM|(System)_22-Jan-2018 08:48:25.3068_Scheduler Timer"

    The version HS3 you are running is beta and one of the issues with the beta HS3 is high CPU on Linux systems. You should have a look at this thread: https://forums.homeseer.com/showthread.php?t=191461. Hopefully it will put you on track on what is happening there?

    The JowiHue plugin is also complaining about the speed according to these lines:

    "Warning: Bridge Philips hue is slow in responding. JowiHue temporary changed Refreshrate to 9 seconds for this bridge"


    So I do think you need to look what is consuming the CPU and maybe even memory? I doubt that the plugin is bringing down HS3, it will be the other way around sooner.

    Wim

    Leave a comment:


  • anstosa
    started a topic JowiHue crashing HS3?

    JowiHue crashing HS3?

    I'm new to the platform so I might be missing something but HS3 is crashing and I'm trying to figure out why. As far as I can tell looking looking at the sqllite logs DB, the last logs before it crashed were as follows:
    Code:
    2018-01-22 17:10:29|4413317|Info|Plugin JowiHue with instance:  has disconnected||0|0||147
    2018-01-22 17:10:30|4678|Warning|I/O interface JowiHue is down, executable is not running, restarting ...|Threadpool worker|0|0||148
    2018-01-22 17:10:35|5519442|Info|Plugin JowiHue has connected. IP:127.0.0.1:44135||0|0||149
    2018-01-22 17:10:48|2221355|JowiHue|Starting plugin JowiHue 2.0.1.6 on Linux||0|0||150
    2018-01-22 17:10:50|8883897|JowiHue|InitIO:Plugin basic initialisation done||0|0||151
    2018-01-22 17:10:52|1110670|Warning|I/O interface Pushover 3P is down, executable is not running, restarting ...|Threadpool worker|0|0||152
    2018-01-22 17:10:52|1119204|Warning|I/O interface Pushover 3P is down, executable is not running, restarting ...|Threadpool worker|0|0||153
    2018-01-22 17:10:53|9908358|Error|Error launching plugin: Item has already been added. Key in dictionary: 'Pushover 3P:'  Key being added: 'Pushover 3P:'|Threadpool worker|0|0||154
    2018-01-22 17:12:38|1126916|Z-Wave|Device: <font color='#000080'>Dining Room Chandelier Switch</font> Set to <font color='#008000'>2002</font>||0|0||155
    2018-01-22 17:12:38|3391325|Z-Wave|Device: <font color='#000080'>Dining Room Chandelier Switch</font> Set to <font color='#008000'>2001</font>||0|0||156
    2018-01-22 17:12:38|6611915|Z-Wave|Device: <font color='#000080'>Dining Room Chandelier Switch</font> Set to <font color='#008000'>2002</font>||0|0||157
    2018-01-22 17:12:38|8852883|Z-Wave|Device: <font color='#000080'>Kitchen Fridge Light Switch</font> Set to <font color='#008000'>2000</font>||0|0||158
    2018-01-22 17:12:49|5570884|Z-Wave|Device: <font color='#000080'>Kitchen Fridge Light</font> Set to <font color='#008000'>OFF</font>||0|0||159
    2018-01-22 17:14:31|9952712|JowiHue|Warning: Bridge Philips hue is slow in responding. JowiHue temporary changed Refreshrate to 7 seconds for this bridge||0|0||160
    2018-01-22 17:14:31|9954929|JowiHue|Warning: Bridge Philips hue is slow in responding. JowiHue temporary changed Refreshrate to 7 seconds for this bridge||0|0||161
    2018-01-22 17:14:32|3307557|JowiHue|Error: (BridgesFillByDevice):Object reference not set to an instance of an object||0|0||162
    2018-01-22 17:15:13|6630780|JowiHue|Warning: Bridge Philips hue is slow in responding. JowiHue temporary changed Refreshrate to 9 seconds for this bridge||0|0||163
    2018-01-22 17:15:53|9910586|System|System clock changed from: 1/22/2018 5:15:43 PM to: 1/22/2018 5:15:45 PM|(System)_22-Jan-2018 08:48:25.3068_Scheduler Timer|0|0||164
    2018-01-22 17:16:34|9926619|JowiHue|Warning: Bridge Philips hue is slow in responding. JowiHue temporary changed Refreshrate to 12 seconds for this bridge||0|0||165
    2018-01-22 17:18:15|1128932|JowiHue|Warning: Bridge Philips hue is slow in responding. JowiHue temporary changed Refreshrate to 15 seconds for this bridge||0|0||166
    2018-01-22 17:19:58|4445989|System|System clock changed from: 1/22/2018 5:19:44 PM to: 1/22/2018 5:19:46 PM|(System)_22-Jan-2018 08:48:25.3068_Scheduler Timer|0|0||167
    2018-01-22 17:20:06|2291030|JowiHue|Warning: Bridge Philips hue is slow in responding. JowiHue temporary changed Refreshrate to 18 seconds for this bridge||0|0||168
    System info:
    Code:
    Current Date/Time: 1/22/2018 6:46:36 PM
    HomeSeer Version: HS3 Standard Edition 3.0.0.402
    Linux version: Linux hometrollerSEL 3.16.0-031600-generic #201408031935 SMP Sun Aug 3 23:56:17 UTC 2014 i686 i686 i686 GNU/Linux System Uptime: 0 Days 0 Hours 5 Minutes 17 Seconds
    IP Address: 192.168.14.2
    Number of Devices: 189
    Number of Events: 23
    Available Threads: 199
    HSTouch Enabled: True
    Event Threads: 0
    Event Trigger Eval Queue: 0
    Event Trigger Priority Eval Queue: 0
    Device Exec Queue: 0
    HSTouch Event Queue: 0
    Email Send Queue: 0
    Anti Virus Installed: 
    
    Enabled Plug-Ins
    2.0.50.0: BLBackup
    3.0.0.42: EasyTrigger
    2.0.1.6: JowiHue
    3.0.0.28: Nest
    3.0.1.109: PHLocation
    0.0.0.35: Pushover 3P
    3.0.1.130: Z-Wave
    Any ideas for further debugging steps?
Working...
X