Announcement

Collapse
No announcement yet.

New PC - big mess

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • New PC - big mess

    Hello,

    I changed my station yesterday. A new fanless PC instead of the old one.

    Everything went ok about Homeseer and Z-Wave plugin, using export/import config. Easy, quick, simple. Not any shadow in the process.

    About Jowihue, well that's not the same kind of thing.

    There's now not any sensor or switch anymore. I got new lights and I was obliged to erase old ones and rename new ones. I got most of my sensor appearing in deCONZ (but all my names disappeared), but none in webapp, Phoscon, nor Jowihue.

    I don't understand. Who owns the database here ? Jowihue as I thought ??? Or deCONZ ? or anything else ?

    Why things did get great with the Z-wave plugin, but not with Jowihue ?

    Should I have saved some configuration file into deCONZ before changing my hardware ?

    Why isn't it written somewhere that things can go wrong in such a case, some kind of warning before people change their computer ?

    Please, if someone here has an idea about this issue, well he will got my eternal devotion.

    Thank you,

    Michel


    EDIT : I imported again the config. Of course both all my sensors and switches came back. But not anymore in deCONZ, even not the lights that had come back the first time.

    And if I trun off/turn on Jowihue, then, and this is the precise moment where it happens, all the sensors and switches have disappeared.
    Last edited by Michelob; January 28th, 2018, 04:29 AM.

  • #2
    Michel,

    Sorry to hear the difficulties you found here.
    Did you use a ConBee on the old machine? On Windows?

    If you did, yes there is some database in the installation of deCONZ. So far I have not experimented with moving deCONZ to another machine. The plugin is checking on the uniqueid's coming from deCONZ and it is very well possible that many of those id's are created by deCONZ and stored in the database.
    But again, never tested it here.

    Is it possible to reach for the old deCONZ installation and move files over to the new installation (make backups of both old and new installations!)? I am not sure if this will work though as I have read somewhere that a new deCONZ installation is somehow encoded to prevent a simple copy.



    Wim
    -- Wim

    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
    650 devices ---- 336 events ----- 40 scripts

    Comment


    • #3
      Hello Wim,

      Thanks for your reply.

      I tried the whole process a second time (old PC -> config -> new PC after a clean up) but this gave the same issue.

      So I had no choice. I started from scratch, resetting my Conbee from the Phoscon app (which hopefully propose this service).

      I lost a lot of time, but hopefully my config is still a tiny one before bigger installation.

      So, I think it's VERY important that this misadventure be profitable to other users :

      Take care : if you move from one PC to another one, things are not simple at all regarding Conbee and Jowihue.

      I had a lot of mismatch errors, typical from database conflicts. I can't imagine what could be the consequences if you got 200 devices in your system. This could represent a week to settle things back.

      So be really careful.

      Michel

      Comment


      • #4
        Finishing now to reset every sensors and switches in my new system. Lot of time.

        Things are globally ok. They are still some strange things like grouped devices about some nodes, but separate about other ones. Anyway, now I'm used to this.

        There's still an issue that I can't solve :

        There are only 3 bulbs that "accepted" to be part of the new Jowihue+HS. But they are 4 more correctly shown as routers in deCONZ.

        I can't find the way to tell Jowihue to get those 4 bulbs. I resetted them a lot, and tried to scan by all the possible ways, but no way. Jowihue is still blind.

        Would you have an idea ?

        Thank you

        Michel

        Comment


        • #5
          I deactivated/reactivated Jowihue and suddenly all the bulbs appeared in the device list.

          I have to confess that I don't understand wow things work, but the most important is that, finally, things work.

          For my personnal information, Wim, could you in a few words, tell me how is designed the Jowihue architecture ? Not the code, I could'nt understand. But there are many instances (HS, JW, Phoscon, webbapp, Rest API, deCONZ), well, that's a lot of things ! I'd be very pleased to understand globally how things work, just to do changes in the better way it could.

          Let's take an example. I need to add a lamp. Do I have to add it with Jowihue ? Or with Phoscon,... etc... .? And if I change a name, am I sure it will spread for all these tools ? There are a lot of questions that I will maybe me able to answer by myself if I understand the deep logic.

          And I have another question : am I the lonely guy here to encounteer those kind of issues ?

          Thank you,

          Michel

          Comment


          • #6
            Michel,

            In overall, this plugin supports Philips Hue bridges. This is how the plugin started. The Philips bridge is a bit picky on what it accepts - devicewise - and does not inform the outside world by itself. So the plugin has to ask (polling) over and over to find if something changed.

            Then there is the raspbee and conbee, both use deCONZ as their gateway to the zigbee interface. deCONZ has the advantage of contacting the plugin when something changes (webhook). So the plugin immediatly knows if a sensor triggers, which makes it more responsive.
            On deCONZ there is a plugin active, called the REST API. The REST API is the communication vehicle for the plugin. Both Philips Hue bridge and the REST API communicate the same way with the plugin.

            Then the deCONZ has two webinterfaces for now. One is old, the other will replace the old one, but is now available as beta software with deCONZ. the Webapp is the old interface and will retire soon. best just forget about that interface. Phoscon is the new webinterface and still in development for all the new possiblities. I won't mention the webapp anymore from here on.

            Both web applications communicate with deCONZ in the same manner as the plugin, through the REST API.

            When you add a new light you can really choose how you want to do this, through Phoscon or with the plugin's configuration page. Once all is stable you should not need to know more from Phoscon other then that you need it for the button to let the plugin join deCONZ.

            I hope this will give you a global picture how things are working around this plugin now?

            I know we are having a bumpy ride with the beta's in the past months and I have been trying to help as much I can for the issues that occured. I think that after this beta is stable (working on one last issue with OSRAM bulbs) we will arrive in stable waters, where I will try to improve smaller bits, like the stability when deCONZ moves. So far I only had time to iron out some ripples there

            Wim
            Last edited by w.vuyk; February 2nd, 2018, 10:04 AM.
            -- Wim

            Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
            650 devices ---- 336 events ----- 40 scripts

            Comment


            • #7
              Yes Wim, thank you very very very much for that explanation. Now I see the whole picture.

              Thanks again.

              Michel

              Comment


              • #8
                Michel,

                To late for your issues you have had, but for the future, I have emulated your issues here and was able to see what you experienced before. Quite a mess indeed

                I was able to solve them all, as far it is involving the plugin. I did not test moving deCONZ as I did not have time for it and it is also something dresden electronics will have to look into.
                but doubling devices, not discovering the gateway has been moved and not working sensors and lights before a fresh restart, all these issues have been solved.
                It all came down to the plugin not recognising deCONZ (philips bridge is doing all good still) moving to a different ip correctly.
                This is included in the next beta.

                Thanks!

                Wim
                Last edited by w.vuyk; February 7th, 2018, 04:53 PM.
                -- Wim

                Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
                650 devices ---- 336 events ----- 40 scripts

                Comment


                • #9
                  Hello Wim,

                  Great !

                  Thank you,

                  Michel

                  Comment

                  Working...
                  X