Announcement

Collapse
No announcement yet.

ConBee Warning every 5 minutes

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ConBee Warning every 5 minutes

    Linux HS3 3.0.0.425, JowiHue plug-in 2.0.2.2, deCONZ 2.05.20 on port 8088

    I'm seeing the following every 5 minutes in the log:

    Apr-25 12:45:46 AM JowiHue Warning: Bridge ConBee changed IP from 10.1.2.20:8088 to 127.0.0.1:8088 - Restarting processes for this bridge

    10.1.2.20 is indeed the address of this machine on the local network, but why is it constantly restarting saying that it's changing from the interface address to the localhost address?

  • #2
    Gentzel,

    Are you using a conbee or a raspbee configuration?
    It appears it is finding the deCONZ on local host as well as the network address. The network address should be preferred I guess.

    Is it possible that deCONZ is starting before the network is available?

    Wim
    -- Wim

    Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
    650 devices ---- 336 events ----- 40 scripts

    Comment


    • #3
      I had this warning some time ago. The problem was that the RPi was plugged into the lan and was also on wifi. I disabled wifi on the Rpi and the warning went away.

      I also had a similar warning when I had both a conbee and raspbee installed. I decided to stay with the raspbee but the conbee still showed in Phoscon until I reset everything.

      Comment


      • #4
        It's a ConBee. Everything is on a single machine: ConBee, deCONZ & HS3. No WiFi; the machine is on a wired network.

        I'm using the standard deCONZ systemd startup script (other than overriding "User" and "http-port") but I do see that they don't include an "After" line to force it to start after the network. I'll add that later today and see if it makes any difference.

        Comment


        • #5
          One interesting bit I just noticed is that deCONZ is listening on all interfaces, so it's going to be listening on both the network address and localhost:
          Code:
          root@ha:/home/gentzel# netstat -an | fgrep 8088
          tcp        0      0 0.0.0.0:8088            0.0.0.0:*               LISTEN
          Not sure if there's a way to prevent this. I'll see if the deCONZ docs give any guidance.

          Comment


          • #6
            Found it! I'll try restricting it to the network interface and see if that cleans up the problem.

            https://github.com/dresden-elektroni...gin/issues/444

            Comment


            • #7
              Good to hear! Let me know if this extra parameter works for you?

              Thanks,

              Wim
              -- Wim

              Plugins:RFXCOM, HSTouch Server, Squeezebox, BLGData, Restart, Jon00's Perfmon and Network monitor, WeatherXML, BLBackup, TenScripting, BC4, Pushover, PHLocation, JowiHue, Zwave, Sonos
              650 devices ---- 336 events ----- 40 scripts

              Comment


              • #8
                Specifying --http-listen on the deCONZ command line does indeed solve the problem.

                You may want to consider ignoring the localhost loopback address when scanning for gateways. That would avoid this issue without having to change the default deCONZ configuration. On the other hand, anyone running HS3 & deCONZ on the same box already has to change the deCONZ (or HS3) configuration to change the port, so no big deal to set the listen address at the same time.

                Comment

                Working...
                X